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READ ME FIRST 
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4 

In case you're not familiar with the terminology, 
Read Me First is quite often the name given to a 
computer file that contains important information 
for people to know prior to using an application. 

This section contains some important information to 
help you use this book so we thought we'd start 
with a Read Me First section. 

 

What skills and knowledge 
you will acquire... 

The skills and knowledge acquired in Microsoft Excel 2016 - Using as a 
Database are sufficient to be able to use and operate the software 
effectively. 

What you'll need to know 
before beginning this 
course... 

Microsoft Excel 2016 - Using as a Database assumes little or no 
knowledge of the software. However, it would be beneficial to have a 
general understanding of personal computers and the Windows operating 
system environment. 

 

The objectives of this guide… At the completion of this course you should be able to: 

sort data in a list in a worksheet 

use a variety of data validation techniques 

use a range of find and replace techniques 

filter data in a table 

use advanced filters to analyse data in a list 

apply conditional formatting to ranges in a worksheet 

use a range of text functions 

understand and create simple PivotTables 

construct and operate PivotTables using some of the more 

advanced techniques 

create and edit a PivotChart 

What you get in a chapter... Each chapter begins with a summary page listing the topics covered in 
that chapter. The chapter then consists of single-page topic sheets 
pertaining to the theme of the chapter. 

What you'll need to have 
before commencing this 
course... 

Many of the topics in this learning guide require you to open an existing 
file with data in it. These files can be obtained from your instructor and 

need the product code for this course which is ExcelAsaDataBase. 

As you work through this 
guide… 

It is strongly recommended that you close all open files, if any, prior to 
commencing each new chapter in this learning guide. Each chapter, 
where relevant, has its own set of exercise files and any from a previous 
chapter are no longer required.  

Where to from here... Have a look at the next page which explains how a topic page works, 
ensure that you have access to the exercise files (see above), and you're 
ready to make a start. 
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The majority of this book comprises single-page 
topic sheets. There are two types of topic sheets: 
task and reference. The layout of both is similar 
– an overview at the top, detail in the centre and 

additional reference (optional) material at the 
bottom. Task sheets contain a Try This Yourself 
step-by-step exercise panel in the detail area as 
shown below. 

 
Topic name 

 
General topic overview provides an introduction to the topic 

 
Try This Yourself (Task-based topic sheets) is a detailed step-by-step practice 
exercise for you to work through. In Reference topic sheets this is usually replaced 
by a box with reference information. 

 
In Task topic sheets screen shots and graphics provide a visual clue as to what 
will happen when you work through the Try This Yourself practice exercise. In 
Reference topic sheets the screen shots and graphics are used to visually 
represent information and concepts. 

 
The For Your Reference (optional) element provides a quick summary of the steps 
required to perform a task. These usually only appear in Task-based topic sheets. 

 
The Handy To Know (optional) element provides additional information such as 
alternate ways of accomplishing a task or further information providing handy tips.  

 

1 

2 

3 

4 

5 6 

WORKING WITH TOPIC SHEETS 
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CHAPTER 1 SORTING DATA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of sorting and lists in Excel 

 learn how to sort alphabetical data in a list 

 learn how to sort numbers 

 learn how to sort on more than one column 

 learn how to sort numbered lists 

 learn how to sort a list by rows. 

Microsoft Excel allows you to sort worksheet data alphabetically, 
numerically or chronologically. You can sort your data by columns, 
starting from the highest value working down to the lowest 
(descending), or from the lowest value working up to the highest 
(ascending). Sorting data can help to analyse trends in sales, or 
target areas in business, and also to make comparisons between 
data. 

INFOCUS 
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UNDERSTANDING LISTS 
 

 

 

 

  

 

Microsoft Excel is quite often used to create lists 
– such as lists of customer contacts, lists of items 
in an inventory, lists of employees, lists of 
upcoming events, and the like. To cater for these 

kinds of lists, Microsoft Excel allows you to perform 
sort operations so that all of the data in the list can 
be rearranged in a more desirable and logical 
fashion. 

Lists – The Key to Understanding Sorting 

To understand how Microsoft Excel performs a sorting operation you first need to grasp the concept of a 
list in Microsoft Excel.  

When you make a cell active Excel analyses all of the adjacent cells – up, down, left and right. It 
considers all of the cells around the active cell to be part of a list range as long as the cells contain data. 

So, in Excel, a list is automatically defined as the area around the active cell that contains data. The 
boundary of the list range is defined when an empty cell is encountered. In the example below, the 
active cell is C4. Excel therefore deems the list to be the one bounded by empty cells – in other words, 
the list is made up of all of the non-empty cells. 

The list extends to the left as far as column A, and to the right as far as column G. It doesn’t go up any 
more rows because C3 is an empty cell. It goes down as far as row 23, the last non-empty cell in the 
column. So the list range is automatically defined as A4 to G23. 

You can make any cell in this list the active cell and the list range will be the same. You don’t have to 
select or highlight the range. 

Sorting a List 

Once a list is available to Excel, the data in it can be sorted. The data is usually sorted down a column, 
known in database jargon as a field. Data is sorted alpha-numerically, meaning that alphabetical 
characters are sorted first, and then numbers. If there are only alphabetical characters in it then the list 
will be sorted alphabetically from left to right. If there are only numbers the list will be sorted numerically. 
If there is mixed data the list will be sorted by alphabetical characters and then by numbers. 

Lists can be sorted in ascending order (from lowest to highest) and in descending order (from highest 
to lowest). 
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PERFORMING AN ALPHABETICAL SORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
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e
 Before starting this 

exercise you MUST open 
the file Sorting_1.xlsx… 

 
Click on the Sorting Text 
worksheet tab and spend 
a few moments studying 
the data – it is a list of 
employees 

 
Click in cell C4 to select 
the cell – this is the Last 
Name column of the listing 

 
On the Home tab, click on 
Sort & Filter in the 
Editing group and select 
Sort A to Z 

The data in the list will be 
sorted alphabetically in 
ascending order by last 
name… 

 
Click on Sort & Filter in 
the Editing group again 
and select Sort Z to A to 
sort the data in 
descending order 

 
Repeat the above steps 
and sort the list by 
Position, by Office, and 
finally by E-Mail 

 

5 

The most common use for sorting is to rearrange 
the data in a list in a specific order. A list is 
simply a grouping of data without any empty 
columns or rows. In a list, a single column can 

be sorted by placing the cell pointer anywhere in 
the column that you wish to sort and choosing the 

Sort & Filter command in the Editing group. 

2 

3 

For Your Reference… 

To alphabetically sort data in a list: 

1. Click in the column to sort, then click on the 
Home tab 

2. Click on Sort & Filter in the Editing group 
and select either Sort A to Z to sort in 
ascending order, or Sort Z to A to sort in 
descending order 

Handy to Know… 

 When you choose to sort, Excel searches in 
all directions from the active cell. The end of 
the list is deemed to be the first blank cell 
encountered in all directions: up, down, left 
and right. 

 Excel assumes that the first row of the list 
contains the column heading or field. 
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PERFORMING A NUMERICAL SORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
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Continue using the 
previous file with this 
exercise, or open the file 
Sorting_2.xlsx... 

 
Click in cell A4 which 
represents the start of the 
employee No column 

 
On the Home tab, click on 
Sort & Filter in the 
Editing group and select 
Sort A to Z to sort the 
data in ascending order 

Notice how the list is 
sorted first by letters, then 
numbers… 

 
Click in cell I5 which is the 
start of the Age column – 
these cells store numbers 

 
Click on Sort & Filter in 
the Editing group again 
and select Sort Smallest 
to Largest to sort the data 
from youngest to oldest 

 
Repeat the above steps 
and sort the list by 
Telephone, by Salary 
Level and by Service 

 

3 

Microsoft Excel allows you to sort all kinds of 
data – alphabetic, numeric, dates and mixed. 
When you place the cell pointer in a cell, Excel 
determines the data type in that cell and amends 

the sort commands accordingly. For example, 
when sorting alphabetical data, the command will 
be Sort A to Z, but for numeric data it changes to 

Sort Smallest to Largest. 

2 

For Your Reference… 

To sort a list numerically: 

1. Click in the column to sort 
2. On the Home tab, click on Sort & Filter in 

the Editing group and select either Sort 
Smallest to Largest to sort in ascending 
order or Sort Largest to Smallest to sort in 
descending order 

Handy to Know… 

 If a numeric column contains a formula which 
displays a calculated value, the sort 
operation will be performed on the calculated 
value rather than the formula. 

4 
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SORTING ON MORE THAN ONE COLUMN 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
Sorting_3.xlsx... 

 
Click in cell A4 to 
position the active cell 
within the list 

 
On the Home tab, click 
on Sort & Filter in the 
Editing group and 
select Custom Sort to 
display the Sort dialog 
box 

 
Click on the drop arrow 
for Sort by to display a 
list of the field (column) 
names, then select 
Position 

 
Click on [Add Level] to 
add another level in the 
dialog box 

 
Click on the drop arrow 
for Then by and select 
Last Name 

 
Click on [OK] to display 
the list sorted by 
Position then by Last 
Name 

 

For Your Reference… 

To sort on more than one column: 

1. Click on the Home tab, then click on Sort & 
Filter in the Editing group  

2. Select Custom Sort 

3. Specify the columns to sort the list on 

Excel allows you to select multiple columns to 
sort by, thereby enabling you to analyse data 
according to different categories. Each column is 
sorted in order one at a time. The listing is sorted 

by the first column, then by the second column, and 
so on. For example, a staff listing can be sorted 
first by Position, then by Last Name so that each 
position contains an alphabetical sub-listing. 

2 

5 

Handy to Know… 

 Be careful when sorting large lists that go 
beyond the boundaries of the screen. You 
should ensure that there are no blank rows 
or columns that can result in you omitting 
some of the data. 

6 
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SORTING NUMBERED LISTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
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Continue using the 
previous file with this 
exercise, or open the file 
Sorting_4.xlsx... 

 
Click on the Sorting 
Numbers worksheet tab 
and examine the data 

 
Click in cell C5 which 
represents the first value in 
sales figures for the month 
of February 

 
On the Home tab, click on 
Sort & Filter in the Editing 
group and select Sort 
Smallest to Largest to 
sort the data 

Everything has worked fine 
because the totals at the 
bottom of the list are the 
largest values (being 
totals)… 

 
Click on Sort & Filter in 
the Editing group and 
select Sort Largest to 
Smallest – you now have 
a mess because the Total 
formulas have been sorted 
out of position 

 
Click on Undo in the Quick 
Access Toolbar to undo 
the last sort 

 

For Your Reference… 

To sort a numbered list: 

1. Click in the column to sort 

2. On the Home tab, click on Sort & Filter in 
the Editing group and select either Sort 
Smallest to Largest or Sort Largest to 

Smallest 

Microsoft Excel allows you to sort any kind of 
data in the worksheet and it is smart enough to 
determine the type of sort to perform. Things get 
a little messy however, when there are lists of 

numbers that may also contain subtotals and totals. 
The problem with these sorts is that Excel can’t 
distinguish between your data and the totals – the 
totals therefore also get sorted. 

2 

3 

Handy to Know… 

 If you have totals at the bottom of a list and 
you want to perform a numerical sort without 
including these totals, you can insert a blank 
row of cells between the last number to be 
included in the sort and the totals. This tells 
Excel that the totals are not included in the 
list. 

4 
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SORTING BY ROWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Most of us are used to sorting vertically down a 
column, rearranging data from highest to lowest, 
or lowest to highest. Excel also allows you to sort 
by rows, from left to right. This takes a little more 

care to set up and is fraught with potential 
problems. However, once you have mastered it, 
you will find it handy to use in your worksheets.  

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the 
file Sorting_5.xlsx... 

 
Click in cell B4, hold 
down  and click in 

cell G12 to select the 
range B4:G12 

 
On the Home tab, click 
on Sort & Filter in the 
Editing group and 
select Custom Sort to 
display the Sort dialog 
box 

 
Click on [Options] to 
display the Sort 
Options dialog box 

 
Click on Sort left to 
right, then click on 
[OK] to return to the 
Sort dialog box 

 
Click on the drop arrow 
for Sort by and select 
Row 12 

 
Click on [OK] to see 
the table totals row 
(row 12) sorted from 
lowest to highest 

 

1 

3 

6 

For Your Reference… 

To sort by rows: 

1. On the Home tab, click on Sort & Filter in 
the Editing group, select Custom Sort and 
click on [Options] 

2. Click on Sort left to right, then click on [OK] 

3. Choose the row to sort and click [OK] 

Handy to Know… 

 When sorting by rows, select the cells that 
you want to sort, remembering to include the 
column headings and to exclude the row 
headings and totals column. 
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NOTES: 
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CHAPTER 2 VALIDATING DATA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of data validation 

 learn how to restrict data to a specific number range 

 learn how to test data validation 

 learn how to create an input message 

 learn how to create an error message 

 learn how to create a drop-down list 

 learn how to use formulas as validation criteria 

 learn how to apply circles to invalid data 

 learn how to remove validation circles 

 learn how to copy validation settings. 

Data validation is all about making workbooks as foolproof and as 
user-friendly as possible. The idea is to create workbooks that don’t 
let people make mistakes. 

Data validation is similar to cell formatting in that you apply it to a 
cell. Unlike a format that changes the look of a cell or its contents, 
data validation checks the data being entered into a cell. If the data 
is incorrect, data validation can prevent it from being entered. 

 

INFOCUS 
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UNDERSTANDING DATA VALIDATION 
 

 

 

 

  

 

The aim of data validation is to ensure the 
accuracy of the data that is entered and this can 
be achieved using a range of approaches. You 
can provide information for the user, identify and 

reject incorrect values, display error messages and 
provide a list of valid options that can be entered 
into the cell. The following describes these options 
in more detail. 
 

Validation Criteria 

You can specify the range of values allowed in a cell. If a user attempts to enter a value outside the 
specified range, an error message will display. For example, you could limit the possible entries in a cell 
to numbers between 1 and 12. 

Input Messages & Error Messages 

You can create messages to give specific help about the type and range of data required in a cell. Input 
messages appear when you click on the cell before entering data, while error messages appear when 
the user has entered an invalid number into a cell. You can even create customised error messages to 
provide specific information about the range of values that are valid. 

 

Drop-Down Lists 

Drop-down lists can be attached to cells to provide a list of valid options for a user. This is ideal where 
there is a limited number of possible values for a cell, such as the days of the week. 

Formulas 

As well as being able to set specific limits for values, you can use formulas to create dynamic ranges of 
values. For example, the Today() function can be used to calculate today’s date. As validation criteria, 
this could be used to ensure that a user does not enter a future date in a cell, or to ensure that the date 
is not too far in the past. 

Customised Validation Criteria 

As well as a range of standard validation options, you can build quite sophisticated customised validation 
criteria. 

This is an example of 
an input message 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 11 Chapter 2 - Validating Data 

CREATING A NUMBER RANGE VALIDATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

One of the simplest types of data validation is to 
restrict data to a specific number range. The data 
validation is set so that Excel expects you to type 
a number in the cell, and the number must fall 

between a set minimum and maximum value. Any 
other data, such as text or a number outside of the 
range is rejected. This is ideal for large volumes of 
data entry and helps to reduce the risk of error. 
 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST 
open the file Data 
Validation_1.xlsx... 

 
Ensure that the Payroll 
worksheet is active, 
then click in cell A10 to 
select the cell 

 
Click on the Data tab, 
then click on the top 
half of Data Validation 
in the Data Tools 
group 

This will display the 
Settings tab of the Data 
Validation dialog box… 

 
Click on the drop arrow 
for Allow in Validation 
criteria, then  select 
Whole number 

 
Click in Minimum, then 
type 100 

 
Press , then type 

199 in Maximum 

 
Click on [OK] 

Nothing appears to 
have happened to the 
cell, but the validation 
criteria will control what 
you can type into it 

 

1 

2 

For Your Reference… 

To apply a number range as data validation: 

1. Click on the cell that you want to apply the 
validation to 

2. Click on the Data tab, then click on the top 
half of Data Validation  

3. Select an option in Allow, set the values, 

then click on [OK] 

Handy to Know… 

 The Data Validation dialog box can be used 
to limit the data to any value, to whole 
numbers or to decimals. You can also use it 
to set a maximum and minimum length for 
information entered into a cell, irrespective of 
whether it is text, a value or a formula. This 

setting is called text length. 

5 
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TESTING A VALIDATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Any data validation applied to a worksheet 
should be tested thoroughly before it is 
unleashed on any unsuspecting users. You must 
ensure that it not only prevents or dissuades the 

entry of invalid numbers, but that you have allowed 
for all possible situations. You must also ensure 
that any messages that appear explain clearly how 
to correct the error that has been made. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Data Validation_2.xlsx... 

 
Ensure the Payroll 
worksheet tab is selected 
and cell A10 is active 

 
Type 1, then press  

As this number falls 
outside of the range 
specified for this cell (i.e. 
100 – 199), a message 
box will appear... 

 
Click on [Retry] 

This will select the 
contents of the cell so that 
you can type another 
number... 

 
Type 106, then press  

This time the number is 
within the acceptable 
range, so the message 
box does not reappear 
and the number is 
accepted 

 

2 

3 

4 

For Your Reference… 

To test data validation: 

1. Try entering a range of values within and 
outside of the defined range 

2. If an error message appears, click on [Retry] 

or [Cancel] 

Handy to Know… 

 When  you are  dealing with a cell that has 
validation criteria applied to it be aware that if 
you type text into that cell when it is 
expecting numbers, the same non-specific 
error message will be displayed. 
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CREATING AN INPUT MESSAGE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

An input message is a message that is 
displayed when you click on a cell. This provides 
clear guidance to the user about the values that 
are expected for a cell. It is far more satisfying 

than being faced with a non-specific error message 
and not knowing how to fix the problem. Input 
messages should be used with validation criteria to 
ensure the best possible results. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Data Validation_3.xlsx... 

 
If necessary, click in cell 
A10 to select the cell 

 
Click on the Data tab, 
then click on the top half 
of Data Validation in the 
Data Tools group 

 
Click on the Input 
Message tab of the Data 
Validation dialog box 

 
Click in Title, then type ID 
Codes 

 
Click in Input message, 
then type Please enter a 
value between 100 and 
199. 

 
Click on [OK] 

As cell A10 is still 
selected, the input 
message is displayed 

 

5 

For Your Reference… 

To create an input message: 

1. Click in the cell 

2. Click on the Data tab, then click on the top 
half of Data Validation  

3. Click on the Input Message tab 

4. Complete the fields, then click on [OK] 

Handy to Know… 

 On the Input Message tab of the Data 
Validation dialog box, by clicking on the 
option Show input message when cell is 
selected until it appears without a tick, you 
can disable the input message without 
having to delete it permanently. 

6 
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CREATING AN ERROR MESSAGE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Error messages enable you to replace the 
standard alerts with something more meaningful. 
The message “Please enter a value between 100 
and 199.” indicates that there is an error and 

clearly explains what is required. Users will find it 
much easier to complete their tasks if they know 
exactly what is expected. The three error message 
styles are Stop, Warning and Information. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the 
file Data Validation_4.xlsx... 

 
Click in cell A10 to select the 
cell 

 
Click on the Data tab, click on 
the top half of Data Validation 
in the Data Tools group to 
display the Data Validation 
dialog box, then click on the 
Error Alert tab 

 
Click on the drop arrow for 
Style, then select Information 

Notice that the Stop icon has 
changed to an Information 
icon... 

 
Click in Title, then type Check 
Staff ID 

 
Click in Error message, then 
type Please try again. Staff ID 
must be between 100 and 199. 

 
Click on [OK], then ensure cell 
A10 is still active 

 
Type 45, then press  

Your customised error message 
will appear... 

 
Click on [OK] 

 
Click in cell A10, type 106, then 

press  

 

3 

5 

For Your Reference… 

To create an error message: 

1. Click on the cell then click on the Data tab 

2. Click on the top half of Data Validation, then 
click on the Error Alert tab 

3. Select a Style, complete the Title and Error 

message fields, then click on [OK] 

Handy to Know… 

 Remember, error messages created using 
the Data Validation dialog box, will only 
work if you have specified validation criteria 
for the selected cell. 

7 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 15 Chapter 2 - Validating Data 

CREATING A DROP DOWN LIST 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you have a limited number of possible options 
for a cell, you can create a drop-down list for the 
user to select from. This ensures that the spelling 
of choices is consistent and makes it much easier 

for the user to complete their data entry tasks. Lists 
are created using the Data Validation settings and 
a separate list of items is stored in the workbook. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Data 
Validation_5.xlsx... 

 
Click on the Sources 
worksheet tab, then read the 
list 

The Titles list has been 
entered as a named range. 
We’ll use it for the drop-down 
list... 

 
Click on the Payroll 
worksheet tab, then click in 
cell B10 

 
On the Data tab, click on the 
top half of Data Validation in 
the Data Tools group to 
display the Data Validation 
dialog box, then click on the 
Settings tab 

 
Click on the drop arrow for 
Allow and select List 

 
Click in Source, click on the 
Sources worksheet tab, select 
cells A3 to A7, then click on 
[OK]  

Because cell B10 is selected, 
a drop arrow will appear... 

 
Click on the drop arrow for cell 
B10 to display a list of titles 

 
Click on Mr to select it and 
enter it into the cell 

 

2 

3 

For Your Reference… 

To create a drop-down list: 

1. Type a list of items and click where you want 
the list to appear 

2. Click on the Data tab, then click on the top 
half of Data Validation  

3. On the Settings tab select List in Allow, 

type the list range in Source, click on [OK] 

Handy to Know… 

 When creating a list of items to use in a drop-
down list, you can create a range name for 
the list to make it easier to locate when using 
the Data Validation dialog box. Keeping the 
list on a separate worksheet helps to protect 
it. You could also hide the worksheet with the 
list to better protect it. 

6 
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USING FORMULAS AS VALIDATION CRITERIA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can use fixed values as validation criteria if 
they never change. However, if you need to 
specify a dynamic range, where the values 
change depending on the conditions stated, you 

can use a formula. For example, you may want to 
ensure that the date entered falls within the last 
week. This can be done by using a formula that 
includes a date function as the validation criteria. 
 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Data 
Validation_6.xlsx... 

 
Click on cell E10 to select the 
cell 

 
Click on the Data tab, click on 
the top half of Data Validation 
in the Data Tools group to 
display the Data Validation 
dialog box 

 
Click on the drop arrow for 
Allow and select Date 

 
Click in Start date and type 
=Today()-7 

 
Click in End date and type 
=Today() 

We’ll display an example of the 
date format required, as a 
message... 

 
Click on the Input Message 
tab, then click in Title and type 
Date Hired 

 
Click in Input message and 
type Please type the date as 
dd/mm/yy. 

 
Click on [OK] 

 
Enter tomorrow’s date, then 
press   to test the 

validation, then click on 
[Retry] and enter today’s date 

 

5 

7 

For Your Reference… 

To use formulas as validation criteria: 

1. Click on the cell to apply the validation to 

2. On the Data tab click on the top half of Data 
Validation then click on the Settings tab 

3. Select an option for Allow, then type 
formulas as limits and click on [OK] 

Handy to Know… 

 When using formulas as validation criteria, 
be sure to use error messages to clearly 
explain what is expected in the cell, so that 
the criteria according to the formula are met. 

9 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 17 Chapter 2 - Validating Data 

CIRCLING INVALID DATA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Data validation works when a user enters data 
directly into the cell with validation criteria. Data 
validation does not work, however, if data is 
copied into a cell with validation criteria, or if an 

invalid entry is made as a result of a formula in the 
cell or if it is generated through a macro. Excel can 
identify cells containing invalid data, using red 
circles, to highlight them. 
 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the 
file Data Validation_7.xlsx... 

 
Click on the HR worksheet tab 
to display this worksheet 

Notice the Staff ID for the last 
entry was typed incorrectly, 
where “12” should be “112” – 
let’s copy this entry to a cell with 
data validation... 

 
Click in cell B20 to select the 
cell 

 
Press  +  to copy the cell 

contents, then click on the 
Payroll worksheet tab and click 
in cell A10 

This cell has validation criteria... 

 
Press  +  to paste the 

value into the cell, then press 
 twice to see the cell more 

clearly 

The error message was not 
generated. Let’s use red circles 
to highlight the issues... 

 
On the Data tab click on the 
bottom half of Data Validation 
in the Data Tools group, and 
select Circle Invalid Data 

A red circle indicates the cell 
with invalid data, according to 
the validation criteria applied 

 

3 

For Your Reference… 

To circle invalid data: 

1. Click on the Data tab  

2. Click on the bottom half of Data Validation 
in the Data Tools group 

3. Select Circle Invalid Data  

4 

5 

Handy to Know… 

 If the Excel window is not maximised, you 
might not see the tools on the ribbon in their 
large format, where some tools have a top 
and bottom half. In this instance, the tool will 
appear smaller and display a small drop-
down arrow at the end of the tool name 
(equivalent to the “bottom half”). 
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REMOVING INVALID CIRCLES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Data validation circles enable you to effectively 
audit your worksheets and ensure data integrity. 
Even if invalid data has managed to appear in 
cells containing data validation criteria, data 

circles will highlight the anomaly for you, enabling 
you to address any issues. There are two ways to 
remove invalid data circles: enter valid data into the 
cell or turn the data circles off. 
 

2 
Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Data Validation_8.xlsx... 

 
Ensure that the Payroll 
worksheet is active, then 
click on the Data tab  

 
Click on the bottom half of 
Data Validation and select 
Circle Invalid Data to see 
the circles 

 
Repeat steps 1 and 2 to 
select Clear Validation 
Circles 

All red circles will be 
removed from the 
worksheet. Let’s turn them 
back on and then remove 
an individual validation 
circle... 

 
Repeat step 2 to redisplay 
the invalid data circle 

Let’s remove the circle a 
different way… 

 
Click in cell A10 to select 
the cell with the invalid data 

 
Type 112 and press  

Now that the data is no 
longer invalid, this circle is 
removed 

 
Click in cell E10 and type 
todays date and press   

 

3 

6 

For Your Reference… 

To remove invalid data circles: 

 Type valid data into the cell(s), or 

On the Data tab, click on the bottom half of 
Data Validation and select Clear Validation 

Circles 

Handy to Know… 

 Validation circles are only temporary – they 
are removed if you save or close a 
workbook, but you can activate them again at 
any time. 
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COPYING VALIDATION SETTINGS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Data validation is usually applied to a range of 
cells rather than a single cell. The most 
appropriate way to create data validation is to 
create and test it in a single cell and then apply 

the same validation technique to the rest of the 
cells. The Paste Special dialog box has an option 
specifically designed to copy validation criteria 
created using the Data Validation dialog box. 
 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Data Validation_9.xlsx... 

 
Click on the Payroll 
worksheet tab, then 
select A10:J10 

Cells A10, B10, E10 and 
J10 have validation 
rules applied... 

 
Press  +  to copy 

the range 

 
Select A11:J20 

This is the destination 
range... 

 
Click on the Home tab, 
then click on the bottom 
half of Paste in the 
Clipboard group and 
select Paste Special 

 
Click on Validation in 
Paste to select it 

 
Click on [OK] to paste 
the validations  

 
Type some test 
employee data in row 11 
to test the validation 
rules 

 

5 

For Your Reference… 

To copy data validation: 
1. Select the cells with the data validation, then 

press  +  to copy the contents 

2. Select the destination cells 
3. On the Home tab, click on the bottom half of 

Paste and select Paste Special 

4. Click on Validation and click on [OK]  

Handy to Know… 

 Copying and pasting validations does not 
transfer conditional formatting if applied to 
cells. To copy conditional formatting, copy 
the cell, then select Format in the Paste 
Special dialog box. 

7 
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NOTES: 
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CHAPTER 3 FINDING AND REPLACING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of find and replace operations 

 learn how to find text 

 learn how to find cell references in formulas 

 learn how to replace values 

 learn how to use replace to change formulas 

 learn how to replace data within a specific range 

 learn how to find formats 

 learn how to find constants using Go To Special 

 learn how to find formulas using Go To Special 

 learn how to find the current region 

 learn how to find the last cell. 

As the names imply, finding involves looking for particular 
information or data in a worksheet and replacing involves replacing 
the data you’ve found with a new value. 

INFOCUS 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 22 Chapter 3 - Finding and Replacing 

UNDERSTANDING FIND AND REPLACE OPERATIONS 
 

 

 

 

  

 

Worksheets can become very complex rather 
quickly and it can then be time consuming to 
locate specific information in the file. This is 
where the Find operation is useful.  Find allows 

you to search for a range of elements so that you 
can check details or make changes. Replace is the 
natural progression from Find, allowing you to 
replace what you’ve found with an alternative. 
 

Find 

The Find operation searches through the active worksheet for whatever you type in the Find what field 
of the Find and Replace dialog box. In the example below, as the result of a search for 514, the cell 
pointer has moved to cell B10 because this is the first occurrence of the value 514. [Find Next] is used 
to find the next occurrence of 514 and [Find All] is used to create a list of all of the occurrences. 

 

Replace 

The Replace operation also searches through the active worksheet for whatever you’ve typed in the 
Find what field of the Find and Replace dialog box. You can then use [Replace] to substitute the text 
in Replace with for the found text. In this example, 514 has been replaced by 518. You can use the 
Find and Replace dialog box to find (and replace) parts of cell entries or entire cell entries. 
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FINDING TEXT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise you 

MUST open the file Find And 
Replace_1.xlsx... 

 
Click on the Home tab, then click 
on Find & Select in the Editing 
group to display a menu of 
options 

The menu includes a series of 
options for locating specific types 
of data or cells in the worksheet... 

 
Select Find to display the Find 
and Replace dialog box 

 
Type broadband, then click on 
[Find Next] 

The cell pointer will move to the 
first cell that contains matching 
text. Notice that Excel includes 
results with different text case 
and, by default, looks for the text 
even if it is only part of a cell 
entry... 

 
Click on [Find Next] to find the 
next occurrence of broadband 

 
Click on [Find Next] two more 
times, watching which cells the 
cell pointer moves to 

Since there are no more 
examples of broadband, the cell 
pointer will move back to the first 
instance... 

 
Click on [Close] to close the Find 
and Replace dialog box 

 

For Your Reference… 

To find text: 

1. Click on the Home tab, then click on Find & 
Select in the Editing group 

2. Select Find 

3. Type the text 

4. Click on [Find Next] 

Handy to Know… 

 You can search the entire workbook or just 
the active sheet by clicking on [Options] in 
the Find and Replace dialog box, then 
selecting Workbook or Sheet in Within. 

 You can restrict the search to text with the 
same case by clicking on Match case under 
[Options]. 

Common reasons to find text in a worksheet are 
because you want to locate an entry that you 
know exists, or because you don’t know if the 
entry does exist. A Find operation in Excel 

requires you to specify the text, value and/or format 
that you want to search for. Excel will search the 
active worksheet then select the first cell that 
matches the criteria. 
 

1 

2 

3 
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FINDING CELL REFERENCES IN FORMULAS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Find And Replace_2.xlsx... 

 
Click on the Home tab, 
click on Find & Select in 
the Editing group, select 
Find, then type D17 in Find 
what 

 
Click on [Find Next] 

The cell pointer will now 
stop on cell F17 which 
contains the formula 
=D17*E17... 

 
Click on [Find Next] until 
you return to cell F17 

 
In the Find and replace 
dialog box, click on 
[Options], then click on 
Match entire cell contents 
so it appears with a tick 

 
Click on [Find Next] 

Excel will advise that it can’t 
find the data. This has 
occurred because Excel is 
looking for a cell that 
contains only D17... 

 
Click on [OK] to close the 
message 

 
Click on [Options] to hide 
the options then click on 
[Close] 

 

2 

For Your Reference… 

To find cell references: 

1. Click on the Home tab, then click on Find & 
Select in the Editing group 

2. Select Find 

3. Type the cell reference 

4. Click on [Find Next] 

Handy to Know… 

 Match entire cell contents is very useful if 
you want to search for a particular number 
and know that it appears in a cell by itself. 
For example, if you want to locate 12 and 
turn on Match entire cell contents, Excel 
will ignore entries such as 112, 12,234 and 
45.12, and only accept 12. 

If you make extensive use of formulas in Excel, a 
very common search that you are likely to use is 
to find every cell that includes a reference to a 
particular cell. For example, you may want to find 

all of the formulas that use the value in cell A23. To 
do this you need to look for data that forms part of 
a cell entry. Fortunately, this is a default Find 
option. 
 

4 

5 
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REPLACING VALUES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Find And 
Replace_3.xlsx... 

 
Click on the Home tab, then 
click on Find & Select in the 
Editing group and select 
Replace 

The Find and Replace dialog 
box will appear with the 
Replace tab active... 

 
Double-click on the text in 
Find what and type global 
roamer 

 
Press  and type GR in 

Replace with 

 
Click on [Options] and 
ensure on Match entire cell 
contents appears without a 
tick 

 
Click on [Replace All] to 
replace the text 

Excel will advise that it has 
made four replacements... 

 
Click on [OK] to close the 
message box 

 
In the Find and Replace 
dialog box, click on 
[Options] to hide the 
options, then click on [Close] 

The last four 
communications products 
have now been renamed 

 

Replacing is the natural extension of finding. 
After all, why do you search for something? Quite 
often it is because you want to update it. You 
undertake a replace operation by nominating 

what to find and what the found data should be 
replaced with. You can even use Replace to 
remove data by finding the data and replacing it 
with nothing. 
 

3 

4 

5 

For Your Reference… 

To replace values: 

1. Click on the Home tab, then click on Find & 
Select in the Editing group 

2. Select Replace 

3. Type the text to find and the text to replace it 

with, then click on [Replace All] 

Handy to Know… 

 You can use wildcards to narrow your 
search so that you find information that has 
certain characters only. Use a question mark 
(?) to replace individual characters, an 
asterisk (*) to replace multiple characters, 
and a tilde (~) to search for wildcard 
characters (such as ~? to search for a ?). 

7 
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USING REPLACE TO CHANGE FORMULAS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Find And 
Replace_4.xlsx... 

 
Click on cell H7 and 
examine the formula in the 
Formula Bar 

=INT(E7+ (E7*$D$2)) 
calculates the projected 
sales based on the rate in 
$D$2. We can change the 
formula to refer to the rate 
in $E$2 instead... 

 
On the Home tab, click on 
Find & Select in the 
Editing group and select 
Replace 

 
Delete the text in Find what 
and type $D$2 

 
Press  and type $E$2 in 

Replace with 

 
Click on [Replace All] to 
replace the formulas in 
column H and to update the 
results of the formula 

There should be 12 
replacements... 

 
Click on [OK] to close the 
message box then click on 
[Close] 

 
Check the modified formula 
in cell H7 in the Formula 
Bar 

 

1 

For Your Reference… 

To use replace to change formulas: 

1. Click on the Home tab, then click on Find & 
Select  in the Editing group 

2. Type the text to find in Find what 

3. Type the replacement text in Replace with 

4. Click on [Replace All] 

Handy to Know… 

 Always save your workbook before 
performing a Replace All operation. If you 
end up with some unexpected results, you 
can close the workbook without saving it and 
then open it to start again. 

Once you’ve mastered find and replace concepts, 
you can use the techniques to perform some very 
interesting operations in a worksheet. Find and 
replace can be useful on those occasions when 

you have to make a structural change to a 
worksheet and need to ensure that the formulas 
are updated correctly, for example. 
 

4 

5 

7 
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REPLACING WITHIN A RANGE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4 

Try This Yourself: 

S
a

m
e

 

F
il
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Continue using the 
previous file with this 
exercise, or open the file 
Find And Replace_5.xlsx... 

 
Click in cell F15, hold down 

 and click on cells F23 

and F25, then release   

The three cells will be 
selected. Notice in the 
Formula Bar that the values 
are based on the SUM 
function. We will change 
them to an AVERAGE 
function... 

 
On the Home tab, click on 
Find & Select in the 
Editing group and select 
Replace to display the Find 
and Replace dialog box 

 
Double-click on the text in 
Find what and type sum 

 
Press  and type 

average in Replace with 

 
Click on [Replace All] to 
replace all of the values 
that match within the 
selected area 

 
Click on [OK] to close the 
message box, then click on 
[Close] 

Notice that the formula in 
the Formula Bar. for the 
selected cells is now an 
AVERAGE function 

 

For Your Reference… 

To replace within a range: 

1. Select the range 

2. Click on the Home tab, then click on Find & 
Select in the Editing group  

3. Select Replace, then type the Find what 
and Replace with text 

4. Click on [Replace All] 

Handy to Know… 

 With Find, you can use Look in to specify 
Values, Formulas or Comments. Values 
searches for a value that is the result of a 
formula, as opposed to a value that has been 
entered directly. With Replace, Look in is 
set to Formulas, which allows you to look at 
any direct cell entry except comments. 

The Find and Replace feature can also be used 
to replace only certain instances of the text for 
which you search. For example, instead of 
changing the formulas in the entire worksheet, 

you may wish to change only those in a specific 
range. To do this, you simply select the range of 
cells in which you want to search, before 
commencing the Find and Replace operation. 
 

1 

6 
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FINDING FORMATS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
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 Before starting this exercise 

you MUST open the file Find 
And Replace_6.xlsx... 

 
On the Home tab, click on 
Find & Select  in the 
Editing group, select Find, 
then click on [Options] 

 
Click on [Format] to display 
the Find Format dialog box 

 
Click on the Font tab, then 
click on Bold under Font 
style 

 
Click on [OK] to see a 
preview 

 
Click on [Find Next] 

The next occurrence in the 
worksheet will be selected, 
which is in cell A2... 

 
Click on [Find All] 

The cells with this format will 
be listed. You may have to 
resize the dialog box to view 
them all… 

 
Drag down the bottom of the 
dialog box to display the full 
list 

The entries are hyperlinked... 

 
In the Find and Replace 
dialog box, click on $B$4 
Model to select this cell, 
then click on [Close] 

 

3 

For Your Reference… 

To find formats: 

1. Click on the Home tab, click on Find & 
Select in the Editing group, then select Find 

2. Click on [Options], then click on [Format] 

3. Select the format, then click on [OK] 

4. Type any required text, then click on 
[Find Next] 

Handy to Know… 

 You can specify existing formatting by 
clicking on [Choose Format From Cell] on 
the Font tab in the Find Format dialog box, 
then clicking on a formatted cell. 

 You can clear formatting by clicking on 

[Clear] in the Find Format dialog box. 

You can search for specific format settings in a 
worksheet. Formats can help you identify and 
locate specific cells, such as percentages or 
headings. The Find feature allows you to search 

for format settings on their own or for a particular 
word or value with specific format settings. You can 
either locate the next matching cell or create a list 
of all entries that match the search criteria. 
 

7 
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FINDING CONSTANTS USING GO TO SPECIAL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the 
file Find And Replace_7.xlsx... 

 
On the Home tab click on Find & 
Select in the Editing group, then 
select Go To Special to display 
the Go To Special dialog box 

 
Click on Constants 

 
Click on [OK] 

All cells that contain an entry that 
is not a formula will be selected... 

 
Repeat step 1 to redisplay the 
Go To Special dialog box 

 
Click on Constants then click on 
Text, Logicals and Errors to 
remove the ticks for each of 
these 

This leaves Numbers selected... 

 
Click on [OK] 

Only the cells that contain 
numbers will be selected. 

You could use this selection to 
apply shading to all cells in the 
worksheet that can be safely 
modified, for example 

 

2 

For Your Reference… 

To find constants using Go To Special: 

1. On the Home tab, click on Find & Select in 
the Editing group and select Go To Special 

2. Click on Constants 

3. Click on [OK] 

Handy to Know… 

 You can select constants by clicking on Find 
& Select in the Editing group and selecting 
Constants but the Go To Special dialog box 
gives you more control over the command. 

 You can use the Go To Special dialog box 
to select all of the Comments in a 
worksheet. 

  

Sometimes it can be really difficult to work out 
which cells contain values that you can change 
as opposed to formulas that you shouldn’t touch. 
A constant is any cell that contains a value or 

text that is not the result of a formula – in other 
words, it remains constant. The Go To Special 
dialog box can be used to select all constants in the 
worksheet. 
 

6 
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FINDING FORMULAS USING GO TO SPECIAL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Find And 
Replace_8.xlsx... 

 
Click in cell A1 to 
deselect the current range 

 
On the Home tab, click on 
Find & Select in the 
Editing group and select 
Go To Special to display 
the Go To Special dialog 
box 

 
Click on Formulas, then 
click on [OK] 

All cells containing 
formulas will be selected 

 

1 

For Your Reference… 

To find formulas using Go To Special: 

1. Click on the Home tab, click on Find & 
Select in the Editing group, then select Go 
To Special  

2. Click on Formulas 

3. Click on [OK] 

Handy to Know… 

 You can select formulas by clicking on the 
Home tab, then clicking on Find & Select in 
the Editing group and selecting formulas. 

 You can restrict the formula selection to only 
those formulas that result in numbers by 
ensuring that only Numbers appears with a 
tick in the Go To Special dialog box. 

If you want to verify the accuracy of a worksheet, 
you should check the formulas. You can locate 
formulas either by clicking on each cell and 
looking at the Formula Bar, or by selecting them 

all using Find & Select. A formula is any entry that 
starts with the equal sign (=) and displays a 
calculated entry of text, a value or a logical entry 
such as Yes or No. 
 

2 
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FINDING THE CURRENT REGION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Find And 
Replace_9.xlsx... 

 
Click in cell A6 to position 
the cell pointer in the first 
main block of entries 

 
On the Home tab, click on 
Find & Select in the 
Editing group and select 
Go To Special to display 
the Go To Special dialog 
box 

 
Click on Current region 
then click on [OK] 

The first block of adjacent 
figures and text will be 
selected 

 

1 

For Your Reference… 

To find the current region: 

1. On the Home tab click on Find & Select in 
the Editing group and select Go To Special 

2. Click on Current region 

3. Click on [OK] 

Handy to Know… 

 You can also select the current region by 
pressing  +  + . 

The Go To Special dialog box can be used to 
select the current region, which is all of the cells 
adjacent to the current cell that contain an entry 
of some sort, such as text or formulas. This is 

useful for selecting an entire list or any block of 
entries in a worksheet that is surrounded by blank 
columns and blank rows. The current region is a 
bit like an island in a sea of empty cells. 
 

2 

3 
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FINDING THE LAST CELL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the 
file Find And 
Replace_10.xlsx... 

 
Press  +  to 

select cell A1 and 
deselect the current 
range 

 
On the Home tab, 
click on Find & 
Select in the Editing 
group, then select 
Go To Special to 
display the Go To 
Special dialog box 

 
Click on Last cell, 
then click on [OK] 

The cell pointer will 
move to cell I26, but 
there doesn’t appear 
to be any data in the 
cell. In this situation, 
this is as close as 
you can get because 
of the formatting that 
has been applied 

 

3 

For Your Reference… 

To find the last cell: 

1. Click on the Home tab, click on Find & 
Select in the Editing group, then select Go 
To Special 

2. Click on Last cell 

3. Click on [OK] 

Handy to Know… 

 To find out more about the last cell, go to 
www.microsoft.com and search for Article 
ID 244435 entitled How to reset the last 
cell in Excel. 

The last cell in a worksheet is, in theory, the 
right-most and lowest cell that contains data. 
When a worksheet is saved, only the part of the 
sheet that contains data or formatting is retained 

to reduce the file size. Sometimes there can be a 
gap between the last cell containing data and what 
Excel thinks is the last cell, causing some rows and 
columns to be saved unnecessarily. 
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CHAPTER 4 FILTERING DATA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of filtering 

 learn how to apply and use a filter 

 learn how to clear a filter 

 learn how to create a compound filter 

 learn how to filter for multiple values 

 learn how to set Save options 

 learn how to set file locations. 

You can use a spreadsheet to collect information and organise it 
into columns and rows within a table. This table can also be referred 
to as a database, and shares terminology with databases. Each 
row in the list is called a record and is one unit of information, e.g. 
an employee or an inventory item. Each column is known as a 
field, and each column heading is known as a field name, e.g. 
name or date of purchase. 

Microsoft Excel provides a Filter function so that you can examine 
information in a table by requesting rows that match criteria or 
values. It works by hiding records that don’t match the criteria you 
specify. 

INFOCUS 
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UNDERSTANDING FILTERING 
 

 

 

 

  

 

Filtering refers to comparing a list of records 
against specific criteria and then hiding the 
records that don’t match the criteria. It can be 
used simply to help find a record, or to create a 

subset of data that you can then edit, format, copy, 
move, chart or otherwise manipulate without 
affecting the other records. Here’s a brief example 
of how simple filtering works. 

An Example of Filtering 

Here is a list of 65 records in a table. The field names appear at the top and are No, First Name, Last 
Name and so on. After filtering using the criterion of Type = Gold, the list is reduced to the 16 records 
that have the word Gold in the Type column and the other records are hidden. Notice the row numbers 
on the left – these confirm that some of the rows are not visible 
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APPLYING AND USING A FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST 
open the file Filtering 
Data_1.xlsx... 

 
Click anywhere in the list  

The values in Years in 
your worksheet may vary 
from those shown here 
because Years updates 
automatically to show 
the current duration of 
membership… 

 
Click on the Data tab, 
then click on Filter in the 
Sort & Filter group 

 
Click on the filter arrow 
to the right of Type to 
display a list of options 

 
Click on (Select All) to 
remove all of the ticks, 
then click on Gold and 
click on [OK] 

All records for Gold 
memberships will be 
shown and the rest of 
the records temporarily 
hidden. 

Notice that the drop 
arrow next to Type has 
changed indicating that a 
filter is active on this 
column 

 

The Filter command applies (or removes) drop 
arrows to the right of the column labels in the list. 
When you click on a Filter arrow, it displays a list 
of the unique items in the column, including 

blanks and non-blanks. By selecting an item from a 
list for a specific column, you can instantly hide all 
rows that don't contain the selected value, and 
display only those that do. 

1 

For Your Reference… 

To turn the filter on or off: 

 Click in the data, click on the Data tab, then 
click on Filter in the Sort & Filter group   

To apply a simple filter: 

 Click on a filter arrow, click on (Select All), 

then click on an option and click on [OK] 

3 

Handy to Know… 

 If the column that you want to filter includes 
blank cells, you will also have the option 
(Blanks) to choose from. This can be used 
to help you locate missing data. 

4 
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CLEARING A FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a
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e
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Continue using the 
previous file with this 
exercise, or open the file 
Filtering Data_2.xlsx... 

 
Examine the list of 
records in the 
spreadsheet 

You’ll notice that it is 
currently filtered on Gold 
under Type... 

 
Click on the filter arrow 
for Type and select 
Clear Filter From 
“Type” 

All of the records will 
again be listed. You can 
also remove the filter 
altogether... 

 
Ensure the Data tab is 
active, then click on 
Filter in the Sort & 
Filter group to remove 
the filter arrows 

 

For Your Reference… 

To clear the filter: 

1. Click on the filter arrow  

2. Select Clear Filter From “fieldname” 

To remove the filter arrows: 

 Click on the Data tab, then click on Filter in 
the Sort & Filter group 

Once a filter has been applied, a subset of data is 
shown in the list. Before you can apply an 
alternative filter, the first one must be cleared so 
that all of the records become available again. 

Filters can be cleared either by clicking on (Select 
All) in the filter options list or by selecting Clear 
Filter From “fieldname” from the menu. You can 
also remove the filter arrows altogether. 

1 

2 

Handy to Know… 

 You can remove the filter altogether in one 
step by clicking on Filter. Use the Clear 
Filter From command when you want to 
perform subsequent filters. 

3 
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CREATING COMPOUND FILTERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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 Continue using the previous 

file with this exercise, or open 
the file Filtering Data_3.xlsx... 

 
Click anywhere in the list, 
ensure the Data tab is active, 
then click on Filter in the Sort 
& Filter group to display the 
filter arrows  

 
Click on the filter arrow for 
Type and click on (Select All), 
then click on Theatre and click 
on [OK] 

Only the records for Theatre 
are displayed… 

 
Click on the filter arrow for 
Suburb, click on (Select All), 
click on Heidelberg Heights, 
then click on [OK] 

Only the Theatre members in 
Heidelberg Heights are now 
shown. Let’s see if there are 
other members who live in 
Heidelberg Heights... 

 
Click on the filter arrow  for 
Type and select Clear Filter 
From “Type” 

Now that the list is filtered to 
show all Types in Heidelberg 
Heights, a Junior member is 
also listed... 

 
Click on the filter arrow for 
Suburb and select Clear 
Filter From “Suburb” 

 

For Your Reference… 

To create a compound filter: 

1. Apply the first filter to the list to display a 
subset of the records 

2. Apply a second filter to the list to show a 
subset of the subset of records 

Handy to Know… 

 When you print a filtered list, Excel will print 
the list as shown in the worksheet, with all of 
the unwanted records hidden. 

The Filter tool allows you to select a filter on one 
column or field at a time. When the filter is 
applied, the records that match that filter will be 
displayed. As you create successive filters on 

other fields, the filters are applied to only the 
records that are currently on display. In other 
words, the filters build up on each other, or 
compound, refining the list as required. 

2 

3 

5 
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MULTIPLE VALUE FILTERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Filtering Data_4.xlsx... 

 
Click on the filter arrow 
for Suburb and click on 
(Select All) to remove 
the ticks 

 
Click on Ascot Vale and 
Bentleigh so that ticks 
appear next to both items 

 
Click on [OK] to display 
the filtered list 

Only those records with 
Ascot Vale or Bentleigh 
in the Suburb are listed... 

 
Click on the filter arrow  
for Suburb and select 
Clear Filter From 
“Suburb” to list all of the 
records 

 

For Your Reference… 

To filter on multiple values: 

1. Click on the filter arrow for the required field 

2. Click on (Select All) 

3. Click on the checkboxes for each of the 
values that you want to filter by 

4. Click on [OK] 

Handy to Know… 

 Using multiple values in criteria is the same 
as saying, for example, if Suburb = Ascot 
Vale OR Suburb = Bentleigh. 

 If the field is a date field, you can filter on 
specific years, specific months or even 
specific dates. These are all provided for 
easy access in the filter menu. 

You may want to list records by creating two 
criteria for one field so that you can select 
records with one of two possible values. For 
example, you may want to see all the records for 

two particular suburbs, or two membership types. 
The filter options list all of the unique values found 
in that field in the list, so you can click on any of the 
values that you want to display. 

2 

3 
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CREATING CUSTOM FILTERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
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 Continue using the 

previous file with this 
exercise, or open the 
file Filtering 
Data_5.xlsx... 

 
Click on the filter arrow 
for Last Name, point 
to Text Filters, then 
select Begins With  

The Custom AutoFilter 
dialog box will 
display… 

 
Type W, as shown 

 
Click on [OK] to filter 
the list so that all 
members with last 
names beginning with 
W are listed 

 
Repeat steps 1 to 3 to 
create a list of 
members whose 
surnames start with S 

 
Click on the filter arrow 
for Last Name and 
select Clear Filter 
from “Last Name” 

 

The Filter feature enables you to create 
individual conditions for multiple fields using the 
drop-down lists. To set more than one condition 
per field you can use the Custom Filter option. 

This is ideal if you want to select records with one 
of several possible values, or where you want a 
record that falls within a range of values rather than 
matching an exact value. 

1 

For Your Reference… 

To create a custom filter: 

1. Click on the filter arrow for the field 

2. Select FieldType Filters > [option] 

3. Type the filter criteria 

4. Click on [OK] 

2 

Handy to Know… 

 If you are not sure how to spell a word, but 
know that it includes particular letters, you 
can search using the criteria contains. 

 Each of the equals, contains, begins with, 
and ends with criteria have an opposite 
choice e.g., does not equal, does not 
contain etc. 

3 
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USING WILDCARDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you need to filter for specific values in a list, 
you can select them individually from the filter 
menu or use wildcards to create a more 
powerful filter. Wildcards are characters that can 

be substituted for any character (?) or series of 
characters (*). For example, B*N would find all 
words starting with B and ending with N, while B?N 
would find the same, but look for three letters. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Filtering 
Data_6.xlsx... 

 
Click on the filter arrow for 
Last Name, point to Text 
Filters, then select Custom 
Filter to display the Custom 
AutoFilter dialog box 

 
Type S* 

 
Click on [OK] to see the 
members whose names 
begin with the letter S 

 
Repeat step 1 to display the 
Custom AutoFilter dialog 
box 

Notice that Excel changed 
your criteria so that it now 
reads “begins with S”… 

 
Click on the drop arrow 
below Last Name, scroll up 
and select equals, then 
click in the field to the right 
of S and 
type *n 

 
Click on [OK] to see the 
names that begin with S and 
end with n 

 
Click on the filter arrow for 
Last Name and select Clear 
Filter From “Last Name” to 
display all of the records 

 

2 

4 

5 

For Your Reference… 

To use wildcards in custom criteria: 

1. Click on a filter arrow, then point to Text 
Filters 

2. Select Custom Filter  

3. Enter a criteria with either an * or a ? 
depending on what you are searching for 

Handy to Know… 

 You can filter for the question mark or 
asterisk character as the actual character 
itself, and not the wildcard character, by 
preceding the character with the tilde ~. For 
example, if you use the criteria Year~?, 
Excel will search for the character string 

Year?. 

6 
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CHAPTER 5 ADVANCED FILTERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of advanced filtering 

 learn how to use an advanced filter 

 learn how to extract records using an advanced filter 

 learn how to use formulas in criteria 

 gain an understanding of the database functions 
available 

 learn how to use database functions 

 learn how to use the DSUM function 

 learn how to use the DMIN function 

 learn how to use the DMAX function 

 learn how to use the DCOUNT function. 

Worksheets can be used to keep lists of information such as 
employee details, subscribers, accounts, sales, or even bird 
sightings if need be. 

The Advanced Filter in Excel enables you to analyse the data in a 
list by filtering it according to specific criteria. 

INFOCUS 
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UNDERSTANDING ADVANCED FILTERING 
 

 

 

 

  

 

 

To work with Advanced Filters in Excel, you 
need to understand a few of the concepts that 
are used. A list in Excel is a series of rows of 
information. Each row is effectively one unit of 

information. This structure is very similar to a 
simple database and therefore Excel uses similar 
terminology to describe the parts of the list. The 
following illustrates a list and its parts. 
 

Fields, Field Names and Records 

A field is a column in the list of data. In the example below, the column of data for the Last Name is an 
example of a field. 

The field name is the heading at the top of the column. The field names within one list must be unique. 
In the example below, the text Annual Fee is an example of a field name. 

A record is a row of data in the list. Each record is one item of data in the list. In the example below, the 
row of information for Fred Jackson is one record. Note that advanced filters do not work correctly if 
there are blank rows in the list. 

 

Criteria, Criteria Range, AND and OR 

Criteria are tests against the data in specific fields, for instance Gold. When Gold is tested against the 
field Type, the filter would display only the people with Gold memberships. All other records are filtered 
out (hidden). 

The criteria range is the area where you specify the criteria. The first row contains the field names that 
mirror those in the list. The second and subsequent rows are used to type the criteria or examples of 
what you are looking for in the list. 

If you want the conditions between fields joined with an AND, you write the conditions on the same row. 
If you want them joined with an OR, you write the conditions on separate rows. In the next example, our 

criteria specifies greater than 15 years membership AND Gold membership. 

Field Field Name 

Criterion Range Criterion  

Record 
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USING AN ADVANCED FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To use an Advanced Filter, you need to create a 
criteria area, enter your criteria, specify the list to 
be filtered and then run the filter. The Advanced 
Filter tool has one distinct advantage over other 

filtering techniques (such as AutoFilter), you type 
your criteria directly into the worksheet. The criteria 
are always visible in the worksheet above the 
records that you have filtered. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Advanced Filters_1.xlsx... 

 
Study the list of records to 
familiarise yourself with the 
data 

First we need to add criteria... 

 
Type the labels and values in 
the range D2:E3 as shown 

The criteria reads “where 
Years are greater than or 
equal to 20 AND the Type is 
Silver”. Now to apply the 
filter... 

 
Click in cell E6 so that Excel 
can locate the list 

 
Click on the Data tab, then 
click on Advanced in the Sort 
& Filter group to display the 
Advanced Filter dialog box 

The List range is automatically 
selected... 

 
Click in Criteria range, then 
type D2:E3 

 
Click on [OK] 

Only the records matching the 
criteria will be displayed... 

 
On the Data tab, click on 
Clear in the Sort & Filter 
group to restore the list 

 

2 

5 4 

For Your Reference… 

To use the Advanced Filter: 

1. Create the criteria range 

2. Click in the list to be filtered 

3. Click on the Data tab, then click on 
Advanced in the Sort & Filter group 

4. Type the Criteria range, then click on [OK] 

6 

Handy to Know… 

 When using the Advanced Filter dialog box, 
if you can’t remember the range of cells that 
hold certain values (e.g. Criteria range), you 
can click on Collapse Dialog which moves 
the focus to the workbook, enabling you to 
select the actual cells on the relevant 
worksheet. 
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EXTRACTING RECORDS WITH ADVANCED FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Advanced Filter can be used to filter a list in 
place (hiding unwanted records) or to extract 
required records and paste them in another 
location. By creating a subset of the list, you can 

further analyse the data without risking accidental 
modifications of the original list. You must specify 
the fields that you want and the location where the 
records are to be copied. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Advanced 
Filters_2.xlsx... 

 
Scroll down to and click 
in cell C75 

This is a blank cell which 
appears below the list… 

 
Type the field headings 
as shown 

These are the fields that 
we want to extract 
according to the criteria 
listed at the top of the 
worksheet... 

 
Click anywhere in the 
original list 

 
Click on the Data tab 
then click on Advanced 
in the Sort & Filter 
group 

 
Under Action click on 
Copy to another 
location  

 
Click in Copy to and 
type C75:F75 

 
Click on [OK], then scroll 
down and examine the 
extracted data 

 

2 

5 6 

For Your Reference… 

To extract records using the Advanced Filter: 

1. Create the criteria and extract ranges 

2. Click on the Data tab, then click on 
Advanced in the Sort & Filter group 

3. Click on Copy to another location 

4. Type the Criteria range and Copy to range, 

then click on [OK] 

Handy to Know… 

 You can use the extract feature of the 
Advanced Filter to create a list of unique 
codes that are used in a list. For example, to 
create a list of Type codes, extract the Type 
field with no criteria and select the checkbox 
Unique records only in the Advanced 

Filter dialog box. 

7 
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USING FORMULAS IN CRITERIA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

By making slight adjustments to the criteria range 
and using a formula for the criteria, you can 
create more sophisticated filters. The first row of 
the criteria range must contain a label that is not 

the same as a field heading. The criteria example 
in the second row must be expressed as a 
formula. The formula often makes a comparison 
using the first record as a model for all others. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Advanced 
Filters_3.xlsx... 

 
Delete the contents of cells 
D2:E3 

 
Type the headings AveMem in 
cell D2 and Average 
Membership in cell F2 as 
shown, then enter these 
formulas: 

in F3 =AVERAGE(E7:E70) 

in D3 =E7>$F$3 

The formula in F3 calculates 
the average Years (20.4), then 
the formula in D3 tests the 
Years of the first record 
against the average. If the 
Years are higher than the 
average, the answer is TRUE. 
Let’s now extract the matching 
records... 

 
Click in the list, then click on 
the Data tab  

 
Click on Advanced in the Sort 
& Filter group, then 
double-click on $E$3 in 
Criteria range and type D3 

 
Click on Copy to another 
location in Action – we’ll use 
the same Copy to cell range 

 
Click on [OK], then scroll down 
to examine the extracted data 

 

2 

4 5 

For Your Reference… 

To use formulas in criteria: 

1. Type a criteria heading that does not match 
a field name 

2. Create a formula (starting with =) below the 
heading that performs a comparison with the 
value of a field in the first record 

Handy to Know… 

 When you perform the copy operation during 
filtering, Excel names the header row of the 
copied records as Extract. It names the cells 
containing the criteria range as Criteria. You 
can use these names to navigate quickly to 
the extract or criteria ranges of the worksheet 

via the Name box. 

6 
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UNDERSTANDING DATABASE FUNCTIONS 
 

 

 

 

  

 

The database functions are functions that are 
specifically designed to perform calculations on 
records in a list without the need to filter them. 
The selection criteria are built into the functions 

returning summary values without filtering the 
records. This page details the database functions, 
their purpose and their criteria. 
 

The Database Functions 

 

Function Purpose 

DAVERAGE Averages the values in the field (column) of records in a database that 
match the criteria that you specify. 

DCOUNT Counts the cells containing numbers in the field of records in the database 
that match the criteria that you specify. 

DCOUNTA Counts the non-blank cells in the field of records in the database that match 
the criteria that you specify. 

DGET Extracts from the database a single record that matches the criteria that 
you specify. 

DMAX Returns the highest number from the field of records in the database that 
match the criteria that you specify. 

DMIN Returns the lowest number from the field of records in the database that 
match the criteria that you specify. 

DPRODUCT Multiplies the values in the field of records in a database that match the 
criteria you specify. 

DSTDEV Estimates the standard deviation based on a sample from the database 
entries that match the criteria that you specify. 

DSTDEVP Calculates the standard deviation from the entire population in a field of 
records in the database that match the criteria that you specify. 

DSUM Adds the values in the field of records in a database that match the criteria 
that you specify. 

DVAR Estimates the variance based on a sample from the database entries that 
match the criteria that you specify. 

DVARP Calculates the variance from the entire population in a field of records in 
the database that match the criteria that you specify. 

 

Function Arguments 

All database functions require the same three arguments: 

 

Argument Use 

database The range of cells that make up the list or database. 

field This is the column that the calculations will be performed upon. It is 
represented either by the label of the column in double quotation marks or 
by a number that represents the position of the column in the list. 

criteria The range of cells that contain the criteria, consisting of a column heading 
and a cell below the label containing the criteria. 
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USING DATABASE FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Advanced Filter can be used to show or 
extract a subset of records from a list for later 
analysis. An alternative to using the filter is to use 
the database functions. These functions are 

specially designed to perform calculations on 
records without the need to filter them. The 
selection criteria are built into the functions, 
returning values without filtering the records. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Advanced 
Filters_4.xlsx... 

 
Delete the contents in 
the range D2:F3 

 
Add the details to cells 
E2, E3, G2, G3 and G4 
as shown 

 
Type the formulas in the 
cells, as shown  

The results for all 
records with less than 
20 years membership 
are shown. 

Your results may differ 
from those shown in the 
example as the data is 
based on the current 
date… 

 
Click in cell E7, then 
click on the Home tab 
and click on Format 
Painter in the 
Clipboard group 

 
Click and drag the 
mouse pointer over the 
range H2:H5 to apply 
the formatting 

 

2 

3 

For Your Reference… 

DCOUNTA(database,field,criteria) 

This function counts all of the nonblank cells in 
a field (column) in a database (list) that match 
the criteria (conditions) that you specify. 
Database is the cell range for the list, field is 
the cell reference of the column heading, and 
criteria is the criteria range. 

Handy to Know… 

 There are twelve database functions 
including DSUM, DPRODUCT, DCOUNT 
and DAVERAGE. They all require the same 
parameters or information: database, field 
and criteria. 

5 
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USING DSUM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Advanced Filters_5.xlsx... 

 
Click in cell E3, then type 
Type 

This is the column that the 
criteria will operate on... 

 
Click in cell E4, then type 
Gold 

Our initial criterion is that the 
membership type must be 
Gold... 

 
Click in cell G3, then type 
Total 

This is a label for our 
database... 

 
Click in cell H3, type 
=DSUM(A8:H72,H8,E3:E4), 
then press   

 
Click in cell H9, click on the 
Home tab, click on Format 
Painter in the Clipboard 
group, then click in cell H3 

 
Click in cell E4, type Silver 

and press   

The Total of the database 
function will recalculate... 

 
Repeat step 6 with the values: 

Junior 

Theatre 

no criteria (i.e. leave blank) 

 

The DSUM function is used to total the contents 
of cells in a specified field of a database, where 
the record matches the criteria specified. The 
criteria can be specified against one or more cells 

and not necessarily against the column that is 
being totalled. The records are not filtered, rather a 
single total figure is calculated and displayed. 

4 

6 

For Your Reference… 

DSUM(database,field,criteria) 

This function adds all of the numeric cells in a 
field (column) in a database (list) that match 
the criteria (conditions) that you specify. 
Database is the cell range for the list, field is 
the cell reference of the column heading, and 
criteria is the criteria range. 

Handy to Know… 

 You can use multiple criteria in the DSUM 
function by entering them in the column 
adjacent to the existing criteria and 
expanding the range for criteria in the 
formula. 

7 
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USING THE DMIN FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Advanced 
Filters_6.xlsx... 

 
Click in cell E4, type Gold, 

then press   

This is our criteria for the 
function... 

 
Click in cell G4, type Min, then 

press   

 
Click in cell H4, type 
=DMIN(A8:H72,E8,E3:E4) 
then press  

The current minimum number 
of years for a Gold 
membership is shown – if 
necessary, you could format 
the number in the cell at this 
point... 

 
Click in cell E4 , type Silver, 
then press  

The Total and Minimum values 
will recalculate... 

 
Repeat step 4 with the values: 

Junior 

Theatre 

no criteria (i.e. leave blank) 

No criteria will give you the 
current overall Minimum Years 

 

The DMIN function is used to find the minimum or 
lowest value in cells in a specified field of a 
database, where the record matches the criteria 
specified. The criteria can be specified against 

one or more columns and not necessarily against 
the column that is being examined. The records are 
not filtered, rather a single minimum figure is 
returned. 
 

3 

4 

For Your Reference… 

DMIN(database,field,criteria) 

This function finds the lowest value in the cells 
in a field (column) in a database (list) that 
matches the criteria (conditions) that you 
specify. Database is the cell range for the list, 
field is the cell reference of the column heading 
and criteria is the criteria. 

Handy to Know… 

 When using database functions (e.g. DMIN), 
instead of using a cell address to refer to the 
field in the database (e.g. E8), you can use 
the database heading text in the cell. For 
example: =DMIN(A8:H72,”Years”,E3:E4), 
where “Years” refers to the heading in cell 
E8. 

5 
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USING THE DMAX FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Advanced 
Filters_7.xlsx... 

 
Click in cell E4, then type Gold 

 
Click in cell G5, then type Max 

 
Click in cell H5, type 
=DMAX(A8:H72,E8,E3:E4) 
then press   

The current maximum number 
of years for a Gold 
membership is shown. Let’s 
add formatting... 

 
Click in cell E9, click on the 
Home tab, click on Format 
Painter in the Clipboard 
group, then click in cell H5 to 
apply the formatting 

 
Click in cell E4, type Life, then 

press  

The Maximum value will 
recalculate... 

 
Repeat step 5 with the values: 

Junior 

Theatre 

no criteria (i.e. leave blank) 

No criteria will give you the 
current overall Maximum 
Years 

 

The DMAX function is used to find the maximum 
or highest value in cells in a specified field of a 
database, where the record matches the criteria 
specified. The criteria can be specified against 

one or more columns and not necessarily against 
the column that is being examined. The records are 
not filtered, rather a single maximum figure is 
calculated. 

3 

5 

For Your Reference… 

DMAX(database,field,criteria) 

This function finds the highest value in the cells 
in a field (column) in a database (list) that 
match the criteria (conditions) that you specify. 
Database is the cell range for the list, field is 
the cell reference of the column heading and 
criteria is the criteria range. 

Handy to Know… 

 When working with databases and database 
functions, you can place the criteria cells 
anywhere on the worksheet, but we 
recommend that you don’t type them below 
the database, as they may be inadvertently 
overwritten when new records are added. 

6 
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USING THE DCOUNT FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The DCOUNT function is used to count the 
number of values in a specified field of a 
database, where the record matches the criteria 
specified. The criteria can be specified against 

one or more cells, and not necessarily against the 
column that is being counted. Any text entries or 
blank cells are ignored. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Advanced 
Filters_8.xlsx... 

 
Click in cell E4 and 
type Gold 

 
Click in cell G6 and 
type Count 

 
Click in cell H6 and 
type 
=DCOUNT(A8:H72,E8,

E3:E4) then press  

The total number of 
Gold memberships is 
shown... 

 
Click in cell E4 and 
type Silver, then press 

 

The values will 
recalculate... 

 
Repeat step 4 for the 
values: 

Junior 

Theatre 

no criteria (i.e. leave 
blank) 

No criteria will give you 
the total number of 
records with values in 
the Years column – 64 

 

3 

For Your Reference… 

DCOUNT(database,field,criteria) 

This function counts all of the numeric cells in a 
field (column) in a database (list) that match 
the criteria (conditions) that you specify. 
Database is the cell range for the list, field is 
the cell reference of the column heading and 
criteria is the criteria range. 

Handy to Know… 

 When using database functions, you can 
create OR criteria by including another row 
below the existing criteria. For instance, if 
you enter Gold in cell E4 and Silver in cell 
E5, then enter E3:E5 for criteria (where E3 
is the heading), the function will include 

records matching either Gold OR Silver. 

4 

5 
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NOTES: 
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CHAPTER 6 CONDITIONAL FORMATTING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of conditional formatting 

 learn how to conditionally format cells containing specific 
values 

 learn how to clear conditional formatting 

 learn how to use more of the cell formatting options 

 learn how to format the top ten items in a range 

 learn how to use the various Top/Bottom Rules 

 learn how to work with data bars 

 learn how to work with colour scales when formatting 
conditionally 

 learn how to apply icon sets to conditionally format a 
range 

 gain an understanding of sparklines 

 learn how to create sparklines 

 learn how to edit sparklines 

 learn how to use logical formulas for more complex 
conditional formatting  

 gain an understanding of the Conditional Formatting 
Rules Manager 

 learn how to manage rules. 

Formatting allows you to change the way that the data in cells within 
a worksheet appears on the screen. For example, numbers can be 
made to appear as currency values or percentages by formatting 
them accordingly. 

Excel provides a variation on formatting known as conditional 
formatting. With conditional formatting, cells can be formatted in 
different colour schemes. Rather than this formatting being applied 
to all cells in a range, it is applied selectively and based on specific 
rules. This type of formatting allows you to see, for example, values 
that are over a certain amount, or to instantly spot high and low 
values based on assigned colouring. 

INFOCUS 
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UNDERSTANDING CONDITIONAL FORMATTING 
 

 

 

 

  

 

As the name suggests, conditional formatting 
is a type of formatting that is applied to cells or 
ranges when certain conditions are met. These 
conditions are set, but can quite often be 

customised and edited, in rules that have been 
programmed into Excel. There are two types of 
conditional formatting – values-based formatting 
and trend-based formatting. 

What Happens With Conditional Formatting 

With conditional formatting, cells in a specified range are coloured or shaded according to certain 
conditions which are outlined in rules. 

Values-Based Conditional Formatting 

With values-based conditional formatting, cells in the range are examined and their shading and 
colouring is based on whether they meet the conditions of the rule. This type of formatting allows you to 
see whether values in a range are greater than a certain value, less than a certain value, equal to a 
certain value, or fall between ranges. You can also display the top ten, bottom ten, top 10%, bottom 
10%, and above and below averages with this type of formatting. 

In all cases a dialog box will appear which allows you to modify the rule based on what is required. 
Basically, the dialog box allows you to specify a value or a range of values for the rule, and to determine 
the colour of the shading used. Below is an example of the dialog box for applying the Between rule. 

 

Trend-Based Conditional Formatting 

With trend-based conditional formatting, colouring is applied to all of the cells in the range. The depth of 
the colouring is determined by the values shown in each cell relative to the overall total of the range. 
This allows you to instantly spot higher, lower and median values in the range and to see the trend of the 
numbers. The formatting can be applied in the form of coloured bars, coloured scales and even 
icons.  

 

Coloured scales 

Icons 

Coloured bars 
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FORMATTING CELLS CONTAINING VALUES 
 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

A common analysis requirement is to see what 
values in a worksheet are greater than a specific 
amount. For example, you may want to see 
which salespeople have achieved better than 

their set targets. This can be done using the 
Greater Than option which appears under 
Highlight Cell Rules in the Conditional 
Formatting menu on the Home tab. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this exercise 
you MUST open the file 
Conditional 
Formatting_1.xlsx... 

 
Select the range I4:I45 

 
Click on the Home tab, click 
on Conditional Formatting in 
the Styles group, then point to 
Highlight Cells Rules to 
display a menu of options, as 
shown 

 
Select Greater Than to 
display the Greater Than 
dialog box 

With Live Preview, the cells in 
the range that meet the 
condition are highlighted… 

 
In Format cells that are 
GREATER THAN: type 90000 

Notice how the formatting 
changes… 

 
Click on the drop arrow for 
with, then select Green Fill 
with Dark Green Text to 
change the colour of the 
shading 

 
Click on [OK] to apply the 
formatting 

 
Click in a blank cell to deselect 
the range and see the 
formatting more clearly 

 

2 

3 

For Your Reference… 

To format cells containing specific values: 

1. Select the range 

2. Click on the Home tab, then click on 
Conditional Formatting in the Styles group 

3. Point to Highlight Cell Rules, then select 
Greater Than 

4. Set the options as required and click on [OK] 

Handy to Know… 

 The Greater Than conditional formatting 
option is very literal. If, for example, you ask 
it to format values over 90,000 it will only 
format values that are over 90,000 – any 
value of 90,000 will not be formatted. 

7 
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CLEARING CONDITIONAL FORMATTING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Excel will compound conditional formats. For 
example, you can apply a Greater Than format, 
then come back and apply a Less Than format. 
The original format will remain, depending upon 

what is required in the second format. Unless you 
want compounding formats, you should clear any 
previous formats from the worksheet before 
applying a new one.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Conditional 
Formatting_2.xlsx... 

 
Click on the Home tab, 
then click on 
Conditional 
Formatting in the 
Styles group to display 
a menu of options 

 
Point to Clear Rules to 
display a menu of 
options 

 
Select Clear Rules 
from Entire Sheet to 
clear all the formatting 
from the entire 
worksheet 

 

2 

3 

For Your Reference… 

To clear conditional formatting: 

1. Click on the Home tab, then click on 
Conditional Formatting in the Styles group 

2. Point to Clear Rules, then select an option 

Handy to Know… 

 You can clear the conditional formatting from 
a selected range by clicking on the Home 
tab, then in the Styles group, selecting 
Conditional Formatting > Clear Rules > 
Clear Rules from Selected Cells. This is 
useful if you have conditional formatting 
within the worksheet that you wish to retain. 
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MORE CELL FORMATTING OPTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are a number of options under Highlight 
Cells Rules on the Conditional Formatting 
menu that are handy to know about and use. 
These include the ability to format less than a 

value, format for values between two values, and 

format for values equal to a specific value.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Conditional 
Formatting_3.xlsx... 

 
Select the range C4:H10  

This includes all of the 
sales for BMW motor 
vehicles… 

 
Click on the Home tab, 
click on Conditional 
Formatting in the Styles 
group, then point to 
Highlight Cells Rules to 
display a menu of options  

 
Select Less Than to 
display the Less Than 
dialog box 

 
Type 15000 to see how 
many months had model 
sales less than 15,000 

At this stage we want to 
use more of these 
commands so we’ll cancel 
the previous one… 

 
Click on [Cancel] to 
cancel the formatting 

 
Repeat steps 2 to 5 to 
see the formatting for the 
Between setting and the 
Equal To setting  

 
Click on [Cancel] to 
cancel the formatting 

 

1 

3 

For Your Reference… 

To format cells containing specific values: 

1. Select the range, then click on the Home tab 

2. Click on Conditional Formatting in the 
Styles group 

3. Point to Highlight Cells Rules, select an 
option, apply the settings as necessary, then 

click on [OK] 

Handy to Know… 

 When applying conditional formatting, if you 
inadvertently click on [OK] instead of 
[Cancel], you can either use the Clear 
Rules option or the Undo tool in the Quick 
Access Toolbar to remove the unwanted 
formatting. 

4 
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TOP TEN ITEMS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Conditional formatting can be used in a 
worksheet to highlight upper and lower values. 
For example, it is often interesting to know your 
top 10 customers, or the top 10% of products 

sold in the last year. This can be achieved using 
the Top/Bottom Rules menu which can be 

accessed from the Conditional Formatting menu. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Conditional 
Formatting_4.xlsx... 

 
Select the range C4:H10 

 
Click on the Home tab, 
click on Conditional 
Formatting in the Styles 
group, then point to 
Top/Bottom Rules to see 
the available options 

 
Select Top 10 Items to 
display the Top 10 Items 
dialog box – shading will 
now be applied to the top 
10 items in the range  

 
Click on the down spinner 
arrow next to the quantity 
until 5 appears, as shown  

The top 5 items in the 
range will now be 
coloured… 

 
Click on [OK] to apply the 
formatting 

 
Click outside the range to 
deselect it and see the 
results more clearly 

 
Click on Conditional 
Formatting in the Styles 
group, then select Clear 
Rules from Entire Sheet 
to clear the formatting 

 

2 

4 

For Your Reference… 

To format the top ten items: 

1. Select the range 

2. Click on the Home tab, click on Conditional 
Formatting in the Styles group, then point 
to Top/Bottom Rules 

3. Select an option 

Handy to Know… 

 Don’t confuse the Top 10 Items with the Top 
10% – the former displays only 10 results 
while the latter can display a variable amount 
of results based on what fits into the top ten 
percent category. 

6 
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MORE TOP AND BOTTOM FORMATTING OPTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Top/Bottom Rules option in the 
Conditional Formatting menu provides a 
number of useful options for displaying upper and 
lower ranges in your data. You can display the 

top and bottom <n> number of values, the top and 
bottom percentage, and whether values are above 
or below average. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Conditional 
Formatting_5.xlsx... 

 
Select the range 
C4:H10  

This includes all of 
the sales for BMW 
motor vehicles… 

 
Click on the Home 
tab, click on 
Conditional 
Formatting in the 
Styles group, point to 
Top/Bottom Rules, 
then select Top 10% 
to display the Top 
10% dialog box 

 
Spend a few 
moments studying 
the results 

 
Click on [Cancel] to 
clear any formatting 

 
Repeat steps 2, 3 
and 4 to select the 
Bottom 10 Items, 
Bottom 10%, Above 
Average, and Below 
Average options to 
view the results  

 

2 

3 

For Your Reference… 

To format cells for top or bottom: 

1. Select the range 

2. Click on the Home tab, click on Conditional 
Formatting and point to Top/Bottom Rules 

3. Select an option, apply the desired settings 

and click on [OK] 

5 

Handy to Know… 

 The up and down spinner arrows next to the 
values in the conditional formatting dialog 
boxes allow you to refine your conditional 
formatting for the number of items and the 
percentage of items. 
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WORKING WITH DATA BARS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

It is sometimes difficult to spot patterns or trends 
when confronted with a worksheet full of figures. 
Conditional formatting allows you to colour cells 
so that you can see how the figures move from 

high value to low value. Data bars provide colour 
accents to cells in the selected range. The width of 
the accents depends on the data value and its size 
relative to the overall total value. 

Try This Yourself: 

O
p

e
n

 F
il

e
 Before starting this 

exercise you MUST 
open the file 
Conditional 
Formatting_6.xlsx... 

 
Select the range 
C11:H11  

This range represents 
the total monthly 
sales of BMW 
vehicles… 

 
Click on the Home 
tab, click on 
Conditional 
Formatting in the 
Styles group, then 
point to Data Bars to 
see the available 
options 

 
Point to the options to 
see a Live Preview of 
the result 

 
Click on Orange 
Data Bar under 
Gradient Fill, then 
click outside the 
range to deselect it 

The bars indicate the 
size of each value 
relative to the total 

 

1 

For Your Reference… 

To use data bars to highlight values: 

1. Select the range 

2. Click on the Home tab, then click on 
Conditional Formatting in the Styles group  

3. Point to Data Bars and select an option 

Handy to Know… 

 To change to a different Data Bar colour, 
select the required range, click on the Home 
tab, then click on Conditional Formatting in 
the Styles group, point to Data Bars and 
click on an option to apply it.  

2 

4 
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WORKING WITH COLOUR SCALES 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Using colour scales, you can highlight the 
values of cells in a selected range relative to the 
total value of all cells in that range. After selecting 
a colour scale, each cell in the range is shaded 

with a different hue and intensity of one of the 
colours in the scale, dependent upon its value 
relative to the overall selection total. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Conditional 
Formatting_7.xlsx... 

 
Select the range C4:H4  

This is the vehicle 
monthly sales for the 3 
Series BMW vehicles… 

 
Click on the Home tab, 
click on Conditional 
Formatting, then point 
to Colour Scales to 
see the options 
available 

 
Point to the colours to 
see a Live Preview of 
the result how coloured 
shading appears across 
the selected range 

 
Select Green-Yellow-
Red Colour Scale 

 
Select the range C7:H8  

This is the vehicle 
monthly sales for the X 
Series BMW… 

 
Repeat steps 2 and 4 to 
apply Green-Yellow-
Red Colour Scale 
shading 

 
Click outside the range 
to deselect it and see 
the results 

 

1 

4 

For Your Reference… 

To use colour scales to highlight values: 

1. Select the range 

2. Click on the Home tab, click on Conditional 
Formatting in the Styles group, then point 
to Colour Scales  

3. Select an option 

Handy to Know… 

 With a three colour option, Excel divides the 
values according to the number of cells in the 
range and then applies a scale of hues. In 
the Green-Yellow-Red Colour Scale option 
the first colour (Green) is applied to the 
highest value, while the last colour (Red) is 
applied to the lowest. 

7 
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WORKING WITH ICON SETS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Using colours to conditionally format ranges in a 
worksheet is fine providing that your readers are 
capable of interpreting and indeed even seeing 
colours. In lieu of colouring a conditionally 

formatted range, you can apply icons to the range. 
With icons a symbol is placed next to a cell to 
indicate the position of that value relative to the 
range total. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Conditional 
Formatting_8.xlsx... 

 
Select the range I4:I10  

This is the total sales for 
each BMW model over 
six months… 

 
Click on the Home tab, 
click on Conditional 
Formatting in the Styles 
group, then point to Icon 
Sets to see a gallery of 
options 

 
Point to the options to 
see a Live Preview of the 
result in the spreadsheet 

 
Under Indicators, click 
on 3 Symbols 
(Uncircled) to select this 
option and apply it to the 
selected range 

The hash (#) symbols 
next to the icons show 
the column is too narrow 
to display the values… 

 
In the column header 
area, double-click on the 
right margin of column I 
to widen it to fit the 
content 

 
Click outside the range 
to view the result  

 

For Your Reference… 

To use icon sets to highlight values: 

1. Select the range 

2. On the Home tab click on Conditional 
Formatting and point to Icon Sets  

3. Select an option 

Handy to Know… 

 Using the 3 Symbols (Uncircled) conditional 
formatting option, there are three icons that 
are applied according to the rule of thirds in 
the range. Values that fall within the top third 
receive the tick icon, values in the second 
third receive the exclamation mark, and the 
values in the last third receive the cross. 

2 

6 
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UNDERSTANDING SPARKLINES 
 

 

 

 

  

     

 

Sparklines are mini-charts that are inserted into 
a single cell of a worksheet. You use Sparklines 
to graphically represent trends and patterns in 
the data in a specific range of cells in the 

worksheet. You insert Sparklines from the Insert 
tab on the ribbon. 

What Are Sparklines? 

Sparklines are simply mini-charts embedded into a single cell. Before you insert a Sparkline you must 
select the range of values you want the Sparkline to represent. 

Each of the Sparklines above charts the figures for the Jan, Feb and Mar columns in the row to their left. 
For example, the Sparkline in cell G4 charts the figures in the range C4:E4. 

There are three different types of Sparklines available in Excel: Line, Column and Win/Loss, as shown 
above. 

The Line Sparkline displays as a line chart. When dots appear in conjunction with the lines it is because 
the Sparklines have been asked to display the highest and lowest values and the dots represent these 
values.  

A Column Sparkline displays as vertical bars. The Win/Loss Sparkline displays positive values in one 
colour above an imaginary line and negative values in another colour below that imaginary line. 

While Sparklines are not as versatile as charts, you still have a lot of formatting options at your disposal 
when working with them. When a cell containing a Sparkline is selected, the Sparkline Tools: Design 
tab will appear in the ribbon as shown below. 

The Sparkline Tools: Design tab 

The Sparkline Tools: Design tab allows you to change the type of Sparkline in a cell, change formatting 
options such as style and colouring, and show various high points, low points and the like. There is also 
a command that allows you to clear Sparklines from the cell.  

 

Column Sparkline 

Line Sparkline 

Win/Loss Sparkline 
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CREATING SPARKLINES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can choose to create a Line, Column or 
Win/Loss Sparkline, depending on the type of 
data you are working with. While it is more 
efficient to get it right at this stage, you do have 

the option of changing the type of Sparkline after it 
is created. Like other forms of charting you will 
need to select the data series before creating the 
Sparkline.  

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this exercise 
you MUST open the file 
Conditional 
Formatting_9.xlsx... 

 
Select the range C4:E4 

 
Click on the Insert tab, 
then click on Column in the 
Sparklines group to 
display the Create 
Sparklines dialog box 

The dialog box shows the 
data range but requires a 
location for the Sparkline… 

 
Click in cell G4 in the 
worksheet, then click on 
[OK] to create the 
Sparkline 

 
Select the range C5:E5 

 
On the Insert tab, click on 
Line in the Sparklines 
group to display the Create 
Sparklines dialog box 

 
Click in cell G5 in the 
worksheet, then click on 
[OK] 

 
Repeat the above steps to 
create a Win/Loss 
Sparkline in G6 for the 
range C6:E6 

 

1 

2 

3 

For Your Reference… 

To create a Sparkline: 

1. Select the range for the data series 

2. Click on the Insert tab, then click on a 
Sparkline type in the Sparklines group 

3. Click in the location cell and click on [OK] 

Handy to Know… 

 You may need to increase the row height of 
rows which have Sparklines in them in order 
to see the trends clearly. 

7 
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EDITING SPARKLINES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sparklines in Excel are both easy to create and 
easy to edit. When a cell containing a Sparkline 
is selected, the Sparkline Tools: Design tab will 
appear on the ribbon. This tab allows you to 

change the type of Sparkline in the cell, its 
formatting and colouring, and to specify things such 
as high and low points. You can also fill Sparklines 
to adjacent cells.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Conditional 
Formatting_10.xlsx... 

 
Click in cell G4, then click 
on the Sparkline Tools: 
Design tab  

 
Click on the Sparkline 
Colour drop arrow in the 
Style group, then click on 
Green, Accent 6 to apply 
this colour to the Sparkline 

 
In the Show group, click 
on High Point so it is 
ticked  

The highest value in the 
Sparkline will appear in a 
different colour… 

 
Repeat step 3 to select 
Low Point to apply 
different colouring to the 
lowest point  

 
In the Type group, click on 
Line to change the 
Sparkline type from a 
column to a line 

 
Click in cell G5, then click 
on Clear in the Group 
group to remove the 
Sparkline from this cell 

 
Click in cell G6, then drag 
the fill handle down to G10 
to create more Sparklines 

 

2 

3 

5 

For Your Reference… 

To edit a Sparkline: 

1. Click on the cell or range containing the 
Sparkline(s) 

2. Use the commands on the Sparkline Tools: 
Design tab to make the appropriate changes 

Handy to Know… 

 You can edit multiple Sparklines by selecting 
the cells in which they are located as a 
range. 

 You can place a Sparkline in a cell 
containing data – the data and the Sparkline 
will simply appear together. 

7 
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CREATING CUSTOM RULES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise you 

MUST open the file Conditional 
Formatting_11.xlsx... 

 
Select the sales figures in cells 
C5:C16 

 
Click on the Home tab, then in the 
Styles group click on Conditional 
Formatting and select New Rule 
to display the New Formatting 
Rule dialog box 

 
Click on Use a formula to 
determine which cells to format 
to select it 

 
Click in Format values… and type 
=C5>=INDIRECT(“$B$”&ROW()) 

This formula checks each sales 
value in column C against its 
corresponding target value in 
column B… 

 
Click on [Format] to display the 
Format Cells dialog box, then on 
the Font tab select Bold in Font 
Style and Green in Colour 

 
Click on [OK] to close the Format 
Cells dialog box, then click on 
[OK] to close the New Formatting 
Rule dialog box to see how the 
conditional formatting formula 
affects your data 

 
Repeat steps 1 to 6 to create a 
new rule with the formula 
=C5<=INDIRECT(“$B$”&ROW()) 
and make the formatting Italic and 
Red 

 

For Your Reference… 

To create new conditional formatting rules: 

1. Select the cell range to be formatted 

2. On the Home tab click on Conditional 
Formatting and select New Rule 

3. Use the New Formatting Rule dialog box to 

create the rule, then click on [OK] 

You can use logical formulas to specify 
formatting criteria to create more complex 
conditional formatting. For example, you may 
wish to change the font colour of values that are 

over target or budget, and use a different font 
colour for values that are under target or budget. 
You can edit an existing rule or create a new rule to 
apply a formula to the formatting criteria. 

4 

Handy to Know… 

 You can enter cell references in a formula by 
selecting cells directly in a worksheet. 
Selecting cells in the worksheet inserts 
absolute cell references. If you wish for Excel 
to adjust the references for each cell in the 
selected range, use relative cell references. 

7 
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THE CONDITIONAL FORMATTING RULES MANAGER 
 

 

 

 

  

 

Each rule that you apply to a cell range is 
controlled by the Conditional Formatting Rules 
Manager. You can use this feature to edit rules, 
change the order in which multiple rules are 

evaluated, delete rules, or change any of the 
conditional formatting or formula criteria. 

The Conditional Formatting Rules Manager 

You can access the Conditional Formatting Rules Manager dialog box by selecting the cells that are 
controlled by the rules that you wish to change, clicking on the Home tab, then in the Styles group 
clicking on Conditional Formatting and selecting Manage Rules. In this dialog box you can specify 
whether you are changing the rules for the current selection of cells, the current worksheet, or another 
worksheet in the current workbook, before changing the order of precedence for rule evaluation and 
editing, adding and deleting rules as required. When you have made all of the required changes, click on 

[Apply], then click on [OK]. 

Conditional Formatting Rules Precedence 

When two or more conditional formatting rules apply to a range of cells, these rules are evaluated in 
order of precedence by how they are listed in the dialog box. A rule that is higher in the list has greater 
precedence than a rule that is lower in the list. By default, new rules are always added to the top of the 
list and therefore have a higher precedence; however you can change the order of precedence by using 
the [Move Up] and [Move Down] arrow buttons in the dialog box. 

The Stop If True Check Box 

Clicking in the Stop If True check box for a rule so that it appears ticked will cause the conditional 
formatting process to stop after applying that rule if it is true for a cell. For example, if the first rule in the 
list is applied to cells with a value lower than 100 and Stop If True is ticked for this rule, the conditional 
formatting process will stop here and no other rules will be applied to cells with a value lower than 100. 
However, the process will continue for cells to which that rule does not apply (i.e. cells with values higher 
than 100). If Stop If True is not selected, subsequent rules can be applied in conjunction with each 
other. 

Note that you cannot select or clear the Stop If True check box is the rule formats by using a data bar, 
colour scale or icon set. 
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MANAGING RULES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Conditional formatting rules can be created, 
edited, deleted and viewed in the Conditional 
Formatting Rules Manager dialog box. When 
two or more conditional formatting rules apply to 

a range of cells, these rules are evaluated in the 
order in which they are listed in this dialog box. You 
can change the order to give some rules 
precedence over others. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise you 

MUST open the file Conditional 
Formatting_12.xlsx... 

 
Select the range B11:F18, click 
on the Home tab, then in the 
Styles group click on Conditional 
Formatting and select Manage 
Rules 

 
Click on the last rule (Top 5), then 
click on Move Up three times to 
move it to the top of the list 

 
Click on [Apply] to apply the 
change to the worksheet 

 
Click on the Icon Set rule, then 
click on [Edit Rule] to display the 
Edit Formatting Rule dialog box 

 
Click on the drop arrow for Icon 
Style and select 5 Quarters, click 
on Show Icon Only so it appears 
ticked as shown, click on [OK] 
then click on [Apply] 

 
Click on the first Top 10 rule to 
select it, click on [Edit Rule], in 
Select a Rule Type click on 
Format only values that are 
above or below average to 
change the rule type, click on 
[OK], then click on [Apply] 

 
Click on the remaining Top 10 
rule to select it, then click on 
[Delete Rule] 

The rule is removed from the list… 

 
Click on [Apply], then click on 
[OK] to return to the worksheet 

 

2 

5 

For Your Reference… 

To manage conditional formatting options: 

1. Select the cell range containing the 
formatting to manage 

2. On the Home tab, click on Conditional 
Formatting and select Manage Rules 

3. Select the rule you wish to change, then 
make the necessary changes 

Handy to Know… 

 If you copy cells that have conditional 
formatting applied to other workbooks, the 
formatting is not copied or applied. 

 You can edit rules using the More Rules 
option on each of the individual conditional 
formatting rules options, such as Data Bars, 
Colour Scales and so on. 
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CHAPTER 7 TEXT FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of TEXT functions 

 learn how to use the PROPER function 

 learn how to use the UPPER and LOWER functions 

 learn how to use the CONCATENATE function 

 learn how to use the LEFT and RIGHT functions 

 learn how to use the MID function 

 learn how to use the LEN function 

 learn how to use the SUBSTITUTE function 

 learn how to use the T function 

 learn how to use the TEXT function 

 learn how to use the VALUE function. 

The Text functions provided with Microsoft Excel are designed to 
help you manipulate text strings. They are ideal for working with text 
fields when you have large volumes of data to convert 

INFOCUS 
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UNDERSTANDING TEXT FUNCTIONS 
 

 

 

 

  

Although most people perceive Excel’s primary 
function to be the manipulation of numbers, Excel 
also provides a range of functions for performing 
text manipulations. For more information on each 

function, you can refer to the Function reference 
section located on the Home page of Excel Help. 
For reference purposes only, the text functions are 
listed below. 
 

Text Functions 

Text functions are useful in situations where you might need to manipulate data that you receive from 
another source where the layout is not consistent with the layout that you have used. For instance, data 
retrieved from a database may place all address fields into a single cell, rather than separating the name, 
number, street, town and postcode data. The text might be in the wrong case (upper case instead of lower 
case) or contain non-printable characters. 

Below is a list of the available text functions 

 

BAHTEXT Converts a number to text 

CHAR Returns the character specified by the code number from the character set 
of your computer 

CLEAN Removes all nonprintable characters from text 

CODE Returns a numeric code for the first character in a text string 

CONCATENATE Joins strings of text into one continuous string 

DOLLAR Converts a number to text, using currency format 

EXACT Checks if two strings are the same 

FIND Returns the position of one text string within another 

FIXED Rounds a number as specified and returns the value as text 

LEFT Returns a specified number of characters from the left (start) of a string 

LEN Returns the number of characters in a string 

LOWER Converts all letters in a string to lowercase 

MID Returns a specified number of characters from the middle of a string 

PROPER Converts a text string to proper case 

REPLACE Replaces part of a text string with another text string 

REPT Repeats text a specified number of times 

RIGHT Returns a specified number of characters from the right (end) of a string 

SEARCH Returns the position number of the first occurrence of a specified 
character 

SUBSTITUTE Replaces existing text with new text in a text string 

T Checks whether a value is text 

TEXT Converts a value to text in a specified number format 

TRIM Removes all spaces from text strings except for single spaces between 
words 

UPPER Converts a string of text to uppercase 

VALUE Converts a text string that represents a number, to a number 
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USING THE PROPER FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The PROPER function is designed to convert a 
text string to what is known as proper case. This 
is where each word in the string begins with a 
capital (uppercase) letter and the rest of each 

word appears in lowercase. The PROPER function 
is ideal for converting uppercase text to a 
combination of upper and lower case text, which is 
much easier to read. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_1.xlsx... 

 
On the PROPER 
worksheet tab, click in 
cell F2 

 
Type =PROPER(B2) 

 
Press   to complete 

the formula 

The upper case first 
name is converted to 
proper case... 

 
Click in cell F2, then click 
on and drag the fill 
handle across to cell G2 
to copy the formula for 
the surname 

 
Ensure that F2:G2 is 
selected, then double-
click on the fill handle to 
copy the formula down 
the table 

 

2 

3 

For Your Reference… 

PROPER(text) 

 This function converts the specified text so that 
the first letter of every word appears in 
uppercase and the remainder of the word(s) 
appear in lowercase. 

Handy to Know… 

 As well as using the PROPER function to 
manipulate text case, you can also use the 
UPPER and LOWER functions. 

4 

5 
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USING THE UPPER AND LOWER FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The UPPER function is designed to convert a 
text string into all uppercase (capital) letters. Any 
existing uppercase letters retain their 
appearance, only lowercase letters are 

converted. The LOWER function is designed to 
convert a text string to lowercase and is ideal for 
converting text for web or email addresses and the 
like. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Text 
Functions_2.xlsx... 

 
Click on the UPPER 
worksheet tab, then click in 
cell F2 

 
Type =UPPER(E2) 

 
Press   to complete the 

formula 

The Type text is returned and 
converted to uppercase... 

 
Click in cell F2, then double-
click on the fill handle to copy 
the formula down the table 

Now let’s try the LOWER 
function... 

 
Click on the LOWER 
worksheet tab, then click in 
cell D2 

 
Type =LOWER(C2) 

 
Press  to complete the 

formula 

 
Click in cell D2, then double-
click on the fill handle to copy 
the formula down the table 

 

2 

3 

For Your Reference… 

UPPER(text) 

This function converts all specified text to 
uppercase. 

LOWER(text) 

This function converts all specified text to 
lowercase. 

Handy to Know… 

 As well as UPPER and LOWER, another 
handy function is PROPER. This function 
converts the first letter of each word in a text 
string to uppercase and all other characters 
to lower text. 

8 
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USING THE CONCATENATE FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The CONCATENATE function is designed to 
combine several strings of text into one. It is very 
useful for creating new cell values that are a 
combination of other cells, such as combining the 

first name and surname to create a complete name 
for a client. It can also be used to include text that 
does not appear anywhere else in a cell, such as 
spaces, symbols or other text. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_3.xlsx... 

 
Click on the 
CONCATENATE 
worksheet tab then click 
in cell D2  

 
Type 
=CONCATENATE(B2,  
C2, 
“@alpheius.com.au”) 

 
Press  to complete 

the formula 

The formula has taken 
the First Name in cell B2, 
added the Surname in 
cell C2 and then added 
the text string to complete 
the email address... 

 
Click in cell D2, then 
double-click on the fill 
handle to copy the 
formula down the table 

                               

1 

2 

3 

For Your Reference… 

CONCATENATE(text1, text2, ...) 

 This function joins the text in text1, text2, etc. 
together to form a single text string. 

4 

Handy to Know… 

 As well as using the CONCATENATE 
function to join text, you can use the 
ampersand (&) symbol. For instance, if cells 
B2 and C2 contained the text Fred and 
Wilson respectively, the formula =B2&C2 

will return the result FredWilson. 
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USING THE LEFT AND RIGHT FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4 

3 

6 

The LEFT and RIGHT functions are used to 
extract characters from text strings. LEFT will 
extract the specified number of characters from 
the left side of the string, whereas RIGHT will 

extract from the right end of the string. These 
functions might prove useful in a data list, where 
multiple pieces of information are provided in a 
single cell and you only want a part of that data. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file Text 
Functions_4.xlsx... 

 
On the LRM worksheet tab, 
click in cell B2 

Look at the data in the first 
column – the part number 
consists of a country (or 
continent), city and part 
number code. In this 
instance, we want to be able 
to separate the three 
elements to use them 
individually... 

 
Type =LEFT(A2,3) 

 
Press  to complete the 

formula 

The first three characters 
have been extracted, giving 
us the country code... 

 
Click in cell D2 and type 
=RIGHT(A2,3) 

 
Press  to complete the 

formula 

The part number is 
extracted... 

 
Select B2:D2, then double-
click on the fill handle to 
copy the formulas down the 
table 

 

2 

For Your Reference… 

LEFT(text, num_chars) 

 This function returns the specified number 
of characters from the left side of a text 
string. 

RIGHT(text, num_chars) 

 This function returns the specified number 
of characters from the right side of a text. 

Handy to Know… 

 The LEFT and RIGHT functions work best 
when the data is consistent. For instance, if 
all the text strings have a three-digit code 
that you want to extract, there are no 
problems, but if that code consists of more or 
less digits in some strings, you will have 
problems. 
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USING THE MID FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4 

3 

2 

1 

The MID function is designed to extract 
characters from the middle of a text string. It 
works the same as the LEFT and RIGHT 
functions. The difference being that the MID 

function enables you to indicate how many 
characters into the text string you want to extract 
from. For instance, by specifying 5, Excel will return 
the characters from the 5th character. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_5.xlsx... 

 
Ensure that the LRM 
worksheet is active, then 
click in cell C2 

 
Type =MID(A2,4,3) 

This indicates to Excel 
that you want to return 3 
characters starting with 
the 4th character in from 
the left... 

 
Press  to complete 

the formula 

Excel will return the 
three digit city code... 

 
Click in cell C2, then 
double-click on the fill 
handle to copy the 
formula down the table 

 

For Your Reference… 

MID(text, start_num, num_chars) 

 This function returns the specified number 
of characters from the middle of a text 
string, where start_num indicates the 
position of the first character to extract. 

Handy to Know… 

 To return characters from the left or right side 
of a text string, use the LEFT and RIGHT 
functions respectively. 
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USING THE LEN FUNCTION 
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The LEN function enables you to return the 
number of characters in a cell containing a text 
string. The function will count characters 
including leading, trailing and any other spaces. 

LEN can be used in conjunction with other 
functions, such as LEFT or RIGHT, to return exact 
numbers of characters, or to report text lengths if 
this impacts elsewhere in a worksheet. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_6.xlsx... 

 
Click on the LEN 
worksheet tab, then click 
in cell E2 

 
Type =LEN(D2) 

 
Press  to complete 

the formula 

There are 11 characters 
in the email name... 

 
Click in cell E2, then 
double-click on the fill 
handle to copy the 
formula down the table 

 

2 

For Your Reference… 

LEN(text) 

Returns the length of a specified text string. 

3 

Handy to Know… 

 The LEN function calculates the number of 
characters in a string including space 
characters. 

4 
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USING THE SUBSTITUTE FUNCTION 
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The SUBSTITUTE function is designed to 
replace old text with new text. This might be 
useful for making a universal change to email 
data if a company name changes. It might also 

be useful in the situation where you have imported 
text and you want to update it with new information. 
The function enables you to substitute all instances 
of the text or just a specific one. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_7.xlsx... 

 
Click on the 
SUBSTITUTE worksheet 
tab, then click in cell E2 

 
Type 
=SUBSTITUTE(D2,"alp
heius","AGE") 

 
Press  to complete 

the formula 

The text “alpheius” in the 
email address is 
replaced with “AGE”... 

 
Click in cell E2, then 
double-click on the fill 
handle to copy the 
formula down the table 

 

2 

3 

For Your Reference… 

SUBSTITUTE(text, text_old, text_new, 
instance_num) 

 This function replaces the specified text_old 
with the specified text_new within a 
specified text string. instance_num 
indicates which occurrence to change. 

Handy to Know… 

 Using the SUBSTITUTE function, the 
instance_num parameter enables you to 
specify which occurrence of the old text you 
want to replace. If you specify an 
instance_num, only that occurrence is 
changed, otherwise all occurrences are 
changed. 

4 
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USING THE T FUNCTION 
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The T function is a left over from Lotus days and 
is used to return the text referred to by a value. If 
a cell contains content other than text, no value 
will be returned. Generally, you will not need to 

use this function, as Excel automatically converts 
values as necessary. The function is primarily 
provided for compatibility with other spreadsheet 
programs. 

Try This Yourself: 

S
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m
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Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_8.xlsx... 

 
Click on the T and 
VALUE worksheet tab, 
then click in cell E3 

 
Type =T(D3) 

 
Press  to complete 

the formula 

The value “Rainfall” is 
returned as the value in 
cell D3 is text... 

 
Click in cell E3, then 
double-click on the fill 
handle to copy the 
formula down the table 

Only those formulas that 
refer to a cell containing a 
text value will return a 
value 

 

2 

For Your Reference… 

T(value) 

 Returns the text referred to by a value. 

Handy to Know… 

 As well as the T function, the VALUE 
function is also a left-over from the Lotus 
days and generally not used in Excel 
formulas. However, both functions are still 
provided for compatibility with other 
spreadsheet applications. 

4 

3 
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USING THE TEXT FUNCTION 
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The TEXT function enables you to convert 
numeric values to text and apply a specified 
number format. The benefit of applying the TEXT 
function, as opposed to applying a number 

format, is that the value will be converted to 
formatted text and no longer used in calculations. 
This is useful if you want to display numbers 
combined with text or symbols. 

Try This Yourself: 

S
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m
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Continue using the 
previous file with this 
exercise, or open the file 
Text Functions_9.xlsx... 

 
Click on the TEXT 
worksheet tab, then click in 
cell D2 

In this example we will 
calculate the Invoice 
amount based on the 
Charge Period. If it is over 
12 hours the Price will be 
invoiced on a daily rate, 
otherwise it will be invoiced 
on an hourly rate... 

 
Type 
=IF(C2>12,(TEXT(B2,"$0.0
0")&" per day"), 
(TEXT(B2,"$0.00”) & "per 
hour"))) 

The formula has been split 
here due to space 
constraints, but it should be 
typed as one continual 
string, as shown... 

 
Press  to complete the 

formula, then double-click 
on the border between 
column D and column E to 
resize column D  

 
Click in cell D2, then 
double-click on the fill 
handle to copy the formula 
down the table 

 

2 

3 

For Your Reference… 

TEXT(value, format_text) 

 This function coverts a value to text in 

aspecified number format. 

Handy to Know… 

 The format_text parameter of the TEXT 
function is a Number format written in text 
form. You can select any format from the 
Number tab in the Format Cells dialog box, 

except for the General number format. 

4 
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USING THE VALUE FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3 

1 

The VALUE function converts a text string that 
resembles a number, into a number. Like the T 
function, this function is a left-over from the Lotus 
days and is generally not used a lot in Excel now. 

It is still incorporated for compatibility with other 
spreadsheet applications. It might be useful in 
converting numbers that have been imported and 
converted to text as a part of that process. 

Try This Yourself: 

S
a

m
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Continue using the previous 
file with this exercise, or 
open the file Text 
Functions_10.xlsx... 

 
Click on the T and VALUE 
worksheet tab, then click in 
cell A3 

Notice that although the cell 
content appears like a date, 
it is in fact a text field – the 
General format is displayed 
in the Number group on the 
HOME tab... 

 
Click in cell B3 and type 
=VALUE(A3) 

 
Press  to complete the 

formula 

The value from cell A3 is 
copied across and 
converted to a serial 
number – let’s apply a date 
format to the cell... 

 
Click in cell B3, then click 
on the dialog box launcher 
for the Number group on 
the Home tab to display the 
Format Cells dialog box 

 
On the Number tab, click 
on Date in Category, click 
on  14/3/12 , then  click 
on[OK] to apply the format 

 
Repeat steps 2 to 5 for cells 
B6, B9, B12 and B15 

 

2 

For Your Reference… 

VALUE(text) 

 This function converts a text string to a 
number. 

Handy to Know… 

 For the VALUE function to work, the text 
string must be in a number, date or time 
format recognised by Excel. If this is not the 

case, #VALUE! is returned. 

5 
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CHAPTER 8 PIVOTTABLES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of PivotTables in Excel 

 learn how to use the Recommended PivotTable feature 

 learn how to create your own PivotTable 

 learn how to drag fields into a PivotTable shell 

 learn how to filter the data in a PivotTable 

 learn how to clear a filter in a PivotTable report 

 learn how to switch fields around in a PivotTable 
structure 

 learn how to apply formatting to a PivotTable 

 gain an understanding of Slicers 

 learn how to insert a Slicer 

 learn how to insert a timeline filter. 

PivotTables can help you make sense of tabular (aka list) data. 

While you are most likely used to creating numerical models, Excel 
also allows you to record data in a list format. For instance, it could 
be a list of daily sales, songs in your music collection, or a list of 
petty cash purchases over the last three months. Trying to make 
sense of the data in a small list is fairly straightforward but when 
your list extends to many dozens, hundreds, or even thousands of 
rows of information, trying to manually analyse the data and extract 
useful information can be tedious. Fortunately PivotTables makes 
this task much easier. 

INFOCUS 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 82 Chapter 8 - PivotTables 

UNDERSTANDING PIVOTTABLES 
 

 

 

 

 

If you have organised your data into columns and 
rows in Excel you have what is known as a 
database or a list. The first row in the list is 
normally used for column headings while each 

row contains a separate record of data. In Excel 
PivotTables can be used to analyse lists and ask 
two-dimensional questions where one column of 
data can be compared against another. 

Asking The Question 

PivotTables are used to interrogate (ask questions of) the data in the 
list. For example, from the list above you may want to know how much 
has been made in sales by each salesperson over the three months of 
data in the list. 

The question is phrased by using the PivotTable Fields pane. 

The PivotTable Fields pane 

The PivotTable Fields pane displays by default when you create a 
PivotTable or when an existing PivotTable is selected. It contains a list 
of all fields within the selected data as well as four areas – FILTERS, 
COLUMNS, ROWS and VALUES. By dragging the relevant fields into 
these special areas you can define how you want your data sorted and 
analysed. 

In the example to the right, the Salesperson field has been dragged to 
the ROWS area, and the Month field has been dragged to the 
COLUMNS area. Since we want to know how much has been made by 
each salesperson in sales, the Price field has been dragged to the 
VALUES area where it is summed by default (since it is a numeric field). 

 

The List 

The following list shows the 
column or field headings 
across the top of the list. Each 
row in the list is equivalent to 
one record. Our example 
actually holds 102 records – 
although you couldn’t easily 
tell without scrolling down. 

Also, the list can’t include any 
blank rows (records) or 
columns. The first blank row or 
column to be encountered is 
deemed to be the end of the 
list. 

Obtaining The Answer 

As you drag fields into the relevant area, Excel 
will start analysing the data. 

When the Price field was dragged to the 
VALUES area, the PivotTable created the table 
as shown. We now know that Hector Smith made 
61,358 in the month of February. 
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RECOMMENDED PIVOTTABLES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Recommended PivotTables feature is very 
handy as it can save you valuable time and 
provides you with useful suggestions for times 
when you may not be sure of what fields you 

want to use to summarise your data. It provides 
you with several different options and shows you a 
preview of what the different PivotTables will look 
like and the kind of data they will supply you with. 
 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
PivotTables_1.xlsx… 

 
Click anywhere in the list of 
sales 

Excel will generate the list 
dimensions based on where 
you’ve clicked… 

 
Click on the Insert tab, then 
click on Recommended 
PivotTables in the Tables 
group to display the 
Recommended PivotTables 
dialog box 

Notice the left pane displays 
previews of various 
PivotTable options based on 
sorting your data by different 
factors… 

 
Click on the previews in the 
left pane to view a larger 
preview in the right pane  

 
Scroll down, then click on 
Sum of Price by Make and 
Age Grouping in the left 
pane and click on [OK] 

A new sheet will be created 
with the PivotTable inserted. 
The PivotTable Fields pane 
will display to the right of the 
screen 

 

1 

2 

For Your Reference… 

To create a quick PivotTable: 

1. Click anywhere in a valid list 

2. Click on the Insert tab, then click on 
Recommended PivotTables in the Tables 
group 

3. Click on the desired option, then click on 
[OK] 

Handy to Know… 

 Using the Recommended PivotTables 
dialog box, you can select to create a blank 
PivotTable by clicking on [Blank 
PivotTable]. You can also choose to change 
the data source by clicking on Change 
Source Data which will then display the 

Choose Data Source dialog box. 

3 
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CREATING YOUR OWN PIVOTTABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Creating a PivotTable from scratch provides you 
with greater control. The PivotTable structure 
can be placed either in the current worksheet or 
in a new sheet in the workbook. When the 

structure, which we’ll refer to as a shell, is selected, 
the PivotTable Fields pane will display showing 
the fields that can be used – these fields are based 
on the headings in the data list.  

Try This Yourself: 

O
p

e
n

 

F
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e
 

Before starting this 
exercise you MUST 
open the file 
PivotTables_2.xlsx… 

 
Click on the Data Sheet 
worksheet tab to see the 
data list 

 
Click anywhere in the list  

Excel will work out the 
list dimensions based on 
where you’ve clicked… 

 
Click on the Insert tab, 
then click on PivotTable 
in the Tables group to 
display the Create 
PivotTable dialog box 

This dialog box is used 
to specify the data list 
(which is already done) 
and also where to place 
the PivotTable… 

 
Ensure that Select a 
table or range and New 
Worksheet are both 
selected, then click on 
[OK] to create a new 
sheet with a PivotTable 
shell  

Notice the PivotTable 
Fields pane displays by 
default at the right of the 
screen 

 

3 

4 

For Your Reference… 

To create your own PivotTable: 

1. Click anywhere in a valid list 

2. Click on the Insert tab, then click on 
PivotTable in the Tables group 

3. Ensure the table range is correct, choose the 

location then click on [OK] 

Handy to Know… 

 It is usually best to place the PivotTable in a 
separate worksheet away from the main data 
list. It’s far too easy to accidentally delete list 
data or PivotTable settings when the two are 
in the same sheet. 
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DEFINING THE PIVOTTABLE STRUCTURE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The structure of the PivotTable is made up of 
fields. The fields available for use are presented 
to you in the PivotTable Fields pane which 
appears when a PivotTable is created. The 

structure of the PivotTable is created by dragging 
the fields you want to use into special areas located 

at the bottom of the PivotTable Fields pane.  

Try This Yourself: 

S
a

m
e

 

F
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Continue using the 
previous file with this 
exercise, or open the file 
PivotTables_3.xlsx... 

 
In the PivotTable Fields 
pane, point to Month so the 
cursor changes to a four-
headed arrow, as shown 

 
Click and hold down the left 
mouse button, drag the 
Month field to the 
COLUMNS area of the 
pane, then release the 
mouse button  

The months will now 
appear as columns in the 
PivotTable structure… 

 
Repeat step 2 to position 
the Salesperson field in 
the ROWS area of the pane 

The Salesperson names 
will now appear in rows in 
the left column of the 
PivotTable structure… 

 
Repeat step 2 to position 
the Price field in the 
VALUES area of the pane 

Excel will sum the price 
(sales) by month and by 
salesperson 

 

For Your Reference… 

To define the PivotTable structure: 

1. Point to the desired field in the PivotTable 
pane 

2. Click and drag the field into the COLUMNS, 
ROWS, or VALUES area of the pane as 
required 

Handy to Know… 

 The VALUES area is almost always used for 
some form of numeric value (often currency) 
as it is here that data is summed, counted, 
averaged, and the like. 

4 1 
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FILTERING A PIVOTTABLE 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Unless you specify otherwise, all of the data in a 
list will be analysed when you create or modify a 
PivotTable. However, you can set up your 
PivotTable to work with specific data by applying 

a filter. This can be done by dragging an additional 
variable (field) to the FILTERS area in the 

PivotTable Fields pane. 

Try This Yourself: 

S
a

m
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 Continue using the previous 

file with this exercise, or open 
the file PivotTables_4.xlsx... 

 
In the PivotTable Fields 
pane, point to the Age 
Grouping field, then click 
and drag the field to the 
FILTERS area of the pane 

 
In the worksheet, click on the 
drop arrow that has appeared 
to the right of the heading 
Age Grouping (All) to 
display a list of all of the 
values in the field  

 
Click on 25 or less to select 
this option, then click on [OK] 
to see the summed sales for 
customers aged 25 or under 

Notice in the worksheet and 
in the PivotTable Fields pane 
a filter icon has appeared on 
the drop arrow for the Age 
Grouping field… 

 
Repeat step 3 for some of the 
other age grouping options 

 
Repeat step 2, then click on 
Select Multiple Items so it 
appears with a tick 

 
Ensure no other options are 
selected, click on 46 – 55 and 
Over 55 so that they both 
appear with a tick, then click 
on [OK] 

 

2 

3 

For Your Reference… 

To filter a PivotTable: 

1. Drag the field you wish to use as a filter 
criteria to the FILTERS area 

2. Click on the filter drop arrow in the 
PivotTable  

3. Click on the filter criteria and click on [OK]  

6 

Handy to Know… 

 There are also filter drop arrows for Column 

Labels and Row Labels.  
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CLEARING A REPORT FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Report filters provide another dimension to 
PivotTables allowing you to be selective in the 
data that is actually analysed. When you no 
longer require the filtering operation you can 

simply advise the filter that you wish to see all of 
the data again. Alternatively, if you no longer need 
to retain the filter you can remove the entire filter 
field from the FILTERS area. 

Try This Yourself: 

S
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Continue using the 
previous file with this 
exercise, or open the file 
PivotTables_5.xlsx... 

 
In the worksheet click on 
the drop arrow to the right 
of Age Grouping to see 
the filter list 

 
Click on Select Multiple 
Items so it appears 
unticked 

 
Click on All then click on 
[OK] to see all of the data 
summed again 

If you no longer require a 
filter you can remove the 
entire filter structure from 
the table… 

 
Point to the Age Grouping 
field in the FILTERS area in 
the PivotTable Fields 
pane and drag the field 
listing out of the FILTERS 
area until a cross appears 
with your cursor then 
release the mouse button 

Notice that the Age 
Grouping field label has 
also been removed from 
the worksheet 

 

2 

4 

For Your Reference… 

To clear a report filter: 

1. Click on the drop arrow button at the right of 
the filter field in the table 

2. Click on All 

3. Click on [OK] 

Handy to Know… 

 To remove a field from the areas at the 
bottom of the PivotTable Fields pane, click 
on a field and drag it outside of the area. The 
name of the field will appear with your cursor 
and when a cross appears below the field 
name, release the mouse button and the field 
will be removed from the area. 
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SWITCHING PIVOTTABLE FIELDS 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

At any time, once you have created a PivotTable, 
you can modify the ROWS or COLUMNS and 
essentially ask a brand new question of the 
existing PivotTable report. When you add or 

remove fields, the PivotTable will automatically 
analyse the data based on the new settings. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
PivotTables_6.xlsx... 

 
In the PivotTable 
Fields pane point to 
Salesperson in the 
ROWS area, then click 
and drag the field 
outside of the ROWS 
area to remove it 

Notice now how only the 
Column totals are left in 
the table… 

 
In the PivotTable 
Fields pane, click and 
drag the Payment 
Method field to the 
ROWS area 

You should now see 
sales by Payment 
Method over the three 
months… 

 
Repeat step 1 to remove 
the Payment Method 
field from the ROWS 
field, then click and drag 
the Make field to the 
ROWS area 

You should now see the 
sales by Make of vehicle 
over the three months 

 

2 

For Your Reference… 

To modify the structure of a PivotTable: 

1. Click on a field in either the ROWS or 
COLUMNS area 

2.  Click and drag it to a different location in the 
PivotTable Fields pane 

3 

Handy to Know… 

 Wondering what Defer Layout Update on 
the PivotTable Fields pane does? If this 
option is ticked, changes made to the 
structure of the table aren’t seen in the 
worksheet until [Update] is clicked. This can 
be used on large lists which may take a while 
to recalculate. 
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FORMATTING A PIVOTTABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PivotTables can be cryptic at the best of times, 
especially with the jargon and terminology used. 
The comprehension of a PivotTable is not 
always helped by the standard formatting applied 

by Excel. Fortunately, using the options on the 
PIVOTTABLE TOOLS: DESIGN tab of the ribbon 
you can format a PivotTable, thus making the 
PivotTable easier to understandable. 

Try This Yourself: 

S
a

m
e
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e
 Continue using the 

previous file with this 
exercise, or open the file 
E1339 
PivotTables_7.xlsx... 

 
Click on the PivotTable 
Tools: Design tab, then 
click on Banded Rows in 
the PivotTable Style 
Options group so it 
appears ticked 

Coloured bands will 
appear in the PivotTable… 

 
Click on Banded 
Columns in the 
PivotTable Style Options 
group so it appears ticked 
to apply column bands in 
the PivotTable 

 
Remove the tick from both 
Banded Rows and 
Banded Columns in the 
PivotTable Style Options 
group to remove the 
banding 

 
Click on the More arrow 
for the PivotTable Styles 
gallery in the PivotTable 
Styles group, then point to 
the various options to view 
a Live Preview of the 
styles 

 
Click on Pivot Style Light 
24 to apply it to the 
PivotTable 

 

1 

2 

For Your Reference… 

To format a PivotTable: 

1. Click on the PIVOTTABLE TOOLS: DESIGN 
tab  

2. Click on an option  

5 

Handy to Know… 

 When formatting a PivotTable, you can use 
the standard formatting options for 
worksheets rather than apply a style from the 
PivotTable Style gallery. 
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UNDERSTANDING SLICERS 
 

 

 

 

  

 

 

 

 

 

 

  

Slicer Buttons 

When you create a Slicer for a PivotTable Excel will place a new graphics object on the worksheet. The 
object is just a rectangle with a series of filter buttons. There is a button for each unique example of data 

in the field you have chosen for your Slicer.  

A Slicer is a filter for one field of your table. In the example above a Slicer has been created for the 
Salesperson field. Since there are three sales people in the table a filter button is created for each 
salesperson. In the example above the filter button for Hector Smith has been clicked and Excel displays 
the monthly sales by make of vehicle for Hector in the PivotTable report. 

What’s really neat with Slicers, is that you can have more than one Slicer associated with your report as 
shown below. 

 

In the example above three Slicers have been created – one for Salesperson, one for Type (of vehicle), 
and another for Year (of vehicle manufacture). With this type of Slicer you could work out the total sales 
of 1999 coupes by Hector, or the total SUV sales by Justin, and the like. 

 

A Slicer is a very special filter that can be applied 
to a PivotTable listing. Slicers slice through your 
data providing instant cross-referencing views. 
Admittedly these cross-reference views can be 

created by more traditional PivotTable filters, but 

the new Slicers make the task very easy indeed. 
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CREATING SLICERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Slicers are special field filters that can be applied 
to Excel tables. They are most useful for further 
dissecting an existing PivotTable report in a 
worksheet. Slicers are actually graphics objects 

comprising of a rectangle and special filter buttons. 
Slicers are inserted into the worksheet from the 

Slicer command on the INSERT tab of the ribbon. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
PivotTables_8.xlsx... 

 
Click anywhere in the 
PivotTable in the Sheet2 
worksheet 

 
Click on the Insert tab, 
then click on Slicer in the 
Filters group to display the 
Insert Slicers dialog box 

This box shows a tick box 
next to each of the fields 
from the data source… 

 
Click on the tick box for 
Salesperson and click on 
[OK] to display a Slicer 
box with the salespeople in 
it 

 
Click on Hector Smith to 
see only the sales made 
by Hector Smith 

 
Click on Mary O’Dwyer to 
see only the sales made 
by Mary O’Dwyer 

 
Click on Clear Filter in the 
Slicer box to see all of the 
sales again 

 

2 

For Your Reference… 

To insert a slicer into a PivotTable: 

1. Click anywhere in the PivotTable 

2. Click on the INSERT tab and click on Slicer 
in the Filters group 

3. Tick the field(s) to slice and click on [OK] 

Handy to Know… 

 You can filter on more than one field. To do 
this click on the first sample, then hold down 

 and click on subsequent samples. 

3 

4 
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INSERTING A TIMELINE FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

  

Inserting a timeline for your PivotChart is a quick 
and easy way of filtering your data using the date 
field. A timeline allows you to quickly navigate 
data so that you can see data relating to specific 

time periods. The timeline is separate to your 
PivotChart and can be moved around the screen as 
you desire.  
 
 

Try This Yourself: 

S
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e
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Continue using the 
previous file with this 
exercise, or open the file 
PivotTables_9.xlsx... 

 
Click in the PivotTable, 
then click on the 
PivotTable Tools: 
Analyse tab  

 
Click on Insert Timeline in 
the Filter group to display 
the Insert Timeline dialog 
box 

 
Select Date so that it 
appears ticked, then click 
on [OK] 

The date window will 
appear, displaying the 
timeline… 

 
Click on the box below Feb 
to view only the sales for 
February in the PivotTable 

 
Click on the drop arrow for 
MONTHS, then select 
DAYS 

 
Scroll to the right to see the 
timeline section for FEB 
2014, then click on the box 
below 9  to only view the 
sales for Sunday 9 Feb 
2014 

 
Press  +  to clear the 

filter and view all the data 
again 

 

4 
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For Your Reference… 

To insert a timeline filter:  

1. Click on the PivotTable Tools: Analyse tab, 
then click on Insert Timeline in the Filter 
group 

2. Click on various section of the timeline to 
view the data for that specific time period 

Handy to Know… 

 When you insert a timeline the contextual 
tab, Timeline Tools: Options will appear. 
You can use this tab to customise the 
appearance of the Date window.  

 To remove the timeline, simply click on the 
window to select it and press . 

6 
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CHAPTER 9 PIVOTTABLE FEATURES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to use compund field variables in a PivotTable 

 learn how to count the values in a PivotTable and 
perform other summary operations 

 learn how to format the values in a PivotTable  

 learn how to hide and show grand totals in a PivotTable  

 learn how to switch PivotTable report subtotals on and 
off 

 learn how to show a percentage of total in a PivotTable  

 learn how to find the difference between specific values 
in a PivotTable 

 learn how to group fields in a PivotTable 

 learn how to create a running total in a PivotTable 

 learn how to create calculated fields in a PivotTable  

 learn how to create custom names for PivotTable fields 

 learn how to create calculated items in a PivotTable 

 learn how to make changes to PivotTable options 

 learn how to sort values in a PivotTable. 

PivotTables provide a very easy and convenient way of analysing 
data in lists and external databases. Once you have mastered the 
basics of how they work and how they are created, you are ready to 
begin a journey into some of the more intricate and advanced 
aspects of PivotTable design, operation, and even formatting. 

INFOCUS 
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USING COMPOUND FIELDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5 4 

Simple PivotTables use only one field for 
Column Labels or Row Labels. In an Excel 
PivotTable you can use more than one field for 
either the Column Labels or Row Labels to 

create more complex analysis of the data. Once 
you have chosen a second field for analysis that 
field in effect becomes a sub-group of the field 
above it in the area. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
PivotTable Features_1.xlsx… 

 
Click anywhere in the list of 
car sales 

 
Click on the Insert tab, then 
click on PivotTable in the 
Tables group to display the 
Create PivotTable dialog box 

 
Ensure that Select a table or 
range and New Worksheet 
are both selected, then click 
on [OK] to create a 
PivotTable 

Notice the PivotTable Fields 
pane displays automatically… 

 
In the PivotTable Fields 
pane, click on and drag the 
Month, Make and Price 
fields into the COLUMNS, 
ROWS and VALUES areas, 
as shown 

 
Repeat step 4 to position the 
Age Grouping field below 
Make in the ROWS area 

This will create an Age 
Grouping sub-total for each 
vehicle Make in the table… 

 
Repeat step 4 to position the 
Type field below Month in 
the COLUMNS area to see 
monthly sales by Make and 
Age Grouping for vehicle 
Types 

 

2 

For Your Reference… 

To use compound fields: 

1. Construct a PivotTable and insert fields in 
the normal way 

2. In the PivotTable Fields pane, click on and 
drag additional fields to the areas under 
Drag fields between areas below 

Handy to Know… 

 You can change how the fields are displayed 
in the PivotTable Fields pane by clicking on 
Tools and selecting an option. For instance, 
if you select Fields Section and Areas 
Section Side-By-Side, the pane will display 
the areas section to the right of the fields list 
rather than below it. 

6 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 95 Chapter 9 - PivotTable Features 

COUNTING IN A PIVOTTABLE  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As a default Excel assumes that you will be using 
your PivotTable report to summarise (total) data 
from your list. However, you can actually choose 
from a number of different analytical operations 

to perform on the data in a PivotTable. Apart from 
summing data, another often-used operation is to 

count the data. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file PivotTable 
Features_2.xlsx... 

 
In the PivotTable, click in cell 
A3 (the Sum of Price 
heading) 

 
On the PivotTable Tools: 
Analyse tab, click on Field 
Settings in the Active Field 
group 

The Value Field Settings 
dialog box will display… 

 
Click on Count, then click on 
[OK] to see a count of the 
values rather than a 
summation 

 
Right-click in cell A3, point to 
Summarise Values By, then 
select Average to see 
average sales 

 
Point to cell C6 to see a 
description of the cell 
calculation 

 
Repeat step 4 and try some 
other options 

 
Right-click on cell A3 and 
select Summarise Values By 
> Sum to see total sales again 

 

1 

2 

For Your Reference… 

To change the summation operation: 

1. Select the summation values cell 

2. Click on the PivotTable Tools: Analyse tab, 
then click on Field Settings in the Active 
Field group  

3. Click on the desired Summarise Value and 
click on [OK] 

Handy to Know… 

 You can display the Value Field Settings 
dialog box by right-clicking on a value in a 
PivotTable pointing to Summarise Values 

By, then selecting More Options. 

4 



Microsoft Excel 2016 - Using as a Database 

© 2017 The University of Nottingham Page 96 Chapter 9 - PivotTable Features 

FORMATTING PIVOTTABLE VALUES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Unless you specify otherwise, the calculated 
values in a PivotTable will appear unformatted. 
This may be satisfactory while performing 
analysis, however, should you wish to print the 

data for others to see it would be far better if the 
values could be formatted so they are readable, 
presentable and understandable.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
PivotTable 
Features_3.xlsx... 

 
In the PivotTable, click in 
cell A3 (the Sum of 
Price heading) 

 
On the PivotTable 
Tools: Analyse tab, click 
on Field Settings in the 
Active Field group to 
display the Value Field 
Settings dialog box 

 
Click on [Number 
Format] in the bottom 
left corner of the dialog 
box to display the 
Format Cells dialog box 

 
Click on Number under 
Category, then adjust 
the settings as shown 

 
Click on [OK] twice to 
return to the formatted 
data 

Notice that commas have 
been inserted in the 
numbers where 
appropriate... 

 

2 

4 

For Your Reference… 

To format values in a PivotTable report: 

1. Click on the values cells, click on the 
PivotTable Tools: Analyse tab, then click 
on Field Settings in the Active Field group 

2. Click on [Number Format], Choose the 

desired format, then click on [OK]  

5 

Handy to Know… 

 Each time the PivotTable is recalculated, the 
number formats are set to those shown in the 
Field Settings command. 
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WORKING WITH PIVOTTABLE GRAND TOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As a default, Excel’s PivotTable reports will 
appear with grand totals at the end of the rows 
and at the end of the columns. These can be 
switched off and on as required. There may be 

times, for example, when you are interested only in 
the data values themselves and not in the grand 
totals. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
PivotTable 
Features_4.xlsx... 

 
Click anywhere in the 
PivotTable  

 
Click on the PivotTable 
Tools: Design tab, then 
click on Grand Totals in 
the Layout group to 
display a list of options 

 
Select Off for Rows 
and Columns to turn 
the grand totals off for 
rows and columns 

 
Repeat steps 2 and 3 to  
select On for Rows 
Only to display the 
grand totals for rows 
only 

 
Repeat step 2 and 3 to 
hide the grand totals 
again  

 

2 

4 

For Your Reference… 

To remove the grand totals from a PivotTable: 

1. Click on the PivotTable Tools: Design tab 

2. Click on Grand Totals in the Layout group 

3. Select the desired option 

5 

Handy to Know… 

 You can show and hide Grand Totals by 
clicking on the PivotTable Tools: Analyse 
tab and clicking on Options in the 
PivotTable group to display the PivotTable 
Options dialog box. Using the Totals & 
Filters tab, you can then switch the grand 
totals on or off. 
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WORKING WITH PIVOTTABLE SUBTOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you add fields to the Column Labels or 
Row Labels area of the PivotTable Fields pane, 
Excel assumes that you also wish to subtotal the 
values for these fields. As a result, subtotals will 

appear at the end of each field value, both column 
and row, in the PivotTable. These can be switched 
off if not required. 
 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file PivotTable 
Features_5.xlsx... 

 
In the PivotTable click 
in cell B4 (Jan) 

 
Click on the 
PivotTable Tools: 
Analyse tab, then 
click on Field 
Settings in the 
Active Field group to 
display the Field 
Settings dialog box 

 
Ensure the Subtotals 
& Filters tab is 
selected, then click 
on None in Subtotals 
to select this option 

 
Click on [OK] to 
remove the monthly 
subtotals and close 
the dialog box 

 
Click in cell A6 
(BMW) 

 
Repeat steps 2 and 3 
to remove the 
subtotals for Make 

 

4 

For Your Reference… 

To show or hide subtotals in a PivotTable: 

1. Click in the first row or column value cell 

2. Click on the PivotTable Tools: Analyse tab, 
then click on Field Settings in the Active 
Field group  

3. Click on the Subtotals & Filters tab, click on 
None in Subtotals, then click on [OK] 

1 

Handy to Know… 

 You can turn off all subtotals in a PivotTable 
simultaneously by clicking on the PivotTable 
Tools: Design tab, clicking on Subtotals in 
the Layout group and selecting Do Not 

Show Subtotals. 

6 
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FINDING THE PERCENTAGE OF TOTAL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PivotTables provide their analysis results as 
tables. During the process, grand totals and 
subtotals are calculated and presented. To assist 
in further analysis of the data it is possible to 

have the PivotTable report calculate the 
percentage of each value against the row total, the 
column total, and even the grand total. This is 
handy for comparative purposes.  

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file PivotTable 
Features_6.xlsx... 

 
Click in cell B5 to activate 
the PivotTable then click 
on the PivotTable Tools: 
Analyse tab  

 
Click on Field Settings in 
the Active Field group to 
display the Field 
Settings dialog box, then 
click on the Show Values 
As tab 

 
Click on the drop arrow 
for Show values as, then 
select % of Row Total 

 
Click on [OK] to see each 
month represented as a 
percentage of the total 

 
Repeat step 2 to display 
the Show Values As tab 
in the Field Settings 
dialog box 

 
Click on the drop arrow 
for Show values as, 
select % of Column 
Total, then click on [OK] 

 

1 

3 

For Your Reference… 

To find the percentage of total: 

1. Click in a data value cell 

2. Click on the PivotTable Tools: Analyse tab, 
then click on Field Settings in the Active 
Field group  

3. Click on the Show Values As tab, click on % 
of row or % of column, then click on [OK]
  

Handy to Know… 

 You can select to show a set of values as a 
percentage by right-clicking on a value in the 
PivotTable and pointing to Show Values As 
to display a list of options. Select an option to 
apply it to the set of values. 

6 
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FINDING THE DIFFERENCE FROM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you need to compare field values from columns 
in a table you can use the Difference From 
option. In our case study we have three months 
of data. Using Jan as the base month, we can 

use the Difference From option to compare the 
values for the months of Feb and Mar against the 
values of Jan. 
 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file PivotTable 
Features_7.xlsx... 

 
Click in cell B5 to activate 
the PivotTable, then click 
on the PivotTable Tools: 
Analyse tab  

 
Click on Field Settings in 
the Active Field group to 
display the Field Settings 
dialog box, then click on 
the Show Values As tab 

 
Click on the drop arrow for 
Show values as, then 
scroll down to and click on 
Difference From 

 
Click on Month in Base 
field and ensure Jan is 
selected in Base item 

The Base field is the field 
used to compare all other 
values to, while Jan is the 
“base item” in the base 
field against which 
comparisons are made… 

 
Click on [OK] to see how 
the values in Feb and Mar 
differ from the 
corresponding base 
values in Jan 

 

1 

4 

For Your Reference… 

To find the difference from: 

1. Click in a data value cell, then click on 
PivotTable Tools: Analyse > Field 
Settings  

2. Click on the Show Values As tab, then click 
on Difference From, specify the Base field 

and Base item, then click on [OK] 

Handy to Know… 

 Using the Show Values As tab in the Value 
Field Settings dialog box you can select % 
Difference From which, as the name 
suggests, shows the difference from a base 
item but expressed as a percentage rather 
than as a value. 

5 
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GROUPING IN PIVOTTABLE REPORTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file PivotTable 
Features_8.xlsx... 

 

This PivotTable report is 
derived from a list of petty 
cash transactions found in 
the Petty Cash Receipts 
worksheet. The table 
sums the transactions by 
Date (rows) and 
Description (columns)… 

 
Click in cell A5 – this is 
the first cell with a date in 
it 

 
On the PivotTable Tools: 
Analyse tab, click on 
Group Selection in the 
Group group to display 
the Grouping dialog box 

 
Ensure that Months is 
selected in By  

 
Click on [OK] to group the 
table according to 
months, based on the 
dates in the first column 

 

Sometimes the results of a PivotTable still aren’t 
enough to provide a comprehensive analysis of 
the data. Further analysis of the data can be 
completed by grouping within a PivotTable. A 

typical use for grouping occurs when dates have 
been used as one of the PivotTable variables. 
These dates can be further grouped into months to 
provide a better analysis of the data. 
 

1 

3 

For Your Reference… 

To group a field in a PivotTable report: 

1. Click on the field to group 

2. On the PivotTable Tools: Analyse tab click 
on Group Selection in the Group group 

3. Select an option in By and click on [OK]  

Handy to Know… 

 Not all fields in a PivotTable report can be 
grouped. The Group Selection command 
will be greyed out when a selected field can’t 
be used for grouping. 

4 
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CREATING RUNNING TOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A really useful analysis tool within PivotTable 
reports is the ability to create running totals 
from the PivotTable data. As the name suggests, 
running totals are cumulatively summed together 

and provide a path as to how the grand total is 
ultimately derived. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
PivotTable 
Features_9.xlsx... 

 
Click in cell B5 – the first 
value cell for the 
Entertainment field 

 
Click on the PivotTable 
Tools: Analyse tab, then 
click on Field Settings in 
the Active Field group to 
display the Value Field 
Settings dialog box 

 
Click on the Show Values 
As tab, then click on the 
drop arrow for Show 
values as and select 
Running Total In 

 
Ensure that Date is 
selected in Base field, 
then click on [OK] 

Notice how each value is 
now cumulatively summed 
until the value for Jul is 
equal to what the previous 
grand total showed 

 

1 

3 

For Your Reference… 

To create running totals in a PivotTable: 

1. Click on the first value field to select it 

2. Click on PivotTable Tools: Analyse > Field 
Settings in the Active Field group  

3. Click on the Show Values As tab and select 
Running Total In, specify the Base field, 

then click on [OK] 

Handy to Know… 

 If your PivotTable contains a grand total row 
and you then apply a running total, the grand 
total row will no longer display any values. In 
order to avoid confusing those viewing your 
PivotTable, it is recommended that you hide 
the grand total row. 

4 
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CREATING CALCULATED FIELDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The fields that appear in a PivotTable are 
normally the column headings in the data list. 
However, you can create calculated fields which 
are derived from the column headings in the data 

list. For example, if you have a field called Sales, 
and you know that tax is always 10% of Sales, you 
can create a new field called Sales Tax which 
calculates values based on the Sales field.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
PivotTable 
Features_10.xlsx... 

 
Click in cell A5 (Feb), then 
click on the PivotTable 
Tools: Analyse tab  

 
Click on Fields, Items & 
Sets in the Calculations 
group and select 
Calculated Field to 
display the Insert 
Calculated Field dialog 
box 

 
Type Tax in Name 

 
Press  to select the 

value in Formula and type 
=Amount*0.1 

This tells Excel to create a 
new calculated field that 
takes the value currently in 
the Amount field and 
multiply it by 0.1 (10%)… 

 
Click on [OK] 

 

1 

4 

For Your Reference… 

To create a calculated field: 

1. On the PivotTable Tools: Analyse tab click 
on Fields, Items & Sets in the Calculations 
group, then select Calculated Field 

2. Type a Name for the field and the Formula 

then click on [OK] 

Handy to Know… 

 To edit or delete a calculated field after it has 
been created, simply use Fields, Items & 
Sets > Calculated Field to display the dialog 
box again. Choose the calculated field that 
you want to change from the drop arrow and 
either make the changes or click on [Delete] 
to delete the field. 

5 
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PROVIDING CUSTOM NAMES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When PivotTables are created they use default 
names for their calculated fields and values. As a 
result you end up with descriptive, but not very 
elegant, names such as Sum of Amount. 

Fortunately you can customise these names so that 
they are more in tune with your requirements and 
possibly make more sense to those viewing your 
workbook.  
 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
PivotTable 
Features_11.xlsx... 

 
Click in cell B5 (Sum of 
Amount), then click on the 
PivotTable Tools: 
Analyse tab  

 
Click on Field Settings in 
the Active Field group to 
display the Value Field 
Settings dialog box 

 
Type Total in Custom 
Name, then click on [OK] 
to rename all Sum of 
Amount columns to Total 

 
Click in cell C5 (Sum of 
Tax) 

 
Click on Field Settings in 
the Active Field group 

 
Type Sales Tax in 
Custom Name, then click 
on [OK] 

 

1 

For Your Reference… 

To create a custom field name: 

1. Click in the field to change 

2. Click on the PivotTable Tools: Analyse tab, 
then click on Field Settings in the Active 
Field group  

3. Type a new name in Custom Name and 
click on [OK] 

3 

Handy to Know… 

 You cannot use a custom name that is the 
same as the name of an existing field – 
duplicate names are not permitted by 
PivotTable reports. 

6 
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CREATING CALCULATED ITEMS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When a field is used as a variable in a PivotTable 
the resultant groupings are known as items. For 
example, if you have a field called Months, the 
values stored in that field (Jan, Feb, etc.) are 

items of that field. In PivotTables you can actually 
create calculated items based on existing items in 
a field. For example, you could add two months 
together, or subtract them from one another, etc.  
 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file PivotTable 
Features_12.xlsx... 

 
Click in cell B4 (Jan), then 
click on the PivotTable 
Tools: Analyse tab  

 
Click on Fields, Items & 
Sets in the Calculations 
group and select 
Calculated Item to display 
the Insert Calculated 
Item dialog box 

 
Type Variation in Name 

 
Press  to move to 

Formula, then type =Feb-
Jan 

 
Click on [OK] to create the 
calculated item 

 
Point above the heading 
Variation in cell E4 until 
the pointer changes to a 
black arrow, then click 
once to select the column 
(or item) 

 
Point to the border of the 
selected area so that the 
pointer changes to a four-
headed arrow, click and 
drag the Variation column 
left to position it between 
Feb and Mar, then release 
the mouse button 

 

1 

4 

For Your Reference… 

To create a calculated item: 

1. Click in the table, click on the PivotTable 
Tools: Analyse tab, then click on Fields, 
Items & Sets in the Calculations group 

2. Select Calculated Item, type a Name and a 

Formula, then click on [OK] 

Handy to Know… 

 Calculated items are much harder to get 
your head around than calculated fields. 
Just remember that a calculated item is one 
created using items within a specific field, 
while calculated fields are created across 
one or more fields. 

7 
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PIVOTTABLE OPTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

While there are many techniques and tools 
available for working with and creating data and 
values in a PivotTable, there are also a number 
of options available which allow you to tweak the 

PivotTable report and enhance its operation and 
appearance. Most of these are grouped together in 

the PivotTable Options dialog box.  

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the file 
PivotTable Features_13.xlsx... 

 
Click in cell B4 (Jan), then click on 
the PivotTable Tools: Analyse 
tab  

 
Click on Options in the 
PivotTable group to display the 
PivotTable Options dialog box 

 
Type Sales Analysis in 
PivotTable Name to rename the 
table 

 
On the Layout & Format tab, click 
in For empty cells show, then 
type 0 

 
Click on Autofit column widths 
on update so it appears unticked  
(this will stop column widths from 
changing each time the table is 
updated) 

 
Click on [OK] to make the 
changes  

Notice how zeros have appeared 
in the previously empty cells… 

 
In the PivotTable Fields pane, 
drag the Make field from the 
ROWS area, then drag it back 
again to force an update – notice 
that the column widths no longer 
change 

If the PivotTable Fields pane is not 
displayed, click on the PivotTable 
Tools: Analyse tab, then click on 
Field List in the Show group 

 

5 

For Your Reference… 

To change options in a PivotTable: 

1. Click in the PivotTable to select it 

2. Click on Options in the PivotTable group to 
display the PivotTable Options dialog box 

3. Make changes as appropriate and click on 

[OK] 

Handy to Know… 

 You can access the PivotTable Options by 
right-clicking on the table and selecting 
PivotTable Options. 

6 
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SORTING IN A PIVOTTABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When a PivotTable report is created, the Row 
Labels and Columns Labels are 
alphanumerically sorted for you. You can change 
this sort order if you wish, or even sort according 

to the data values rather than the row or column 
labels.  
 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
PivotTable 
Features_14.xlsx... 

 
Click in cell F5 (the first 
Grand Total value), then 
click on the Home tab  

 
Click on Sort & Filter in 
the Editing group  

 
Select Sort Smallest to 
Largest to sort the table 
according to the values 
in the Grand Total 

 
Repeat step 2 then 
select Sort Largest to 
Smallest to reverse the 
order 

 

1 

3 

For Your Reference… 

To sort the values in a PivotTable: 

1. Click on the column to sort 

2. Click on the Home tab 

3. Click on Sort & Filter in the Editing group  

4. Select Sort Smallest to Largest or Sort 

Largest to Smallest 

Handy to Know… 

 More complex and multiple sorts can be 
done using the Sort dialog box which can be 
accessed using the Sort command on the 
Data tab. 

4 
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NOTES: 
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CHAPTER 10 PIVOTCHARTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to create a PivotChart shell 

 learn how to define the PivotChart structure 

 learn how to change the PivotChart type 

 learn how to use the PivotChart Filter field buttons 

 learn how to move a PivotChart to its own chart sheet. 

PivotTables create a very convenient and efficient way of analysing 
and interpreting data from internal lists and external databases. 
However, the data is presented in a tabular format. If the table is 
very large and complex it may be difficult to spot trends and 
patterns. As a consequence Excel combines the ease and 
convenience of PivotTables with its charting operations to provide 
you with PivotCharts. 

 

INFOCUS 
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INSERTING A PIVOTCHART  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PivotTables can sometimes become quite 
complex and large, making the data they contain 
difficult to understand. It can therefore be useful 
to have a way of representing the data in a 

simpler format. This is where PivotCharts are 
useful. They can be used in conjunction with a 
PivotTable or even on their own and are created in 
a similar way to PivotTables. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file 
PivotCharts_1.xlsx... 

 
Click anywhere in the list 
of sales  

This will enable Excel to 
determine the fields and 
records to be used in the 
PivotChart… 

 
Click on the Insert tab, 
then click on the top half 
of PivotChart in the 
Charts group to display 
the Create PivotChart 
dialog box 

 
Ensure that Select a 
table or range and New 
Worksheet are both 
selected, then click on 
[OK] 

A PivotTable structure 
and a PivotChart structure 
will appear in a new 
worksheet together with 
the PivotChart Fields 
pane 

 

2 

For Your Reference… 

To insert a PivotChart: 

1. Click anywhere in the list, click on the Insert 
tab, then click on the upper half of 
PivotChart in the Charts group  

2. Nominate the location for the table, then click 

on [OK] 

Handy to Know… 

 The chart appears embedded in the 
worksheet with the PivotTable as a default. 
It can later be moved to its own chart sheet if 
required. 

3 
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DEFINING THE PIVOTCHART STRUCTURE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you create a PivotTable, the PivotTable 
Fields pane displays automatically and it is by 
using this pane that you can create the structure 
of a PivotTable. In the same way when you 

create a PivotChart, the PivotChart Fields pane 
displays. You can use this pane in the same way 
as the PivotTable Fields pane to create the 
structure of a PivotChart. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
PivotCharts_2.xlsx... 

 
In the PivotChart 
Fields pane click on and 
drag the Price field to 
the Values area in the 
PivotChart Fields pane 
and release the mouse 
button 

The PivotChart and 
PivotTable will now 
display the price 
values… 

 
Repeat step 1 to 
position the 
Salesperson field in the 
LEGEND (SERIES) 
area 

 
Repeat step 1 to drag 
the Month field to the 
AXIS (CATEGORIES) 
area 

 

1 2 

For Your Reference… 

To define the PivotChart structure: 

1. In the PivotChart Fields pane click on the 
desired field 

2. Drag the field into the COLUMNS, ROWS or 
VALUES area of the pane as required  

Handy to Know… 

 The PivotChart Fields pane, though similar 
to the PivotTable Fields pane, has one main 
difference – the areas are named differently. 
For instance, Column Labels becomes 
Legend Fields, while Row Labels become 
Axis Fields. 

3 
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CHANGING THE PIVOTCHART TYPE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sometimes you may use different types of charts 
to represent the same data. Or you may decide, 
for example, that your data would be better 
displayed in a pie chart rather than a column 

chart. You can easily convert an existing chart to a 
different chart type. You can also use this feature to 
test different chart types until you find the one that 
will best represent your data.  
 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file 
PivotCharts_3.xlsx... 

 
Click on the 
PivotChart to ensure 
it is selected and to 
display the Chart 
Elements and Chart 
Styles buttons to the 
top right of the chart  

 
Click on the 
PivotChart Tools: 
Design tab, then 
click on Change 
Chart Type in the 
Type group to 
display the Change 
Chart Type dialog 
box 

 
Click on Bar in the 
list on the left, then 
click on [OK] to 
change the 
PivotChart to a 
horizontal bar chart 

 

1 

2 

For Your Reference… 

To change the chart type: 

1. Click on the chart to select it  

2. Click on the PivotChart Tools: Design tab, 
then click on Change Chart Type in the 
Type group 

3. Click on the desired type, then click on [OK] 

Handy to Know… 

 If you want to change the colour of your chart 
or the way it appears, you can click on the 
Chart Styles button which appears to the 
right of a chart when it is selected. Clicking 
on the Chart Styles button displays a gallery 
of style options you can choose from. 

3 
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USING THE PIVOTCHART FILTER FIELD BUTTONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file 
PivotCharts_4.xlsx... 

 
Click on the Month 
filter field button to see 
a menu of options, as 
shown 

 
Click on Sort Z to A to 
see the months so that 
Jan is displayed at the 
top 

 

The PivotChart Filter field buttons appear on a 
PivotChart. These buttons appear next to the 
axis and legend fields on the actual PivotChart. It 
allows you to perform both sorting and filtering 

operations on the fields that have been specifically 

chosen for the axis and legend fields. 

1 

2 

For Your Reference… 

To use a PivotChart filter field button: 

1. Click on the appropriate filter field button on 
the PivotChart  

2. Select an option 

Handy to Know… 

 In addition to performing a sort, you can also 
use the menus that appear in the PivotChart 
Filter field buttons to perform filtering 
operations. It’s worth spending a few 
moments playing around with the filters. 
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MOVING PIVOTCHARTS TO CHART SHEETS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

While it is convenient to see both the PivotTable 
and the PivotChart in the one sheet, when it 
comes to printing the chart or adding more detail, 
it is often better to have the chart in its own 

sheet. PivotCharts are just like any other charts 
(except that their data source comes from a table) 
and can therefore be moved to and from a 
worksheet and a chart sheet. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file PivotCharts_5.xlsx... 

 
Right-click on the PivotChart to 
display the shortcut menu 

 
Select Move Chart to display 
the Move Chart dialog box 

 
Select the text in New sheet 
and type Sales Chart  

This will become the name of 
the new chart sheet… 

 
Click on [OK] to move the 
chart to its own worksheet 

Notice that the PivotTable 
Fields pane is still visible… 

 
Click on the Sheet 1 
worksheet tab to see the 
PivotTable and the PivotChart 
Fields pane  

The PivotTable acts as the 
data source for the chart 

 

2 

3 

For Your Reference… 

To move a PivotChart to its own sheet: 

1. Right-click on the PivotChart, then select 
Move Chart 

2. Provide a new chart sheet name, then click 
on [OK] 

Handy to Know… 

 Even when a PivotChart is moved to its own 
chart sheet, it still retains the same 
functionality as when it was embedded in the 
same worksheet as the PivotTable. 

4 

5 
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CONCLUDING REMARKS 

 

 

 

 

 

 

 

 

Congratulations!  

You have now completed Microsoft Excel 2016 - Using as a Database. Microsoft Excel 2016 - 
Using as a Database was designed to get you to the point where you can competently perform a 
variety of operations.  

We have tried to build up your skills and knowledge by having you work through specific tasks. 
The step by step approach will serve as a reference for you when you need to repeat a task. 

 

Where To From Here? 

The following is a little advice about what to do next: 

 Spend some time playing with what you have learnt. You should reinforce the skills that you 
have acquired and use some of the application's commands. This will test just how much of 
the concepts and features have stuck! Don't try a big task just yet if you can avoid it - small 
is a good way to start. 

 Some aspects of the course may now be a little vague. Go over some of the points that you 
may be unclear about. Use the examples and exercises in these notes and have another go 
- these step-by-step notes were designed to help you in the classroom and in the work 
place! 

Here are a few techniques and strategies that we've found handy for learning more about 
technology: 

 read computer magazines - there are often useful articles about specific techniques 

 if you have the skills and facilities browse the Internet, specifically the technical pages of 
the application that you have just learnt 

 take an interest in what your work colleagues have done and how they did it - we don't 
suggest that you plagiarise but you can certainly learn from the techniques of others 

 if your software came with a manual (which is rare nowadays) spend a bit of time each day 
reading a few pages. Then try the techniques out straight away - over a period of time 
you'll learn a lot this way 

 and of course, there are also more courses and books for you to work through. 

Hungry for More? 

We live in an ever-changing world where we all need to review and upgrade our 
skills. 

If you have received this course book on a training course why not ask the tutor or 
trainer for other courses that may be of benefit to you. If you are attending a 
college ask for one of their brochures. 

Alternatively, if you’ve enjoyed using this course book you can find others that 
cover a wide range of topics at our web site www.watsoniapublishing.com. 

 

http://www.watsoniapublishing.com/
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