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READ ME FIRST 
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In case you're not familiar with the terminology, 
Read Me First is quite often the name given to a 
computer file that contains important information 
for people to know prior to using an application. 

This section contains some important information to 
help you use this book so we thought we'd start 
with a Read Me First section. 

 

What skills and knowledge 
you will acquire... 

The skills and knowledge acquired in Microsoft Access 2016 - An 
Introduction are sufficient to be able to use and operate the software 
effectively. 

What you'll need to know 
before beginning this 
course... 

Microsoft Access 2016 - An Introduction assumes little or no knowledge 
of the software. However, it would be beneficial to have a general 
understanding of personal computers and the Windows operating system 
environment. 

 

The objectives of this guide… At the completion of this course you should be able to: 

understand how Access is used and how to navigate around it 

create a database structure using Access  

create a relational database file with multiple tables 

modify the structure of an existing table 

set table relationships and join tables together 

add records to a new table 

add transactional records to a lookup database 

work with the records in a database table 

format the data in a table 

sort and filter records in a table 

export records to and import records from a wide variety of sources 
and applications 

create and use forms 

modify and adapt an existing form according to specific needs 

create simple and effective queries 

create meaningful reports from tables 

What you get in a chapter... Each chapter begins with a summary page listing the topics covered in 
that chapter. The chapter then consists of single-page topic sheets 
pertaining to the theme of the chapter. 

What you'll need to have 
before commencing this 
course... 

Many of the topics in this learning guide require you to open an existing 
file with data in it. These files can be obtained from your instructor and 

need the product code for this course which is AccessIntroduction. 

As you work through this 
guide… 

It is strongly recommended that you close all open files, if any, prior to 
commencing each new chapter in this learning guide. Each chapter, 
where relevant, has its own set of exercise files and any from a previous 
chapter are no longer required.  

Where to from here... Have a look at the next page which explains how a topic page works, 
ensure that you have access to the exercise files (see above), and you're 
ready to make a start. 
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The majority of this book comprises single-page 
topic sheets. There are two types of topic sheets: 
task and reference. The layout of both is similar 
– an overview at the top, detail in the centre and 

additional reference (optional) material at the 
bottom. Task sheets contain a Try This Yourself 
step-by-step exercise panel in the detail area as 
shown below. 

 
Topic name 

 
General topic overview provides an introduction to the topic 

 
Try This Yourself (Task-based topic sheets) is a detailed step-by-step practice 
exercise for you to work through. In Reference topic sheets this is usually replaced 
by a box with reference information. 

 
In Task topic sheets screen shots and graphics provide a visual clue as to what 
will happen when you work through the Try This Yourself practice exercise. In 
Reference topic sheets the screen shots and graphics are used to visually 
represent information and concepts. 

 
The For Your Reference (optional) element provides a quick summary of the steps 
required to perform a task. These usually only appear in Task-based topic sheets. 

 
The Handy To Know (optional) element provides additional information such as 
alternate ways of accomplishing a task or further information providing handy tips.  

 

1 

2 

3 

4 
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CHAPTER 1 GETTING TO KNOW ACCESS 2016 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of how Access works and what it 
can be used for 

 learn how to start Access from the desktop 

 gain an understanding of the Access Start screen 

 learn how to create a new blank database 

 gain an understanding of the Backstage View 

 learn how to open an existing database file 

 gain an understanding of the Access screen 

 learn how to use the ribbon 

 learn how to work with the Navigation pane to filter 
database objects 

 learn how to add commands to the QAT 

 learn how to work with Touch Mode 

 learn how to work with a table 

 learn how to work with other database objects 

 learn how to close a database file 

 learn how to exit from Access . 

Microsoft Access 2016 is described as a database management 
system (DBMS). 

A database is a structure that contains data. You enter data into the 
database via a variety of sources including typing (data entry), 
importing from other sources, and even electronically and 
automatically from other equipment (data logging). The data can 
then be manipulated by the DBMS to provide a range of useful 
information. 

INFOCUS 
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UNDERSTANDING MICROSOFT ACCESS 2016 
 

 

 

 

 

 

Microsoft Access has a reputation for being a 
more difficult application to learn and use than 
other Office applications such as Word, Excel 
and PowerPoint. There are many reasons for this 

and a good orientation to Microsoft Access will 
greatly help in understanding how this powerful 
application can be used to perform a range of 
useful jobs. 

How Access Is Different 

Unlike other Office 2016 applications such as, Word, Excel and PowerPoint where you can start to 
create something useful almost immediately and directly on the screen, with Access you must first 
design and create structures to hold your data, and then create special template layouts for displaying, 
manipulating and presenting that data in a useful and meaningful way. In other words, rather than just 
creating something through trial and error, Access requires more thought, more planning and good 
designs in order to be used effectively. While there is a lot of ‘learn by doing’ involved with Access, 
there is also great deal to learn before you start using it. 

How Access Works 

Basically, Access allows you to do two main things:  

 it allows you to store huge amounts of data 

 it allows you to manipulate that data to produce relevant and useful information. This is what 
Database Management Systems (DBMS) are all about, and the good news is that Access is 
one of the easiest of these to learn and use. 

Data is stored in tables. Tables are structures made up of rows and columns and are similar in 
appearance and operation to Excel worksheets. You need to design and create these tables yourself 
before the data can be entered. 

The data in tables is manipulated using forms, reports and queries. A form is mostly used for data 
entry (although you can enter data directly into a table). A report is used to manipulate the data and 
present it either on the screen or printed on paper in a more pleasing way. A query is used to produce 
a subset of the data – for example, in a sales system you may only want to see the sales in the 
northwest region. 

Forms, reports and queries are created as layout frameworks. Once the framework has been 
designed you can then run the data from the tables through them. Indeed, this is a common theme 
throughout Microsoft Access: design versus display. You create or modify a form, report or query in 
design mode, and then preview the data in display mode. 

Even tables (that store your data) conform to this design/display metaphor. You design a table 
structure, then enter the data in a display (they call it a datasheet) view. 

Tables, forms, reports and queries are known as database objects. In fact, each of these is like a 
mini-application within the broader Access application. Each has a very large range of commands and 
options that you can use to both design the structure or framework, and also use to display data. 

What Can Access Be Used For? 

You can use Access to create a system for managing your music or stamp collection, membership at 
your local soccer or polo club, petty cash, inventory and stock control, or sales at work and much, 
much more. Any situation where you need to store data, manipulate it, and then present it as useful 
information is a perfect contender for Access. 

The only disadvantage with Access is that unless you use one of the pre-created system templates, 
you need to plan and design the system and the database objects (the tables, forms, reports and 
queries) used in that system. This is what takes time and learning to do. 
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STARTING ACCESS FROM THE DESKTOP 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

 

Before you begin, ensure 
that your computer is 
switched on and the desktop 
is displayed… 

 
If there is no Access icon in 
the taskbar at the bottom of 
the desktop, click on the 
Windows icon in the 
taskbar, as shown, to display 
the Start menu 

 
Click on All apps to display 
a list of all the apps on your 
computer 

 
Scroll down to the A section 

Access 2016 is listed here… 

 
Click on Acces 2016 to start 
Access 

 
Right-click on the Access 
icon in the taskbar to display 
a menu of options, as shown, 
then select Pin this 
program to taskbar 

You can now click on this 
icon to open Access from the 
desktop. This icon will 
remain in the taskbar unless 
you remove it… 

 
Repeat step 5 to select 
Close window to close 
Access 

 
Click on the Access icon in 
the taskbar to open Access 
again 

 

To create a new database or work with an 
existing one, the first thing you must do is to start 
Microsoft Access. The first time you use Access 
you need to open it from the taskbar Search the 

web and Windows bar or the All apps list in the 
Start menu. You can choose to pin it to the Start 
menu or the taskbar so that you can access it more 
quickly and easily the next time you use it. 

1 

5 

For Your Reference… 

To pin Access to the taskbar: 

1. From the Start screen, click on the down 
arrow icon to display the Apps screen 

2. Locate and right-click on Access 2016 

3. Click on Pin to taskbar 

Handy to Know… 

 You can start Access by clicking in the 
taskbar Search… bar, typing access, then 
clicking on Access in the list of search 
results. 

 You can pin Access to the Start menu by 
displaying the All apps list, right-clicking on 
Access 2016 and selecting Pin to Start. 
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UNDERSTANDING THE START SCREEN 
 

 

 

 

 

  

Most times you open Access, a start screen will 
display. From this initial screen, you can choose 
what kind of database you want to work with. You 
can choose to work with one of your most 

recently accessed files, open a database which has 
been saved to Computer or OneDrive or create a 
new database using the available templates. 

Microsoft Access 2016 Start Screen 

The Microsoft Access 2016 start screen is very helpful if you want to quickly access a database you 
have worked on recently or create a new database based on one of the available templates (including 
the default Blank desktop database). 

If you have already worked on a database or several databases in Access, a list of recent databases will 
display below Recent in the pane to the left of the screen. If you haven’t worked on any databases yet, 
you can still open existing databases by clicking on the link, Open Other Files, located below Recent. 
This lets you open an existing file from your computer or OneDrive. 

The main pane of the start screen displays available templates you can use to create a new database 
and a search box you can use to search the internet for additional templates. Templates are simply 
layouts that have already been created which you can customise to suit your needs and then enter 
relevant content. If you want to start with a clean slate you can choose the Blank desktop database 
template – you’ll probably find this is the one you will use the most. Templates displaying the globe icon 
(e.g. Asset tracking) use the web-based SharePoint servers to host your database and make it 
available over the internet (note that these templates require subscriptions). 

In the top right corner of the screen you’ll see information about the account you’ve used to sign into 
Windows as well as help, minimise, restore down, and close tools. 

The start screen will only display when you launch the Access 2016 application directly – that is, by 
clicking on the Access tile on the Windows 10 Start screen, clicking on the application on the Apps 
screen or under search results, or clicking on the taskbar icon if the application has been pinned to the 
taskbar. 

Access 2016 can also be started in Windows 10 by double-clicking on an Access database in File 
Explorer. When this occurs Access 2016 will start with the database open on the screen and the start 
screen shown above will be bypassed. 
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CREATING A NEW BLANK DATABASE 
 

 

 

 

 

 

 

 

  

 

  

 

  

 

 

 

 

 

 

When you launch Microsoft Access 2016, you will 
be presented with the start screen, which 
enables you to open an existing database or 
create a new one based on one of a multitude of 

available templates. Most of the templates shown 
are web-based and may involve a subscription to 
Office 365. You can also simply create a new, 
blank desktop database which is free. 

Try This Yourself: 

 

Before starting this 
exercise you MUST 
ensure that the Access 
2016 Start screen is 
displayed... 

 
In the right pane, click 
on Blank desktop 
database 

You will be asked to 
name the database… 

 
Type My Database in 
File Name, then click on 
the Browse icon to 
display the File New 
Database dialog box, 
locate and double-click 
on C:/ Course Files for 
Microsoft Access 2016 
and click on [OK] 

You could click on the 
Next arrow to display 
the other built-in 
templates and use one 
of those instead, but we 
will stay with the blank 
template… 

 
Click on [Create] to 
open the new blank 
database in Access 

Access has created a 
single blank table for 
you to begin with 

 

1 

2 

For Your Reference… 

To create a new blank database: 

1. In the start screen, click on Blank desktop 
database 

2. Type a File Name, click on [Browse] and 
select a save in location 

3. Click on [OK] then click on [Create] 

Handy to Know… 

 If you already have a database open and 
want to create a new one, click on the File 
tab to open the Backstage, then click on 

New and click on Blank desktop database. 

3 
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UNDERSTANDING THE BACKSTAGE VIEW 
 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Before you can properly enter Microsoft Access 
2016, you must have a database file open. A 
database file is where your database objects 
(tables, forms, reports, queries etc) for a 

particular system or project you are working on are 
located. The Backstage view is accessed using 
the File tab and provides you with file information 
and enables you to print, save and more. 

The Backstage 

The File tab on the ribbon is not a 
standard tab. Clicking on the File 
tab launches a mini-program within 
Microsoft Access called Backstage 
view, also called simply 
Backstage. 

A navigation pane occupies the left 
side of the Backstage. The options 
in this pane enable you to access a 
number of operations, such as 
printing and saving and can also 
provide you with information about 
your database such as size. 

Click on the options in the 
navigation pane to change the 
display in the pane on the right. 

The Backstage Options 

Info Provides status information about the current database and lets 
you compact and repair the database and encrypt it with a 
password. 

New Enables you create a new database and provides access to 
inbuilt templates as well as ready access to a range of online 
templates. 

Open Provides a list of recent documents as well as the option to 
search through your Computer, SkyDrive or other place, to find 
what you are looking for. 

Save Saves your current object (table, query, form etc). 

Save As Enables you to save the current database in a different format 
(e.g. as .mdb, compatible with versions earlier than 2007) and/or 
in a different location. 

Print Enables you to print the current object and preview it. 

Close Closes your current database. 

Account Contains product and user information. 

Options Displays the Access Options dialog box, which presents you 
with options for setting up how Access works in general and 
options (preferences) for the current database. 

Feedback Allows you to provide Feedback to Microsoft on any issues or 
suggestions you have about Access. 
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OPENING AN EXISTING DATABASE FILE 
 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

A good way to see how Access 2016 works is to 
open an existing database file. To open a 
database file, you need to use the Open option in 
the Backstage. If the database file has recently 

been opened, it may appear in the Recent 
Database list. However, if it doesn’t appear there, 
you will need to use one of the other Open options 
to search for and open it. 

Try This Yourself: 

 

Before starting this exercise 
ensure that Access has 
started... 

 
Click on the File tab to open 
the Backstage, then click on 
Open to display the Open 
options 

Let’s change the folder 
location to display our existing 
database files… 

 
Click on This PC under Open 
in the middle pane 

This will display the current 
folder and any recent folders. 
Let’s assume these are not the 
folders that we need… 

 
Click on Browse to display the 
Open dialog box 

 
Double-click on the icon for C: 
drive, then double-click on the 
Course Files for Microsoft 
Access 2016 folder 

 
Click on A Sample 
Database.accdb, then click on 
[Open] to open the database 

 
If a security warning displays 
in the yellow info bar just 
below the ribbon, click on 
[Enable Content] to close the 
info bar 

 

2 

For Your Reference… 

To open an existing database file: 

1. Select Open in Backstage view 

2. Move to the folder that contains the file 

3. Click on the file to select it 

4. Click on [Open] 

Handy to Know… 

 You can use the keyboard shortcut  +  
at any time to display the Open area in 
Backstage view. 

4 
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UNDERSTANDING THE ACCESS 2016 SCREEN 
 

 

 

 

 

 

At first glance there’s not much to an Access 
2016 database screen. The screen really only 
gives you access to either create, modify, or run 
one of the database objects in a database file 

(tables, forms, reports, queries, etc). It isn’t until 
you choose to perform one of these operations that 
the screen really becomes more intricate. 

 
The ribbon is the tabbed band that appears across the top of the window. It is the command control 
centre of Access 2016. You use the tabs on the ribbon to access commands which have been 
categorised into groups. Commands can be buttons or sometimes include galleries of formatting 
options that you can select from. This area really comes to life when a database object is opened.  

 
The File tab of the ribbon is used to access file management functions such as saving, opening, closing, 
printing, etc. Access Options are also available so that you can set your working preferences and options 
for Access 2016. 

 
The main part of the screen is the data area. Here a database object will appear either in design or in 
preview mode. The database object must first be opened before it will appear so, even though Asset 
Items in the screen above is selected, it hasn’t yet been opened. 

 
The Navigation pane is used to list and navigate the various database objects (tables, forms, reports, 
queries, etc) that exist in the database. By default, all objects are displayed (as shown above) but it is 
possible to filter the pane to show, for instance, only objects of one type (e.g. tables). 

 
The Security and Message area displays information about the database object that is currently open. 
Since there are no objects open the area is not showing much at the moment other than the fact that it is 
ready for you to begin. 

 

2 

1 

4 

3 

5 
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USING THE RIBBON 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The ribbon is the command centre for Access. It 
provides a series of commands organised into 
groups that are placed on relevant tabs. Tabs 
are activated by clicking on their name to display 

the command groups. Commands are activated by 
clicking on a button, tool or gallery option. Although 
there are often several ways to access an option, 
the ribbon provides a simple, direct approach. 

Try This Yourself: 

 

Continue using the previous 
file with this exercise, or open 
the file A Sample 
Database.accdb... 

 
In the Navigation pane, 
double-click on Asset Items 
under Tables to open the 
object – examine the groups 
on the Home tab 

When an object is open, more 
options on the ribbon become 
active. The Home tab contains 
commonly used commands… 

 
Click on the Create tab 

These commands are used to 
create new objects (tables, 
queries etc)… 

 
Click on the Table Tools: 
Fields tab, then click on More 
Fields in the Add & Delete 
group 

A down arrow indicates the 
option will display a gallery… 

 
Click on each of the tabs and 
examine the commands 

Some commands open dialog 
boxes… 

 
On the Home tab, click on 
Find in the Find group to open 
the Find and Replace dialog 
box 

 
Click on [Cancel] 

 

1 

For Your Reference… 

To use the ribbon: 

1. Click on a tab to display the commands 

2. Click on a tool to activate a command, 

display a gallery or display a dialog box 

Handy to Know… 

 Additional tabs, known as contextual tabs, 
appear in specific circumstances. For 
instance, if you open a table, the Table 
Tools: Fields and Table Tools: Table tabs 
appear. This provides quick access to all of 
the tools you may need to work with tables. 

3 
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WORKING WITH THE NAVIGATION PANE 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Navigation pane is an essential part of 
Access 2016 as it provides you with access to 
the database objects that are in your database 
file. The pane itself can be filtered to show you 

more or less objects and you should get a pretty 
good grasp on how it operates before you begin to 
create tables and other database objects. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
A Sample 
Database.accdb... 

 
Click on the All Access 
Objects drop arrow in the 
Navigation pane, as 
shown 

A menu will display… 

 
Select Queries under 
Filter By Group to see 
only the saved query 
objects in the database 

 
Click on the drop arrow 
again and select Reports 
to see only the reports 

 
Click on the drop arrow 
again and select All 
Access Objects to see 
all of the database objects 

 
Click on the arrow to the 
right of Forms in the 
Navigation pane 

The forms will be hidden 
and the arrows will 
change to double down 
arrows… 

 
Click on the arrow to the 
right of Forms to display 
the forms again 

 

1 2 

5 6 

For Your Reference… 

To filter database objects in the Navigation 
pane: 

1. Click on the All Access Objects drop arrow 
for the object type in the Navigation pane 

2. Select the desired filter option 

Handy to Know… 

 The Navigation pane menu is quite 
complex. Once you’ve become proficient with 
it you can list the objects by date created or 
modified. However, the best option is to list 
objects grouped according to their type. 
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ADDING COMMANDS TO THE QAT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The QAT (Quick Access Toolbar) is a small 
toolbar that appears at the top left corner of the 
Access window and is a handy location to place 
the commands from the ribbon that you use most 

frequently. Adding commands from the ribbon 
involves locating the command, right-clicking on it 

and selecting Add to Quick Access Toolbar.  

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous file 
with this exercise, or open the 
file A Sample 
Database.accdb... 

 
Point to the first button on the 
Quick Access Toolbar to see 
the name of the tool and its 
shortcut 

In our case it’s the Save tool – 
by default, only three tools 
appear in the QAT (Save, 
Undo and Redo)… 

 
On the Home tab, right-click on 
Filter in the Sort & Filter 
group to display a shortcut 
menu 

 
Select Add to Quick Access 
Toolbar to add the Filter tool 
to the QAT 

 
Click on Customise Quick 
Access Toolbar, as shown, to 
display a menu 

 
Select Open to add the Open 
tool to the QAT 

It is just as easy to remove 
tools you don’t want from the 
QAT… 

 
Right-click on the Filter tool in 
the QAT and select Remove 
from Quick Access Toolbar 

 
Repeat step 6 to remove the 
Open tool from the QAT 

 

3 

4 

For Your Reference… 

To customise the Quick Access Toolbar 

 Right-click on the command you want to add 
and select Add to Quick Access Toolbar, 
or 

 Click on Customise Quick Access Toolbar 
and select a command 

Handy to Know… 

 You can position the QAT under the ribbon 
by clicking on Customise Quick Access 
Toolbar and selecting Show Below the 
Ribbon. This puts the tools that you use 
most frequently closer to your workspace 
making it quicker to access them. 

6 
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WORKING WITH TOUCH MODE 
 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

These days many people are using Office 
programs on touchscreen devices such as tablets 
and even smart phones. Because these screens 
are small, it is easy to accidentally tap the 

incorrect command. To help prevent this, you can 
activate touch mode which creates more space 
between tools on the QAT, commands on the 
ribbon, and the tabs on the ribbon. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous file 
with this exercise, or open the 
file A Sample 
Database.accdb... 

 
Click on Customise Quick 
Access Toolbar, as shown 

 
Select Touch/Mouse Mode 

This will only add the tool to the 
Quick Access toolbar, not 
activate Touch mode… 

 
Click on Touch/Mouse Mode 
in the QAT to open a menu 

Mouse mode is selected by 
default. With this mode the 
commands are optimised for 
use with a mouse… 

 
Select Touch 

The tools on the Quick Access 
toolbar, tabs on the ribbon and 
each command on the ribbon 
will spread out significantly. 
Let’s revert to the default 
Mouse mode… 

 
Repeat steps 3 and 4, selecting 
Mouse to activate Mouse 
mode 

Let’s remove the tool from the 
Quick Access toolbar… 

 
Right-click on Touch/Mouse 
Mode in the QAT and select 
Remove from Quick Access 
Toolbar 

 

1 

3 

Despite its name, Touch mode can be used with a mouse and 
may suit people who have difficulty with fine mouse movements. 

4 

For Your Reference… 

To activate Touch mode: 

1. Click on Customise Quick Access Toolbar  

2. Select Touch/Mouse Mode 

3. Click on Touch/Mouse Mode in the Quick 
Access toolbar 

4. Select Touch 

Handy to Know… 

 When you activate Touch mode in one 
Office application, it is automatically 
activated in all other Office programs (Word, 
Outlook, etc.) immediately. 
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WORKING WITH A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

A table is used in a database file to store data. A 
table has a defined structure and in Access 2016 
whenever the table is open, it is seen either in 
Design mode or in Datasheet mode. When it is 

in Design mode you can make changes to the 
structure of the table but not to the data itself, and 
when it is in Datasheet mode you can make 
changes to the data but not to the structure.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
A Sample 
Database.accdb... 

 
Ensure Datasheet 
mode is active – if not, 
in the Navigation pane, 
double-click on Asset 
Items under Tables – 
this mode provides 
access to the actual 
data 

 
On the Home tab, click 
on the top half of View 
in the Views group to 
switch to Design view 

This mode displays the 
structure of the table. 

There are also view 
buttons at the bottom of 
the screen which allow 
you to toggle between 
Design and Datasheet 
modes… 

 
Click on Datasheet 
View in the bottom right 
of the window, as 
shown, to see the data 
again 

 
Click on Close ‘Asset 
Items’ in the top right 
corner of the main pane 
as shown (just beneath 
the ribbon) to close the 
table 

1 

2 

For Your Reference… 

To display a table: 

1. In the Navigation pane, double-click on the 
table name to display the table in datasheet 
view 

2. On the Home tab, click on View in the Views 

group to toggle the view to Design mode 

3 

Handy to Know… 

 Clicking on View in the Views group (on the 
Home tab) toggles between Design and 
Datasheet views for an open table. For 
example, if you are in Datasheet view, 
clicking on View will switch to Design view 
and vice versa. 

4 
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WORKING WITH OTHER DATABASE OBJECTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The key thing to remember with database objects 
including tables is that, when open, they will 
either be in Design mode where you can make 
changes to the structure or layout of the object, 

or in Data mode where data is parsed through the 
object’s layout and presented to you. Once the 
object is open, it is easy to toggle between these 
two modes of operation.  

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
A Sample 
Database.accdb... 

 
In the Navigation pane, 
double-click on 
qryCostsSummedByOw
ner under Queries to run 
the query and display the 
data parsed through it 

 
On the Home tab, click on 
the top half of View in the 
Views group to display 
the design of the query 

 
Click on Close to close 
the query 

 
Double-click on 
rptAssetsGroupedByOw
ners under Reports to 
run the report and display 
it in preview mode 

 
Click on Design View in 
the task bar at the bottom 
right of the window to 
display the design 
structure of the report 

 
Click on Close to close 
the report 

 

1 

2 

For Your Reference… 

To work with other database objects: 

1. In the Navigation pane, double-click on the 
object name to run the object 

2. On the Home tab, click on View to see the 
design of the object 

Handy to Know… 

 For forms and reports there is a Layout 
view. In Design view you see the name of 
the controls used to display the data. You 
don’t actually see where the data ends up in 
Design view. In Layout view you see the 
data but can still make changes to the actual 
layout of the form or report. 

5 
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CLOSING A DATABASE FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Closing a database file is a little different to 
closing files in most other applications. In Access 
2016 the data in a database file is saved as it is 
being entered, while changes to structures and 

designs are saved when the objects are closed. 
You will never therefore be prompted to save new 
data added to a database file because all of this 
has already been done automatically. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file A Sample 
Database.accdb... 

 
Click on the File tab to 
open the Backstage 

 
Click on Close to 
close the database 
and return to the 
Home tab 

The Home tab has 
been selected 
because you closed 
the database. Only 
one database can be 
open at a time in 
Access and Access 
will always display the 
Home tab and a blank 
screen when a 
database is not 
currently open 

 

1 

For Your Reference… 

To close a database: 

1. Click on the File tab 

2. Click on Close 

2 

Handy to Know… 

 When closing a database in Access, the only 
time you will be asked to save anything is if 
there is a Design view window open and 
unsaved changes have been made to the 
design prior to closing. 
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EXITING FROM ACCESS 2016 
 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

You can exit from Access 2016 without the need 
to worry about losing unsaved data. All of the 
data in a database is saved as the data is 
entered, while changes to the design of any 

database objects are saved when the object is 
closed. 

Try This Yourself: 

 Before starting this exercise, 
ensure that Access is open... 

 
Click on Close in the top right 
corner of the application 
window to close Access 2016 

 

1 

For Your Reference… 

To exit from Access 2016: 

 Click on Close in the top right corner of the 
application window 

Handy to Know… 

 You can use the keyboard shortcut  +  
to exit from Access. 

 You cannot exit from Access via the 
Backstage. 
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CHAPTER 2 CREATING A LOOKUP DATABASE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to create a new database file 

 learn how to create a lookup table in a database 

 learn how to define a primary key for a table 

 learn how to save and close a new table design 

 learn how to create a transaction table 

 gain an understanding of the relationship between the 
tables in a lookup database 

 learn how to connect a transaction table to a lookup table 

 learn how to view table relationships. 

Once a database design has been prepared, you are ready to 
create the database structure using database application software. 
The creation stage involves creating the tables and the fields within 
the tables, and then specifying how the fields in one table relate to 
the other. 

INFOCUS 
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CREATING A NEW DATABASE FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In Access all elements of your database: tables, 
reports, forms and the like, are stored in one file 
with the file extension ACCDB. This is what is 
commonly referred to as the database file – not 

to be confused with the tables where your data is 
stored. Before you can create tables, reports, 
forms, or any other object, you need to create a 
new database file. 

Try This Yourself: 

 

Before you begin, ensure 
that Access 2016 has 
started... 

 
If the start screen is 
currently displayed, go to 
step 2, otherwise, click on 
the File tab to display the 
New area in the 
Backstage 

 
Click on the Blank 
desktop database 
template and type 
Employee Expenses 

We’ll save it where the 
other course files are 
located… 

 
Click on the Browse icon 
to display the File New 
Database dialog box, then 
locate and double-click on 
the Course Files for 
Microsoft Access 2016 
folder and click on [OK] 

The course files folder is 
now where the database 
will be saved… 

 
Click on [Create] to create 
the new database 

 
Click on Close to close the 
automatic table (Table1) 
that has appeared 

 

3 

Note: Be sure to click on the Close button for the database 
object when closing tables, queries, forms etc. – if you click on 
the Close button in the very top, right corner of the application 
window, you will close Access 

For Your Reference… 

To create a new database file: 

1. Click on the File tab and click on New 

2. Type the File Name, click on [Browse] and 
choose a save location 

3. Click on [Create] 

5 

Handy to Know… 

 All new Access 2016 database files will be 
saved in the same format as Access 2007 
and 2010 files (.accdb). If you need to 
provide the file to other users who may be 
using earlier versions, you can save it as an 
Access 2003 or earlier file (.mdb), but the file 
may lose some functionality. 
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CREATING THE LOOKUP TABLE 
 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The lookup table holds the records that will be 
looked up by the transaction table. In this 
example, the lookup table holds Employee 
records. Creating a lookup table involves creating 

the fields in the table and specifying their size and 
type. The fields will hold the employee details that 
are needed for our database but that are not 
relevant to specific expense transactions. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Create 
Database_1.accdb... 

 
Click on the Create tab, 
then click on Table Design 
in the Tables group to 
display a new table 

 
Type EmpNo in Field 

Name, then press  to 
move to Data Type 

 
Click on the drop arrow for 
Data Type and click on 
Short Text, if necessary, 

then press  to move to 
Description 

 
Type Records the 
employee number 

 
In the Field Properties at 
the bottom of the Table1 
window, select the value in 
Field Size and type 6 

 
Click in the row under 
EmpNo to start a new field, 
then repeat steps 2 to 5 to 
create the additional fields 
as shown 

Leave the table design on 
the screen for the next 
exercise 

 

1 

For Your Reference… 

To create a new table: 

1. Click on the Create tab, then click on Table 
Design in the Tables group 

2. Type the Field Name, select a Data Type 
and type the Description for each field 

Handy to Know… 

 When you click on a field in the table Design 
window, the Properties for that field are 
displayed in the lower half of the window. 
The number and type of properties that you 
see will vary depending on the data type of 
the field. 

6 

4 
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DEFINING THE PRIMARY KEY 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For a lookup database to be useful, it must be 
able to retrieve data quickly and easily. In 
addition, it must be able to pull data from different 
tables together rapidly to provide information. To 

make this possible, each table should include a 
field or set of fields that makes each record in the 
table unique. This field or set of fields is known as 

the primary key. 

Try This Yourself: 

 

Before starting this 
exercise, ensure that the 
table design from the 
previous exercise is 
displayed. 

 

A primary key is 
indicated by a key 
symbol. Currently, this 
table does not have a 
primary key assigned… 

 
Click on EmpNo in 
Field Name to select 
the field 

 
On the Table Tools: 
Design tab, click on 
Primary Key in the 
Tools group 

A small key icon will be 
displayed to the left of 
the field to indicate that 
this is the primary key 
field. 

Leave the table design 
on the screen for the 
next exercise 

 

1 

2 

For Your Reference… 

To define a primary key: 

1. In table Design view, click on the field that 
will be used as the primary key 

2. On the Table Tools: Design tab, click on 

Primary Key in the Tools group 

Handy to Know… 

 Once you have nominated a field as the 
primary key, Access will only allow you to 
enter unique values in that field. Duplicate 
values or empty fields (known as nulls) will 
not be accepted. AutoNumber field types 
are ideal for primary keys because they are 
automatically created and are unique. 
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SAVING AND CLOSING A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

 

Before starting this 
exercise, ensure that the 
table design from the 
previous exercise is 
displayed... 

 
Click on the File tab and 
select Save to display the 
Save As dialog box 

We selected Save, not 
Save As, because the Save 
As options relate to the 
database as a whole and 
we are only saving an 
object within the database 
here. Unlike larger Save As 
dialog boxes found in other 
applications, this dialog box 
is relatively small. This is 
because the table structure 
is saved as part of the 
database file so there is no 
need to specify a file 
location for database 
objects… 

 
Type Employees in Table 
Name and click on [OK] 

The table’s name will now 
appear in the Navigation 
pane, and on the table 
design tab… 

 
Click on Close to close the 
table 

 

For Your Reference… 

To save a table design: 

1. Click on the File tab to display the 
Backstage and click on Save 

2. Type a Table Name and click on [OK] 

Unlike data that is saved as you move away from 
a field, tables are objects that must be saved if 
you want to retain any changes that you make to 
the design. You can either save the table as you 

work or save it as you close it. One advantage of 
this process is that if you want to return to the 
previous settings, you can simply close the table 
without saving it. 

1 

2 

Handy to Know… 

 If you try to close a table that has been 
modified but not saved, Access will prompt 
you to save the changes and provide a 
dialog box so that you can choose [Yes] or 

[No]. 

3 
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CREATING THE TRANSACTION TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Lookup databases consist of a transaction table 
that holds the individual transactions and a 
lookup table that the transactions are related to. 
The transaction table may hold many records for 

each of the records in the lookup table. To ensure 
that the relationship can be created, you must 
ensure that the primary key of the lookup table 
appears as a field in the transaction table. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Create 
Database_2.accdb... 

 
Click on the Create tab, 
then click on Table 
Design in the Tables 
group to open a new table 

 
Type the fields as shown 
(set the Field Size (in 
Field Properties) for the 
Description field to 30) 

 
Click on ExpTransNo in 
Field Name to select the 
field, then click on 
Primary Key in the Tools 
group to make this field 
the primary key 

 
Click on Save in the 
Quick Access Toolbar to 
display the Save As 
dialog box 

 
Type Expense 
Transactions in Table 
Name,then click on [OK] 

 
Click on Close to close 
the table 

The new table is now 
listed in the Navigation 
pane and the object name 
appears in the tab at the 
top of the design window 

 

2 

3 

For Your Reference… 

To create the transaction table: 

1. On the Create tab, click on Table Design in 
the Tables group 

2. Specify the fields and the primary key, then 

click on Save 

Handy to Know… 

 The AutoNumber field type provides an 
automatic and unique number for each 
transaction. It is ideal for tasks where we 
need to have a new and unique number for 
each transaction record that is entered into 
the table. 

5 
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UNDERSTANDING LOOKUP TABLE RELATIONSHIPS 
 

 

 

 

 

 

A lookup database requires at least two tables: 
the lookup table and the transaction table. For 
these tables to work together they must be linked 
in some way, or as it is referred to in database 

jargon, they must be related. This is done using a 
field that is common between the two tables. In the 
lookup table this is normally the field that is unique 
and is the primary key. 

One-To-Many Relationships 

Lookup databases have a relationship known as a one-to-many relationship. 

In this type of relationship the lookup table contains unique records and forms the one side in the 
one-to-many relationship. The transaction table forms the many side in the one-to-many 
relationship because there may be many transactions for each record or entity from the lookup table. 

Taking our case study as an example, the Employees table is the lookup table – there is only one 
record here for each employee. The Expense Transactions table is the transaction table – there 
may be many records for each of the employees in the Employees table. 

Table relationships are made possible by the use of the primary key in the lookup table. In our 
example, the primary key of the Employees table EmpNo is used in the table to uniquely identify 
employees. For the relationship to work it will also need to be in the Expense Transactions table 
against each expense so that we can identify who incurred the expense. 

Once the relationships between the tables are established, we can use them in either table to ask 
questions (or query) the data. 

For example, in the Expense Transactions table we can ask “who was the employee that incurred 
this expense?”… 

In the Employees table we can ask “what are the transactions incurred by this employee?”… 
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CONNECTING TO A LOOKUP TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once you have created a transaction table and a 
lookup table, you can connect the two tables in a 
number of ways. One of the easiest methods for 
connecting the two tables is to use the Lookup 

Wizard to create a Lookup Column in the 
transaction table. The wizard enables you to 
nominate the fields from the lookup table that you 
want displayed with your transaction data. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Create Database_3.accdb... 

 
Ensure Design View is 
active  

If Design View is not active, 
right-click on the Expense 
Transactions table in the 
Navigation pane, then select 
Design View 

This provides a quick 
method for displaying a 
database object in a specific 
view… 

 
Click in the row beneath the 
Amount field then, on the 
Table Tools: Design tab, 
click on Modify Lookups in 
the Tools group to start the 
Lookup Wizard 

 
Work through the wizard, 
making the selections as 
shown 

 
Click on [Finish] to 
complete the wizard, then 
click on [Yes] to save the 
changes 

 
Click on the Employee field, 
then click on the Lookup 
tab in the Field Properties 
pane to see the settings that 
have been created 

 
Click on Close to close the 
table 

 

Screen Task Then 

1 Select I want the lookup field to get the values 
from another table or query 

[Next] 

2 Select Table:Employees [Next] 

3 In Available fields double-click on LastName 
then on FirstName 

[Next] 

4 Select LastName for the first sort column, then 
FirstName for the second sort column, 
ensuring that both are set to ascending order 

[Next] 

5 Ensure that Hide key column appears with a 
tick 

[Next] 

6 Type Employee as the label for the lookup field  

 

3 

For Your Reference… 

To connect to a lookup table: 

1. Open the transaction table in Design View, 
then click in the first blank row 

2. On the Table Tools: Design tab, click on 
Modify Lookups in the Tools group 

3. Follow the steps of the wizard and specify 
the relevant field details 

Handy to Know… 

 The connection between tables is only 
possible through the primary field of the 
lookup table and must be the field specified 
in the wizard when creating the connection 
from the transaction table. 

4 

5 
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VIEWING TABLE RELATIONSHIPS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Table relationships can be viewed and edited 
using the Relationships window. This window 
gives you a better understanding of how tables 
are related or joined together. It also lists all of 

the fields in each table so that you can locate 
content easily. The Relationships window can be 
used to document part of your database design by 
printing it as a report. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Create 
Database_4.accdb... 

 
Click on the Database 
Tools tab, then click on 
Relationships in the 
Relationships group 

The relationship between 
all tables in the database 
will now be shown… 

 
On the Relationship 
Tools: Design tab, click on 
Relationship Report in the 
Tools group to see a 
preview of a printable 
report 

 
Click on the File tab and 
click on Print to see the 
Print area, then click on 
Quick Print to send the 
report directly to the printer 

 
Click on Close for the 
Relationships for Create 
Database_4… tab, then 
click on [No] when 
prompted to save the report 

 
Close the Relationships 
window 

 

1 

For Your Reference… 

To view table relationships: 

 Click on the Database Tools tab and click on 
Relationships in the Relationships group 

Handy to Know… 

 The Relationship Report is a database 
object just the same as a table. You could 
save it if required, however relationships 
often change so it is better to generate a new 
report each time rather than saving them. 

2 
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NOTES: 
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CHAPTER 3 CREATING A RELATIONAL DATABASE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to create a new database file 

 learn how to create the lookup tables 

 learn how to define a primary key for a table 

 learn how to save and close a new table design 

 learn how to create a second lookup table in a database 

 learn how to create the transactions table 

 learn how to create the details table. 

A database application requires the creation of a database file and 
appropriate table structures. In Microsoft Access your complete 
relational database application is stored in one database file. 

After you have planned your system, the first task is to create a new 
database file which becomes the repository for all of the tables, 
reports, forms, and other objects of your system. 

When the database has been created, you can populate it with the 
necessary tables and data. 

INFOCUS 
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CREATING A NEW DATABASE FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

 

Before you begin, ensure 
that Access has started... 

 
Click on the File tab to 
display the New area in 
the Backstage 

 
Click on the Blank 
desktop database 
template and type 
Expense System in File 
Name 

We’ll save it where the 
other course files are 
located… 

 
Click on [Browse] to 
display the New 
Database dialog box, 
then locate and click on 
the Course Files for 
Microsoft Access 2016 
folder and click on [OK] 

The course files folder is 
now where the database 
will be saved… 

 
Click on [Create] to 
create the new database 

 
Click on Close to close 
the automatic table 
(Table1) that has 
appeared 

 

In Microsoft Access 2016 all elements of your 
database; tables, reports, forms, and the like, are 
stored in one file with the file extension accdb. 
This is what is commonly referred to as the 

database file – not to be confused with the tables 
where your data is stored. Before you can create 
tables, or reports, or forms, or any other object, you 
need to create a new database file. 

3 

For Your Reference… 

To create a new database file: 

1. Click on the File tab and click on New 

2. Click on Blank database, type the File 
Name, click on [Browse] and choose a save 
location 

3. Click on [OK] then click on [Create] 

Note: Be sure to click on the Close button for the 
database object when closing tables, queries, forms 
etc – if you click on the Close button in the very top 
right corner, you will close Access 

4 

Handy to Know… 

 All new Access 2016 database files will be 
saved in the same format as Access 2007 
and 2010 files (.accdb). If you need to 
provide the file to other users who may be 
using earlier versions, you can save it as an 
Access 2003 or earlier file (.mdb), but the file 
may lose some functionality. 
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CREATING LOOKUP TABLES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The lookup table holds the records that will be 
looked up by the transaction table. In this 
example, the lookup table holds Employee 
records. Creating a lookup table involves creating 

the fields in the table and specifying their size and 
type. The fields will hold the employee details that 
are needed for our database but are not relevant to 
specific expense transactions. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Relational 
Databases_1.accdb... 

 
Click on the Create tab, 
then click on Table Design 
in the Tables group to 
display a new table 

 
Type EmpNo in Field 

Name, then press  to 
move to Data Type 

 
Click on the drop arrow for 
Data Type and select 
Short Text, if necessary, 

then press  to move to 
Description 

 
Type Records the 
employee number 

 
In the Field Properties at 
the bottom of the Table1 
window, select the value in 
Field Size and type 6 

 
Click in the row under 
EmpNo to start a new field, 
then repeat steps 2 to 5 to 
create the additional fields 
with Field Sizes, as shown 

Leave the table design on 
the screen for the next 
exercise 

 

1 

For Your Reference… 

To create a new table: 

1. Click on the Create tab, then click on Table 
Design in the Tables group 

2. Type the Field Name, select a Data Type 
and type the Description for each field 

Handy to Know… 

 When you click on a field in the table Design 
window, the Properties for that field are 
displayed in the lower half of the window. 
The number and type of properties that you 
see will vary depending on the data type of 
the field. 

Field Sizes to change: 

FirstName 15 
LastName 25 
Department 25 

4 

6 
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DEFINING A PRIMARY KEY 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

 

Before starting this 
exercise, ensure that the 
table design from the 
previous exercise is 
displayed... 

 
A primary key is 
indicated by a key 
symbol. Currently, this 
table does not have a 
primary key assigned… 

 
In table Design View, 
click on EmpNo in Field 
Name to select the field 

 
On the Table Tools: 
Design tab, click on 
Primary Key in the 
Tools group 

A small key icon will 
appear to the left of the 
selected field to indicate 
that it is the primary key 
field. 

Leave the table design 
on the screen for the 
next exercise 

 

For a lookup database to be useful, it must be 
able to retrieve data quickly and easily. In 
addition, it must be able to pull data from different 
tables together quickly to provide information. To 

make this possible, each table should include a 
field or set of fields that makes each record in the 
table unique. This field or set of fields is known as 
the primary key. 

1 

2 

For Your Reference… 

To define a primary key for a table: 

1. In table Design View, click on the field that 
will be used as the primary key 

2. On the Table Tools: Design tab, click on 
Primary Key in the Tools group 

Handy to Know… 

 Once you have nominated a field as the 
primary key, Access will only allow you to 
enter unique values in that field. Duplicate 
values or empty fields (known as nulls) will 
not be accepted. AutoNumber field types 
are ideal for primary keys because they are 
automatically created and are always unique. 
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SAVING AND CLOSING A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Unlike data that is saved as you move away from 
a field, tables are objects that must be saved if 
you want to retain any changes that you make to 
the design. You can either save the table as you 

work or save it as you close it. One advantage of 
this process is that if you want to return to the 
previous settings, you can simply close the table 
without saving it. 

Try This Yourself: 

 

Before starting this exercise, 
ensure that the table design 
from the previous exercise is 
displayed... 

 
Click on the File tab, then click 
on Save to display the Save 
As dialog box 

We selected Save, not Save 
As, because the Save As 
options relate to the database 
as a whole and we are only 
saving an object within the 
database at this point. Unlike 
larger Save As dialog boxes 
found in other applications, this 
box is relatively small. This is 
because the table structure is 
saved as part of the database 
file so there is no need to 
specify a file location for 
database objects… 

 
Type Employees in Table 
Name, then click on [OK] 

The table’s name will now 
appear in the Navigation 
pane… 

 
Click on Close to close the 
table 

 

1 

2 

For Your Reference… 

To save a table design: 

1. Click on the File tab to display the 
Backstage, then click on Save 

2. Type a Table Name and click on [OK] 

Handy to Know… 

 If you try to close a table that has been 
modified but not saved, Access will prompt 
you to save the changes and provide a 
dialog box so that you can choose [Yes] or 

[No]. 



Microsoft Access 2016 - An Introduction 

© 2017 The University of Nottingham Page 32 Chapter 3 - Creating a Relational Database 

CREATING THE EXPENSE TYPE TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The relational database in our case study 
actually requires two lookup tables. The first is 
used for the Employees entity, while the second 
is used for the Expense Type entity. In the 

Expense Type lookup table, information is entered 
about types of transactions which can be then later 
looked up from the transactions table. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Relational 
Databases_2.accdb... 

 
Click on the Create tab, 
then click on Table Design 
in the Tables group to open 
a new table 

 
Type the fields as shown 
(set the Field Size for the 
Description field to 30) 

 
Click on ExpTypeNo in 
Field Name to select the 
field, then on the Table 
Tools: Design tab, click on 
Primary Key in the Tools 
group to make this field the 
primary key 

 
Click on Save in the Quick 
Access Toolbar (QAT) to 
display the Save As dialog 
box 

 
Type Expense Type in 
Table Name, then click on 
[OK] 

The new table is listed in 
the Navigation pane and 
the object name appears in 
the tab at the top of the 
design window… 

 
Click on Close to close the 
table 

 

2 

3 

For Your Reference… 

To create an expense type table: 

1. On the Create tab, click on Table Design in 
the Tables group 

2. Specify the fields and the primary key, then 
click on Save in the QAT 

Handy to Know… 

 The AutoNumber field type provides an 
automatic and unique number for each 
transaction. It is ideal for tasks where you 
need to have a new and unique number for 
each transaction record that is entered into 
the table. 

5 
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CREATING THE TRANSACTIONS TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once you have created the lookup tables for your 
relational database, you can turn your attention 
to creating the transaction table or tables. There 
is nothing different or special about creating a 

transaction table from creating a lookup table – you 
still need to enter and define the fields, identify a 
primary key and name the table. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Relational 
Databases_3.accdb... 

 
Click on the Create tab, then 
click on Table Design in the 
Tables group to open a new 
table 

 
Type the fields as shown (set 
the Field Size for the EmpNo 
field to 6) 

 
Click on ExpTransNo in Field 
Name to select the field, then 
on the Table Tools: Design 
tab, click on Primary Key in 
the Tools group to make this 
field the primary key 

 
Click on Save in the QAT to 
display the Save As dialog box 

 
Type Expense Transactions 
in Table Name, then click on 
[OK] 

The new table is listed in the 
Navigation pane and the object 
name appears in the tab at the 
top of the design window… 

 
Close the table 

 

2 

3 

For Your Reference… 

To create a transaction table: 

1. On the Create tab, click on Table Design in 
the Tables group 

2. Specify the fields and the primary key, then 
click on Save 

Handy to Know… 

 When one table (e.g. TableA) links to an 
Autonumber field in a lookup table (e.g. 
TableB), that field should be defined as 
numeric in TableA as this allows you to 
enter the correct number for the item in the 
lookup table. 

5 
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CREATING THE DETAILS TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Relational 
Databases_4.accdb... 

 
Click on the Create tab, 
then click on Table 
Design in the Tables 
group to create a new 
table 

 
Create the fields with 
Field Sizes, as shown 

 
Click on EmpNo in 
Field Name to select 
the field, then on the 
Table Tools: Design 
tab, click on Primary 
Key in the Tools group 
to make this field the 
primary key 

 
Click on Save in the 
QAT to display the Save 
As dialog box 

 
Type Personal Details 
in Table Name, then 
click on [OK] 

 
Close the table 

 

In our case study database specification we 
required a table that will hold personal details of 
the employees in our system. This table is like an 
addendum to the main Employees table – it is 

neither a lookup table nor a transaction table. It is 
generally best to create these details tables last. 

Field Sizes to change: 

EmpNo 6 
HomePhone 12 
NextOfKin 20 
Relationship 20 

2 

3 

For Your Reference… 

To create a details table: 

1. Click on the Create tab, then click on Table 
Design in the Tables group 

2. Type the field names, field types and field 
descriptions, then set a primary key 

3. Save and close the table 

Handy to Know… 

 A phone number field should be defined as a 
text field even though it consists of numbers 
because telephone numbers are not used in 
calculations. 

5 

Note: In reality, NextOfKin should probably be two fields (for first 
and last name), but we have kept it short for the purposes of this 
case study. 
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CHAPTER 4 MODIFYING TABLE STRUCTURES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to open an existing table 

 learn how to add more fields to an existing table 

 gain an understanding of the various field properties 

 learn how to change the size of an existing field 

 learn how to change the name of a field 

 learn how to change the number of decimal places in a 
field 

 learn how to change the format of dates 

 learn how to index fields in a table 

 learn how to delete fields from a table 

 learn how to make a copy of a table within a database file 

 learn how to delete a table from a database file. 

In theory, good design practices should negate the need to modify 
existing table structures. However, the real world doesn’t always 
work this way and sometimes it is necessary to make adjustments 
to a table after it has been created. This occurs often because the 
end user changes their mind or you think of additional functionality 
for your database after the design and creation phase. 

INFOCUS 
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OPENING AN EXISTING TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Tables exist within a database file as database 
objects. When you work with a table you usually 
work with its data – this is done in a special table 
view known as Datasheet view. If you want to 

modify the structure of a table or one of its fields 

you must work with the table in Design view. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file Modifying 
Tables_1.accdb… 

 
In the Navigation pane, 
double-click on the 
Employees table to open 
the table in Datasheet 
view 

 
On the Home tab, click 
on the top half of View in 
the Views group to 
switch to Design mode 

Note that the picture on 
the View tool changes to 
indicate the view you will 
be toggled to… 

 
Click on View again to 
toggle back to Datasheet 
view 

 
Click on Close to the 
right of the table to close 
it 

 
In the Navigation pane, 
right-click on the 
Employees table to 
display the shortcut menu 

 
Select Design View to 
display the table in 
Design view 

 
Close the table 

 

2 

3 

For Your Reference… 

To open an existing table: 

 Double-click on the table in the Navigation 
pane, or 

Right-click on the table to see a shortcut 
menu and select the appropriate command 

Handy to Know… 

 There is no right or wrong way to open a 
table. Choose either the Navigation pane 
double-click method or the right-click method 
as suits. 

5 
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ADDING FIELDS TO AN EXISTING TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Tables_1.accdb... 

 
In the Navigation pane, 
right-click on the 
Employees table and 
select Design View to 
display the table in 
Design view 

 
Click on the Started 
field then, on the Table 
Tools: Design tab, click 
on Insert Rows in the 
Tools group to add a 
new field row 

 
Enter the details as 
shown and change the 
Field Size property to 
30 

 
Repeat steps 2 and 3 to 
add a PhoneNo field as 
shown, with a Field Size 
of 15 

 
Click on Save in the 
Quick Access Toolbar 
to save the design 
changes 

 
Click on Close to close 
the table 

 

Your database design may have been perfect 
when you first created it, but after reviews with 
end-users and managers, and even after some 
additional reflection or brain waves, it may 

become necessary to tweak the field structure. 
Fortunately, modern database applications like 
Access allow you to add fields to an existing table 
with minimal effort. 

2 

For Your Reference… 

To add another field to a table: 

1. Click on the field above which you wish to 
insert the new field 

2. On the Table Tools: Design tab, click on 

Insert Rows in the Tools group 

Handy to Know… 

 Some words are reserved for key operations 
in Access and can’t be used for field names. 
One such word is Date – Access will warn 
you if you attempt to use a reserved word as 
a field name. 

4 

3 
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UNDERSTANDING FIELD PROPERTIES 
 

 

 

 

 

 

Fields in a table structure have specific 
characteristics that can be modified to adjust how 
the field is displayed on the screen, what it is 
named, and even what can be entered into it. 

These characteristics are known as properties and 
appear at the bottom of the Design view screen 
when a field is selected. They can become very 
powerful tools when used correctly. 

Field Properties 

The properties of fields vary depending upon the data type of the field. For example, you can’t 
change the width of a numeric field, but you can for a text field. The list of properties, therefore, 
should be watched carefully to see just what is available to you. 

The following list shows the more common field properties that appear when you click on a field in 
Design view. If one of the properties below fails to appear when a field is clicked, then that property is 
not available to the data type of the selected field. 

Field Size Limits the size of Short Text fields. It can be set from 1 to 255. Be careful 
changing the size of fields if records have already been entered into the table. 

New Values Appears only for AutoNumber fields and allows you to specify the increment 
value between new numbers. 

Format Allows you to change how numbers and dates are displayed. If you have 
formatted numbers in Microsoft Excel, then the formats used here will be 
familiar to you. 

Input Mask Allows you to force data entry into predefined formats, such as phone numbers 
(e.g. (03) 9851 4000) where brackets, spaces, dashes etc are used for the 
data. 

Caption Captions are used in forms and reports in lieu of the normal field name. 
Captions are handy when you have used truncated or abbreviated field names 
(e.g. EmpNo can be made to appear as Employee Number). 

Decimal Places Allows you to specify the number of decimal places for numeric fields. 

Default Value Allows you to specify a default value that will appear in the field whenever a 
new record is created. This can be standard text or, in the case of dates, can be 
an expression (i.e. a formula) that displays the current date. 

Validation Rule Allows you to specify a rule for the data to ensure that data is entered correctly. 
For example, you can specify a rule that a number has to be greater than 1,000 
or that the date must be today or later etc. 

Validation Text Displays a message to the user when data entered into a field with a validation 
rule doesn’t match what the validation rule requires. 

Required Ensures that data is entered into the field. Access will not move off the record 
until data has been entered into the field. 

Allow Zero 
Length 

If nothing is entered into a text field it is deemed to be of null length. If you wish 
to enter an empty string (“ “) you must select this property. Note that this is an 
advanced concept. 

Indexed Indexes are used to list data in a specific order, speed up searching, and/or 
restrict the entry of duplicate values. They will be explained in greater detail 
later. 

Smart Tags Smart Tags are used to obtain specific data for the field. They can be used to 
obtain stock quotes, exchange rates, etc. Again, they are an advanced concept. 

Text Align Allows you to determine where in a column (left, centre or right) data will 
appear. 
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CHANGING FIELD SIZE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

By rights you should have determined the 
appropriate size of a field during the design 
phase. However, you can alter the size of a field 
at any time in Design view. To change the field 

size all you need to do is to specify a new value in 
the Field Size property of the relevant field. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Tables_2.accdb... 

 
In the Navigation pane, 
right-click on the 
Employees table and 
select Design View to 
display the table 

 
Click on the Location 
field, then double-click 
on 30 in Field Size in the 
Field Properties pane at 
the bottom of the window 

 
Type 40 and press  
to increase the size 

 
Click on the PhoneNo 
field, then double-click 
on 15 in Field Size 

 
Type 6 and press  

 
Save and close the table 

 

1 

2 

For Your Reference… 

To change the size of a field: 

1. In Design view, click on the field to select it 

2. Double-click on the value for Field Size in 
Field Properties 

3. Type a new value and press  

Handy to Know… 

 Generally you won’t have too many problems 
if you increase field size. However, if you 
decrease field size and there are records in 
the table you may find you will lose some 
data. 

3 
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CHANGING FIELD NAMES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There is much debate regarding the naming of 
fields. Again, field names are something that 
should really be sorted out before the structure is 
created and then they should be rigidly adhered 

to. However, if you have to you can easily change 
the name of a field in Design mode. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Tables_3.accdb... 

 
In the Navigation pane, 
right-click on the 
Employees table and 
select Design View to 
display the table 

 
Double-click on the 
Location field to place its 
name in edit mode 

 
Type EmployeeLocation 

and press  

This name reflects a 
traditional approach to 
field naming, where 
spaces are excluded and 
multi-word names have 
each word beginning with 
a capital letter… 

 
Save and close the table 

 

2 

3 

For Your Reference… 

To change the name of a field: 

1. In Design view, double-click on the field to 
place it into edit mode 

2. Type the new name and press  

Handy to Know… 

 Rather than changing the column heading, 
and therefore the field name, you can use 
the Caption property in Table Design view. 
This provides an alternative name for a field 
when it is displayed in a table. 
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CHANGING DECIMAL PLACES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Numbers can be used in databases for a variety 
of reasons. They can record values, sizes, areas, 
volumes, temperatures and so on. Each field 
containing a number may require specialised 

formatting. While some formats are taken from the 
data type, such as Currency, other numbers may 
require adjustment of decimal places to correctly 
represent their value. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Tables_4.accdb... 

 
In the Navigation pane, 
right-click on the 
Employees table and 
select Design View to 
display the table 

 
Click on the 
WeeklyHours field to 
display its properties in 
the Field Properties 
pane 

 
Click on the value in 
Decimal Places, then 
click on the drop arrow 
and select 1 

The drop arrow appears 
at the very right end of the 
field in the Field 
Properties pane… 

 
Save and close the table 

 

2 

3 

For Your Reference… 

To change decimal places: 

1. In Design view, click on the field to format 

2. In the Field Properties pane, click on the 
value in Decimal Places, click on the drop 
arrow and select the number of decimal 
places you require 

Handy to Know… 

 Some data types, such as Currency, have a 
predefined number of decimal places. 
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CHANGING DATE FORMATS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Modifying 
Tables_5.accdb... 

 
In the Navigation pane, 
right-click on the Employees 
table and select Design View 
to display the table 

 
Click on the Started field to 
display the Field Properties 

 
In the Field Properties pane, 
click in Format, then click on 
the drop arrow and click on 
Medium Date 

 
Repeat steps 2 and 3 for the 
DateOfBirth field 

 
Save and close the table 

 

Dates may be stored in tables for a variety of 
reasons. They may include dates of birth, starting 
dates, expiry dates, or the dates of milestones. 
Access allows you to display dates in a variety of 

formats – depending on the needs of your 
application. You can choose between Long Date, 
Medium Date, General Date, Short Date, and 
various time-only formats. 

2 

3 

For Your Reference… 

To change the date format of a field: 

1. In Design view, click on the field to format 

2. Click on Format in the Field Properties 
pane, then click on the drop arrow 

3. Select the date format 

Handy to Know… 

 Terms such as long date and medium date 
can be rather meaningless to most people. In 
the Field Properties pane, the sample to the 
right of the list of date formats can be used 
as a guide to see how date formats will 
appear. 
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INDEXING FIELDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Tables_6.accdb... 

 
Ensure the Employees 
table is displayed in 
Design View  

 
Click on the LastName 
field to display the Field 
Properties pane 

 
Click on Indexed, then 
click on the drop arrow 

 
Select Yes (Duplicates 
OK) if it isn’t already 
selected 

 
Click on the PhoneNo 
field to display its 
properties 

 
Click on Indexed, click on 
the drop arrow and select 
Yes (No Duplicates) 

 
Save and close the table 

 

Because indexes help to speed up data retrieval, 
you can create indexes on fields that you expect 
to sort or search on frequently. Indexes can also 
be used to prevent duplicate data from being 

typed into the table. When you specify that a field 
should be indexed, you can specify it as 
Duplicates OK or No Duplicates depending upon 
the requirements of the field being indexed. 

2 

3 

For Your Reference… 

To create an index on a field: 

1. In Design view, click on the field to index 

2. Click on Indexed in the Field Properties 
pane, then click on the drop arrow 

3. Select the required indexing option 

Handy to Know… 

 You can specify an index for a LastName 
field as Duplicates OK because there might 
be more than one employee with the same 
last name. A PhoneNo field, however, 
should be indexed as No Duplicates 
because every employee should have a 
different phone number. 
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DELETING FIELDS FROM A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Like adding fields to a table, deleting fields really 
shouldn’t be necessary if the designing has gone 
to plan. However, if you need to delete a field 
from a table it can be done with relative ease. 

You do need to be aware that deleting a field from 
a table that has records in it will result in data loss. 
Therefore before deleting fields in an existing table 
you should make adequate backups. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Tables_7.accdb... 

 
In the Navigation pane, 
right-click on the 
Employees table and 
select Design View 

 
Click on the 
EmployeeLocation field 
to select it 

 
On the Table Tools: 
Design tab, click on 
Delete Rows in the 
Tools group 

The field is deleted from 
the table structure… 

 
Save and close the table 

 

2 

For Your Reference… 

To delete a field from a table: 

1. In Design view, click on the field to delete 

2. On the Table Tools: Design tab, click on 

Delete Rows in the Tools group 

3 

Handy to Know… 

 If you accidentally delete a field that you 
need, close the table without saving the 
changes. Deletions only come into effect 
when the table is saved. 
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COPYING A TABLE WITHIN A DATABASE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Modifying 
Tables_8.accdb... 

 
In the Navigation pane, 
right-click on the Employees 
table and select Copy to 
copy the table to the 
clipboard 

 
On the Home tab, click on 
the top half of Paste in the 
Clipboard group to display 
the Paste Table As dialog 
box 

This dialog box allows you to 
determine what to copy and 
how to name it… 

 
Ensure Structure and Data 
is selected, then click on 
[OK] to paste a copy of the 
table 

Let’s give it a more 
descriptive name… 

 
Right-click on the Copy of 
Employees table and select 
Rename to place the name 
in edit mode 

 
Type Employees Backup, 

then press  

 

When you make structural changes to a table 
which can involve data loss, it is a good idea to 
make a back-up of the table first. You could back 
up the entire database file using conventional file 

copy operations in File Explorer, however, a 
quicker and easier way is simply to make a 
duplicate copy of the table within the database file 
itself. 

2 

3 4 

5 

For Your Reference… 

To copy a table within a database file: 

1. In the Navigation pane, right-click on the 
table and select Copy 

2. On the Home tab, click on the top half of 
Paste 

3. Complete the dialog box options and click on 
[OK] 

Handy to Know… 

 Your database file will grow in size if you add 
copies of your tables. If you have a number 
of tables in the database file it may be more 
effective to make a backup copy of the 
database file rather than the tables. 
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DELETING A TABLE FROM A DATABASE FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Modifying 
Tables_9.accdb... 

 
In the Navigation 
pane, right-click on the 
Employees Backup 
table and select 
Delete 

A deletion warning 
message will display… 

 
Click on [Yes] to 
delete the table 

The deleted table will 
no longer appear in 
the Navigation pane 

 

For Your Reference… 

To delete a table from a database file: 

1. In the Navigation pane, right-click on the 
table and select Delete 

2. Click on [Yes] to delete the table 

Tables are simply objects stored within a 
database file. As such you can create them, 
modify them, and even delete them if so required. 
In general terms the only time you should really 

need to delete a table is when you no longer 
require copies of tables made for back-up and data 
protection purposes. 

1 

Handy to Know… 

 Deletion of a table is final – there’s no way 
back. It is a good idea therefore to make a 
back-up copy of the database file before 
deleting tables (or indeed, other objects) 
from the database. 

2 
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CHAPTER 5 SETTING TABLE RELATIONSHIPS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of setting table relationships 

 gain an understanding of how lookup tables are used for 
one-to-many relationships 

 learn how to create a lookup that will look up employee 
details 

 learn how to look up the expense types 

 learn how to view the relationship between the tables in a 
special relationships diagram 

 gain an understanding of table joins 

 learn how to edit joins between tables to enforce 
referential integrity 

 learn how to edit the Expense Type table join 

 learn how to manually create a join between tables 

 learn how to create a relationship report. 

Once tables have been designed and created in Microsoft Access 
you can commence the process of relating, or joining, the tables 
together. 

There are several advantages in relating tables. 

 When tables are related, Access allows you to create 
multi-table queries where the data is joined together into 
one recordset – this recordset can then be used to make 
the process of creating complex reports and forms much 
easier. 

 When a relationship has been set between two tables, 
Access provides special subforms and subdatasheets 
that make it easy to see related data. 

 With related tables you have the ability to enforce 
referential integrity – a set of rules that helps prevent 
erroneous data from entering the tables. 

INFOCUS 
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UNDERSTANDING TABLE RELATIONSHIPS 
 

 

 

 

 

 

In a relational system the database is normally 
made up of several tables that store your data. 
Where multiple tables exist they are linked or 
joined together, thereby forming a relationship 

which allows the system to add, update or report on 
the data contained in the tables as though they 
were one entity. 

Types of Relationships 

There are three types of relationships that can exist between tables: 

 one-to-one, where each record in a table is related to only one other record in another table – 
this is a rare form of relationship. 

 one-to-many, where one record in a table is related to many others in another table – this is 
the most common form of relationship and usually exists where one table is used to look up key 
values. In this type of relationship, the table with many records is often referred to as the 
transaction table, while the other table is known as the lookup table as it is used by the 
transaction table to lookup some data, usually a name, or a title, or something similar. 

 many-to-many, where many records in one table can be related to many records in another 
table – this is extremely rare and very problematic. 

Referential Integrity 

Referential integrity is probably the most significant benefit of relating tables.  

Let's consider two of the tables in our system, Expense Transactions and Employees. These 
tables can be related using a one-to-many relationship – there can be many expense transaction 
records for each employee. 

Since we need to know which employee raised a claim, it would be imprudent of our database if it let 
us create a new expense transaction without information about the employee. 

If we enforce referential integrity in the one-to-many relationship between the Expense 
Transactions and Employees table it will not be possible to enter a new expense record without 
assigning it to an employee record that exists in the Employees table. 

Referential integrity has some further options. For example if the EmpNo number for an employee 
changed it would be handy if Access would automatically update the number in all of the related 
tables – this can be done by activating Cascade Update. 

Similarly, if we delete an employee from the Employees table, we may wish to delete all of the 
expense transaction records for that employee from the system. This can be done by activating the 
Cascade Delete option – however, you should treat this with care and really examine the needs of 
your business before activating Cascade Delete. It is possible that you need to retain the expense 
records for a certain period of time, even if the employee has left. 

Relationships as Data Protection 

All of this theory is a lot of information to process. Look carefully at your data and you'll notice that 
these are only rules to protect your data and ensure that it remains updated and consistent. They 
also ensure that you don’t accidentally delete records that you need to keep.  
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UNDERSTANDING LOOKUP RELATIONSHIPS 
 

 

 

 

 

  

The most common reason for relating tables in a 
database file is for lookup purposes. Lookups 
are used when the details from single entity 
tables are required to be displayed in transaction 

tables, usually to assist in data entry or reporting. In 
our case study the expenses table uses the 
employee number, but to assist in data entry we 
need to display (i.e. lookup) the employee name. 

One-To-Many Relationships 

Lookup databases have a one-to-many relationship. 

In this type of relationship the lookup table contains unique records and forms the one side in the 
one-to-many relationship. The transaction table forms the many side in the one-to-many 
relationship because there may be many transactions for each record or entity from the lookup table. 

Lookups are done from the transaction table into the lookup table. 

In our case study we have two lookup requirements from the Expense Transactions table: one for 
employees and the other for expense types. 

With employees, the Employees table is the lookup table – there is only one record here for each 
employee. The Expense Transactions table is the transaction table – there may be many records 
for each of the employees in the Expense Transactions table. 

With expense types, the Expense Types table is the lookup table – there is only one record here for 
each type of expense that can be incurred. The Expense Transactions table is again the 
transaction table – there may be many records for each of the types in the Expense Type table. 

Table relationships are made possible by the use of the primary key in the lookup table. The role of 
the primary key is to keep records in order and to facilitate a fast search mechanism so that lookups 
appear almost instantaneously. The primary key is referenced from the transaction table using a 
lookup field, often with a similar name to that of the primary key in the lookup table. The value in 
the lookup field is used to search the primary key field in the lookup table and once found, data from 
other fields of the found record can be used. 

For example, with employees in our case study, the primary key of the Employees table is EmpNo 
and is used in that table to uniquely identify employees. For the relationships to work with Expense 
Transactions, there is a field called Employee. The value in the Employee field in the Expense 
Transactions table is used to look up the primary key field EmpNo in Employees for the correct 
employee. Once a match is made other details such as first name, last name etc. from Employees 
can be used for reports and displays such as drop-lists as shown above. 
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LOOKING UP THE EMPLOYEES TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once you have created a transaction and a 
lookup table, you can connect the two tables to 
form a relationship between them. One of the 
easiest ways to do this is to use the Lookup 

Wizard to create a Lookup Column in the 
transaction table. The wizard enables you to 
nominate the fields from the lookup table that you 
want displayed with your transaction data. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this exercise 
you MUST open the file 
Creating 
Relationships_1.accdb… 

 
Open the table Expense 
Transactions in Design 
View 

 
Click on Short Text in Data 
Type for EmpNo, then click 
on the drop arrow and 
select Lookup Wizard to 
start the Lookup Wizard 

 
Work through the wizard, 
making the selections as 
shown 

 
Click on [Finish] to 
complete the wizard, then 
click on [Yes] to save the 
changes 

Notice the EmpNo field is 
now called Employee… 

 
Click on the Employee 
field, then click on the 
Lookup tab in the Field 
Properties pane to see the 
settings that have been 
created 

 
Close the table 

 

2 

Screen Task Then 

1 Select I want the lookup field to get the 
values from another table or query 

[Next] 

2 Select Table:Employees [Next] 

3 Double-click on LastName then on FirstName 
in Available fields 

[Next] 

4 Select LastName for the first sort column, 
then FirstName for the second sort column, 
ensuring that both are set to Ascending order 

[Next] 

5 Ensure that Hide key column appears with a 
tick 

[Next] 

6 Type Employee as the label for the lookup 
field 

 

 

For Your Reference… 

To connect to a lookup table: 

1. Open the transaction table in Design View 
and click in the first blank row 

2. Click on Modify Lookups in the Tools group 

3. Follow the steps of the wizard and specify 
the relevant field details 

Handy to Know… 

 Relationships between tables can be done 
through the Lookup Wizard or you can 
create them manually in the Relationships 
pane. 

3 

4 
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LOOKING UP THE EXPENSE TYPES TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The second example of a lookup required in our 
case study database is one that looks up 
expense type details. The looking up is done 
from the transactions table and uses the expense 

type number as a lookup key. The wizard provides 
the quickest and easiest way of creating the 
lookup. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Relationships_2.accdb... 

 
Open the table Expense 
Transactions in Design 
View 

 
Click on Number in Data 
Type for ExpTypeNo, then 
click on the drop arrow and 
select Lookup Wizard to 
start the Lookup Wizard 

 
Work through the wizard, 
making the selections as 
shown 

 
Click on [Finish] to 
complete the wizard, then 
click on [Yes] to save the 
changes 

Notice the ExpTypeNo field 
has been changed to 
Expense Type… 

 
Click on the Expense Type 
field, then click on the 
Lookup tab in the Field 
Properties pane to see the 
settings that have been 
created 

 
Close the table 

 

Screen Task Then 

1 Select I want the lookup field to get the 
values from another table or query 

[Next] 

2 Select Table: Expense Type [Next] 

3 Double-click on Description in Available 
fields 

[Next] 

4 Ignore the sort order settings [Next] 

5 Ensure that Hide key column appears 
ticked 

[Next] 

6 Type Expense Type as the label for the 
lookup field 

 

 

4 

For Your Reference… 

To connect to a lookup table: 

1. Open the transaction table in Design View, 
then click in a blank row 

2. Change the relevant field to a Lookup field 

3. Follow the steps of the wizard and specify 
the relevant field details 

Handy to Know… 

 The lookup operation is performed in Access 
using SQL programming code. The code that 
does this is in the Row Source field of the 
Lookup tab in Field Properties. It’s worth 
having a look at this code to see how it is 
written. 

5 

3 
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VIEWING TABLE RELATIONSHIPS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Table relationships can be viewed and edited 
using the Relationships window. This window 
gives you a better understanding of how tables 
are related or joined together. It also lists all of 

the fields in each table so that you can locate 
content easily. The Relationships window can be 
used to document part of your database design by 
printing it as a report. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Relationships_3.accdb... 

 
Click on the Database 
Tools tab, then click on 
Relationships in the 
Relationships group 

The existing 
relationships between 
tables will be shown.  

 
On the Relationship 
Tools: Design tab, click 
on Show Table in the 
Relationships group to 
display the Show Table 
dialog box 

 
Double-click on 
Personal Details to add 
the table, then click on 
[Close] 

The lines that appear 
are join lines showing 
the table relationships… 

 
Use the mouse to drag 
the tables into position 
as shown 

 
Save and close the 
Relationships window 

 

2 

4 

For Your Reference… 

To view table relationships: 

1. Click on the Database Tools tab  

2. Click on Relationships in the Relationships 
group 

Handy to Know… 

 If you need a hard copy of the table 
relationships, click on the Relationship 
Tools: Design tab and click on 
Relationship Report in the Tools group. 
Click on the File tab to display the 
Backstage, select Print and click on Quick 

Print to print the report. 

IMPORTANT: 
Additional tables may 
display such as the 
MSysNavPaneGroups 
table. These are 
hidden system objects 
that keep track of the 
way database objects 
are grouped. To 
continue with the 
exercise, hide them by 
right-clicking on the 
Navigation pane, 
selecting Navigation 
Options, then clicking 
on Show Hidden 
Objects and Show 
System Objects so 
they both appear 
unticked. If this doesn’t 
work, right-click on the 
table and select Hide. 
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UNDERSTANDING TABLE JOINS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

While the actual process of joining tables in a 
relational database in Microsoft Access is easy, a 
reasonable degree of thought should be devoted 
before making the joins. In our case study we 

have four tables which will need to be joined. A little 
understanding of what types of joins we need and 
why we are using them is useful before proceeding 
much further. 

While the Relationships window is open, the quickest way to create a relationship is to drag the mouse 
from one field in a table to another field in a different table. The process is very simple and easy to do. 

For example, in the design of our Expenses System we have a transaction table that contains expense 
transactions (Expense Transactions) and another that contains details about our employees 

(Employees). 

This structure ensures that we don't re-enter employee details every time an employee has an expense to 
claim for – instead, we use the EmpNo number as a code to look up the employee details in the 
Employees table. 

Let's stop and consider what we are doing. With this relationship we are telling Microsoft Access that 
there will be one employee record in Employees and many in Expense Transactions. The two tables 
are related by the common field of EmpNo. In the Employees table the EmpNo field is the primary key 
– it is unique, there can only be one EmpNo number for each employee (remember, it appears with a key 
icon because it is the primary key).  

From a design perspective we are creating a one-to-many relationship. To do this, the link field in the one 

table must be the primary key. The link field in the many table becomes known as the foreign key. 

When a join is created in Microsoft Access, 
a line appears between the related fields in 
the two tables. The symbols on the line tell 
you what type of join it is. The infinity symbol 
indicates that the Expense Transactions 
table is a many table, while the one symbol 
indicates that the Employees table is a one 
table. 

We have several other issues to consider here. 

Should we enforce referential integrity? If we want to stop an expense record being created that is not 
linked to an existing employee, then the answer is yes. 

If we opt for referential integrity, do we want all of the EmpNo numbers in expenses to update when we 
change the EmpNo in Employees? If the answer is yes we must activate Cascade Update. 

Again, if we want all of the expenses for an employee to be deleted when we delete the employee from 
the Employees table, we must activate Cascade Delete. 

Naturally, these questions will need to be asked for all of the joins that we create between all of the tables 
in the system. 
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EDITING THE EMPLOYEE TABLE JOIN 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Joins created using the Lookup Wizard use the 
common join settings. They do not however have 
any referential integrity settings in place. If you 
want to establish integrity between the tables you 

will need to edit the join in the Relationships 
window. In our case study we want to ensure that 

updates are reflected from the Employees table. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Creating 
Relationships_4.accdb... 

 
On the Database Tools tab, 
click on Relationships in the 
Relationships group 

 
Click on the join line between 
the Expense Transactions 
and Employees tables to 
select it – it should appear 
slightly thicker 

 
On the Relationship Tools: 
Design tab, click on Edit 
Relationships in the Tools 
group to display the Edit 
Relationships dialog box 

 
Click on Enforce Referential 
Integrity until it appears with a 
tick 

 
Click on Cascade Update 
Related Fields until it appears 
with a tick 

 
Ensure Cascade Delete 
Related Fields appears 
without a tick 

 
Click on [OK] to apply the 
changes 

The symbols on the join 
indicate a one-to-many 
relationship… 

 
Close the Relationships 
window 

 

2 

3 

For Your Reference… 

To edit relationship joins: 

1. Click on the join line to select it 

2. On the Relationship Tools: Design tab, 
click on Edit Relationships in the Tools 
group 

3. Make the changes as appropriate 

Handy to Know… 

 In a one-to-many relationship where 
referential integrity is enforced, you cannot 
enter a record into the many (transaction) 
table unless the related (linked) field has 
been entered into the one (lookup) table as a 
record. The integrity of the relationship is 
thereby enforced (watched). 

7 
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EDITING THE EXPENSE TYPE TABLE JOIN 
 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

We should also set the referential integrity 
options for the join between the Expense 
Transactions and Expense Type tables. Since 
these tables form a one-to-many type of 

relationship, referential integrity will ensure that we 
can’t enter a record in the transactions table 
without a relevant entity in the lookup table. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Creating 
Relationships_5.accdb... 

 
On the Database Tools tab, 
click on All Relationships in 
the Relationships group 

 
Click on the join line between 
the Expense Transactions 
and Expense Type tables to 
select it – it should appear 
slightly thicker 

 
On the Relationship Tools: 
Design tab, click on Edit 
Relationships in the Tools 
group to display the Edit 
Relationships dialog box 

 
Click on Enforce Referential 
Integrity until it appears with a 
tick 

 
Click on Cascade Update 
Related Fields until it appears 
with a tick 

 
Ensure Cascade Delete 
Related fields appears 
without a tick 

 
Click on [OK] to apply the 
changes 

 
Close the Relationships 
window 

 

2 

6 

For Your Reference… 

To edit relationship joins: 

1. Click on the join line to select it 

2. On the Relationship Tools: Design tab, 
click on Edit Relationships in the Tools 
group 

3. Make the changes as appropriate 

Handy to Know… 

 If you want linked transactions to be deleted 
when a record is deleted in a lookup table, 
tick Cascade Delete in the Edit 
Relationships dialog box – but do not tick it 
if you want to keep the transactions (e.g. for 
accounting purposes). 

7 
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CREATING A NEW JOIN 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Not all tables are joined using the Lookup 
Wizard. Indeed, once you are proficient with the 
way joins work, you’ll probably find yourself 
manually creating your own joins. In our case 

study we need to establish a join between the 
Employees table and the Employee Details table 
– this will be a one-to-one join type. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous file 
with this exercise, or open the 
file Creating 
Relationships_6.accdb... 

 
On the Database Tools tab, 
click on Relationships in the 
Relationships group 

 
Click on EmpNo in the 
Employees table, then drag and 
drop the field on EmpNo in the 
Personal Details table 

This will open the Edit 
Relationships dialog box… 

 
Ensure that the three referential 
integrity boxes appear with a tick 

 
Click on [Join Type] to see the 
Join Properties dialog box 

 
Click on option 2: to create a left 
outer join where ALL employee 
records will be displayed 

Employees is the dominant table 
and we always want to see the 
records here… 

 
Click on [OK] to return to the 
Edit Relationships dialog box, 
then click on [Create] to create 
the join 

You might need to move the 
tables slightly to see the join… 

 
Save and close the 
Relationships window  

 

2 

4 

For Your Reference… 

To create a new join between tables: 

1. Drag one joining field onto the other 

2. Choose the appropriate degree of referential 
integrity required 

3. Click on [Join Type] and specify the desired 
type of join 

6 

Handy to Know… 

 When creating a new join manually, the 
default join type, where only rows that 
appear in both tables are included, is known 
as an inner join. If you want to see all 
records in the main table, irrespective of 
whether there is a related record in the linked 

table, create a left outer join. 
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CREATING A RELATIONSHIP REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Relationships_7.accdb... 

 
On the Database Tools 
tab, click on 
Relationships in the 
Relationships group 

 
On the Relationship 
Tools: Design tab, click 
on Relationship Report 
in the Tools group to 
create a report of the 
relationships 

The report appears as 
another tab in the 
database window… 

 
On the Print Preview tab, 
click on Print in the Print 
group to display the Print 
dialog box 

 
Ensure that your printer is 
online and ready to print, 
then click on [OK] 

 
Close the Relationships 
for… window without 
saving it 

 
Close the Relationships 
window 

 

Once all of your table relationships are created 
and have been refined the way you want, it is a 
good idea to document these relationships. The 
Relationships window allows you to produce a 

Relationship Report which is, in reality, a print 
preview version of the relationships window. For 
documentation purposes, you can then print this to 
either paper or a file. 

2 

For Your Reference… 

To produce a relationship report: 

1. Click on the Database Tools tab and click 
on Relationships in the Relationships 
group 

2. On the Relationship Tools: Design tab, 
click on Relationship Report in the Tools 
group 

Handy to Know… 

 A relationship report is actually created as an 
Access form. Even though you can save the 
report, there is little point in doing so unless 
you want to keep the current version of the 
relationships for your records. It takes so little 
time to create a new report, it’s just not worth 
the bother. 

3 
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CHAPTER 6 ADDING RECORDS TO A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to type records directly into a table 

 learn how to add records to a table using a default form 

 learn how to save a default form layout for reuse 

 learn how to enter records into a table using an existing 
form 

 gain an understanding of adding additional records 

 learn how to import records into a table from an Excel 
workbook. 

Once tables have been created in a database file, the next step is to 
add the data to the tables. Each line that is added to a table is 
known as a record. Each record is a single instance of a particular 
entity, such as a person, an event or an object. 

INFOCUS 
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TYPING RECORDS IN A TABLE 
 

 

 

 

 

 

 

 

 

 

 

Kerr 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
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Before starting this 
exercise you MUST 
open the file Adding 
Records_1.accdb… 

 
In the Navigation 
pane, double-click on 
the Employees table 
to open it 

The table will appear 
empty because no 
records have yet been 
entered. To enter a 
record, you type the 
data into each field 

and press  to 
move between the 
fields… 

 
Type the data as 
shown – use the 
mouse to click the 
check box for 
FullTime and press 

 to move through 
the fields 

 
Check that your data 
matches that shown 

 
Close the table 

 

For Your Reference… 

To add a record to a table: 

1. Double-click on the table in the Navigation 
pane to open it in Datasheet view 

2. Type the data into each field, pressing  
to move across fields 

Handy to Know… 

 When entering data, long entries will appear 
truncated on the screen, but the complete 
data is stored in the field. 

 Records are saved automatically when you 
move to the next field or record. 

 To correct an error when adding a record, 
simply type over it. 

1 

The easiest way to enter data is directly into an 
open table. When you open a table you are 
shown the Datasheet view by default. Access 
always displays the records in the table plus one 

additional row at the bottom of the table. This is the 
new record row where a new record can be 
entered. The total number of records, shown in the 
status bar, will increase as you add data. 

 Record 1 Record 2 Record 3 

EmpNo: 101 102 103 

FirstName: Julianne Harry Angel 

LastName: Kerr Jones Harrington 

Department: Executive Executive Executive 

PhoneNo: 60001 60002 60003 

Started: 28/6/2010 19/7/2010 19/7/2010 

DateOfBirth: 5/2/1960 13/4/1965 19/8/1958 

FullTime: 
   

WeeklyHours 40 40 40 

Salary: $250,000 $140,000 $145,000 

Comments:    

 

2 

3 
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ADDING RECORDS USING A FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Adding 
Records_2.accdb... 

 
In the Navigation pane, click 
on the Employees table to 
ensure it is selected 

 
Click on the Create tab, then 
click on Form in the Forms 
group to display the first record 
of data in a form layout 

The form layout is like a 
structure. We need to be in 
Form view to work with the 
data… 

 
On the Form Layout Tools: 
Design tab, click on the top 
half of View in the Views 
group to display the form in 
Form view 

 
Click on New (blank) record 
in the bar at the very bottom of 
the form to display a new 
record – a yellow dotted 
square appears on this tool 

 
Type the three records, as 

shown, pressing  to move 
down the fields 

 
Close the form – since the 
form is a new object you will 
be asked if you wish to save it 

 
Click on [No] 

 

For Your Reference… 

To add records using a default form: 

1. Click on the table in the Navigation pane 

2. Click on the Create tab, then click on Form 
in the Forms group 

3. Click on the Home tab and click on View in 

the Views group 

Records can also be added to a table using a 
form. A form normally displays the details for one 
record on the screen at a time. It is like a card in 
a manual card file system. In Access you can 

create quite sophisticated forms for data entry and 
data display. You can also create a simple form for 
immediate data entry purposes using the Form 
command. 

The New (blank) record tool 
3 

 Record 4 Record 5 Record 6 

EmpNo: 104 105 106 

FirstName: Peter Mark Maureen 

LastName: Dawson Jones Grayson 

Department: Executive Executive Administration 

PhoneNo: 60004 60005 61021 

Started: 19/7/2010 19/7/2010 6/9/2010 

DateOfBirth: 12/7/1954 6/8/1963 23/10/1974 

FullTime: 
   

WeeklyHours 40 40 40 

Salary: $140,000 $132,000 $85,000 

Comments:    

 

Handy to Know… 

 When you click on Form on the Create tab, 
a default form is built from the table design 
and appears in Layout view, which allows 
you to change the layout of the form. You 
switch to Form view to work with the data, 
much the same as you switch to Datasheet 
view to work with data in a table. 

5 
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SAVING A FORM LAYOUT FOR REUSE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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e
 

Continue using the previous 
file with this exercise, or 
open the file Adding 
Records_3.accdb... 

 
In the Navigation pane, 
click on the Employees 
table to select it 

 
Click on the Create tab, 
then click on Form in the 
Forms group to display the 
first record of data in a form 
layout 

We won’t make any 
changes here (even though 
we could)… 

 
Click on the File tab to 
display the Backstage, then 
click on Save to display the 
Save As dialog box 

 
Type Employees Form in 
Form Name, then click on 
[OK] 

The form will now appear in 
the Navigation pane, under 
the Forms header… 

 
Close the form 

 

For Your Reference… 

To save a default form for reuse: 

1. Click on the table to select it, then click on 
the Create tab and click on Form in the 
Forms group 

2. Click on the File tab and click on Save 

3. Type a Form Name and click on [OK] 

Default Forms are quick and easy forms created 
by Access to facilitate either data viewing or data 
entry. You can, if you wish, save default forms for 
future use. When you save a default form, a new 

form object is created which will appear in the 
Navigation pane. It can then be opened any time it 
is required. 

2 

3 

Handy to Know… 

 Access uses headers (e.g. Tables, Forms, 
Reports etc.) in the Navigation pane to 
group the different objects, making it easier 
to differentiate and locate items quickly. This 
is particularly useful if two or more objects 
share the same name (e.g. Employees). 

4 
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ADDING RECORDS USING AN EXISTING FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Adding 
Records_4.accdb... 

 
In the Navigation pane, 
double-click on 
Employees Form to open 
the form in Form view 

 
Click on New (blank) 
record in the bar at the 
very bottom of the form to 
display a new record 

 
Complete the new record 
as shown 

 
Click on Close to close 
the form 

 

Forms appear in the Navigation pane and are 
used to display data and make changes to data, 
including adding new records. It doesn't matter 
whether your form was created from a default 

form or from scratch, you use it in exactly the same 
way. To add a record using an existing form you 
open it, click on the new record button and start 
typing. 

1 

For Your Reference… 

To add records using an existing form: 

1. Double-click on the form in the Navigation 
pane 

2. Click on New (blank) record and enter the 
desired data 

Handy to Know… 

 The navigation buttons at the bottom of the 
form can be used to display different records 
in the table. 

3 
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ADDING ADDITIONAL RECORDS 
 

 

 

 

  

 

Records can be added to a table directly by 
typing in the new record line of the opened table, 
or by using a form. The choice is entirely yours. 
In this section you'll have the opportunity to add 

more records using whichever technique you 
prefer, and to practise moving between the fields 
and records in a datasheet or form. 

Sub Heading 

Ensure you have completed the previous exercises and continue using the previous file, then open 
either the Employees table or the Employees Form and enter the data as shown below. It doesn’t 
matter in which order you type records. When a table is opened the records are always sorted according 
to the primary key. You can select or tick a checkbox using the keyboard rather than the mouse. Simply 
press   to move to the checkbox then press   to toggle on and off 

 

 Record 8 Record 9 Record 10 Record 11 Record 12 Record 13 

EmpNo: 108 109 110 111 112 113 

FirstName: Amanda George Neville Petra Vivienne Jerry 

LastName: Bennet Samuelson Smith Henricks Clark Hancock 

Department: Administration Administration Administration Administration Administration Administration 

PhoneNo: 61023 61024 61025 61026 61027 61028 

Started: 6/9/2010 6/9/2010 6/9/2010 6/9/2010 6/9/2010 6/9/2010 

DateOfBirth: 4/5/1959 1/12/1987 7/8/1954 3/4/1981 22/11/1961 9/10/1975 

FullTime: 
      

WeeklyHours 40 40 40 40 40 40 

Salary: $87,000 $98,000 $78,000 $82,000 $80,000 $79,000 

Comments:   Studying MBA    
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IMPORTING FROM MICROSOFT EXCEL 
 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Access can import data from a wide variety of 
applications, including Microsoft Excel. The key 
to importing successfully, is ensuring that the 
structure that you import from has the same field 

names as the table into which the data is to be 
placed. In our case study we are assuming that 
Alpheius Global Enterprises already has an 
employee data list in an Excel spreadsheet format. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Adding Records_5.accdb... 

 
Click on the Employees 
table to select it 

 
Click on the External Data 
tab, then click on Excel in 
the Import & Link group to 
display the Get External 
Data dialog box 

 
Click on [Browse], locate 
the file Employee List.xlsx 
in C:\Course Files for 
Microsoft Access 2016, 
then click on [Open] 

 
Click on Append a copy of 
the records to the table 
Employees, then click on 
[OK] to start the Import 
Spreadsheet Wizard 

 
Click on [Next] until you 
arrive at the last screen 

 
Click on [Finish], then click 
on [Yes] and [Close] to 
complete the operation 

 
Double-click on the 
Employees table to open it 
and see the data 

 
Click on Close to close the 
table 

 

4 

For Your Reference… 

To import records from Microsoft Excel: 

1. Click on the External Data tab, then click on 
Excel in the Import & Link group 

2. Browse for the file to import, click on [OK], 
then follow the wizard to complete the import 

The Record count indicates that the table now contains 
104 records 

7 

Handy to Know… 

 The Import Wizard is by far the easiest way 
to import data and provides useful prompts 
along the way. Study each step carefully to 
see what options are available to you. 

 Importing can mess up data in a table – it is 
a good idea to make a backup of a table 
before importing into it. 
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CHAPTER 7 ADDING TRANSACTIONAL RECORDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to type transactional records 

 learn how to add transactional records using a form 

 gain an understanding of adding additional transactional 
records 

 learn how to add transactional records using a 
subdatasheet 

 learn how to remove a subdatasheet 

 learn how to insert a subdatasheet. 

Transactional records are instances of a particular transaction, such 
as an expense, trip, visit, plane flight, appointment, purchase, and 
so on. 

Transactional records require not only the details of the transaction 
itself, but they require you to include a link to the lookup table. In 
terms of our case study, when you add an expense, you need to 
nominate the employee who the expense relates to. 

INFOCUS 
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TYPING TRANSACTIONAL RECORDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file Transactional 
Records_1.accdb… 

 
Double-click on the 
Expense Transactions 
table to open it 

The first field, an 
Autonumber, will be 
entered automatically for 
you when you start 
typing… 

 
Press  to move to 
ExpDate, type 2/1/2017 

then press  to move 
to Description 

 
Type Accommodation A 

then press  to move 
to Amount and type 132 

 
Press , then click on 
the drop arrow for 
Employee to see a list of 
employees from the 
Employees table 

 
Type d to move to the 
first employee starting 
with this letter, then click 
on Dawson Peter 

 
Close the table 

 

1 

When you enter data into the datasheet of a 
transaction table, the values in the lookup table 
become available as a drop-down list in the 
linked field of the transaction table. In terms of 

our example, rather than having to remember and 
type the employee number for a particular expense, 
you can select from any of the employees in the 
Employees table. 

2 

For Your Reference… 

To add transactional records to a table: 

1. Double-click on the table 

2. Type the data and press  to move 
between fields 

3. Click on the drop arrow in the lookup field 
and click on the relevant link record 

Handy to Know… 

 When you use a form to add a record to a 
transaction table, the lookup table appears 
as a subform. 

5 
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ADDING TRANSACTIONAL RECORDS USING A FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Records can also be added to a transaction table 
using a form. When a transaction table is linked 
to a lookup table, you can enter transactions via 
the lookup table. Access will automatically create 

a sub-form for the transactions so that transactions 
can be entered directly against a particular 
employee. The right employee must be selected 
before the transaction details are entered. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Transactional 
Records_2.accdb... 

 
Click on the Employees 
table to ensure it is 
selected 

 
Click on the Create tab, 
then click on Form in the 
Forms group to display 
the first record of data in a 
form layout 

 
On the Form Layout 
Tools: Design tab, click 
on the top half of View in 
the Views group to see 
the form in Form view 

 
Click in ExpDate in the 
sub-form (located beneath 
the main form), type 

2/1/17, then press  

 
Type Accommodation A 
in Description, press  

, then type 145 in 

Amount and press  

 
Close the form – since the 
form is a new object you 
will be asked if you wish 
to save it 

 
Click on [No] 

 

3 

The sub-form displays an individual employee and their 
transactions in a single window beneath the main form. 

For Your Reference… 

To add a transactional record using a form: 

1. Click on the Create tab, then click on Form 
in the Forms group 

2. Click on View in the Views group, then enter 
the data into the sub-form 

Handy to Know… 

 You can use the normal controls on a form to 
navigate to the desired record before 
entering data into the sub-form – you do not 
need to necessarily enter data into the first 
record. 

5 
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ADDING ADDITIONAL TRANSACTIONAL RECORDS 
 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Records can be added to a table directly by 
typing into the new record line of the open table 
or by using a form. The choice is entirely yours. 
In this section you'll have the opportunity to add 

more records using whichever of these techniques 
you prefer. 
 

Adding Records 

Either open the Expense Transactions table or use a default form to type the records as shown 

 Close the table or the form when you have finished. If you decide to use a form based on the transaction 
table, the form will appear with the first record in the table on display. You then need to click on either 
the Next Record button or the New Record button at the bottom of the form window until a blank form 
appears for data entry. 

 It doesn't really matter in which order you type these transactions into the table. When the table is 
reopened later, the records will be sorted into Primary Key (ExpTransNo) order by Access. 

 

 

 Record 3 Record 4 

Date: 2/01/2017 2/01/2017 

Description: Gifts Postage 

Amount: $27.06 $3.59 

Employee: 
(EmpNo) 

Ali, Syed  Moore, Belinda  

 

 Record 5 Record 6 

Date: 2/01/2017 2/01/2017 

Description: Postage Accommodation A 

Amount: $16.99 $154.50 

Employee: 
(EmpNo) 

Morris, Charles  Clark, Vivienne  

 

 Record 7 Record 8 Record 9 

Date: 2/01/2017 2/01/2017 2/01/2017 

Description: Accommodation A Other Expenses Coffee and Tea 
Expenses 

Amount: $125.50 $48.39 $18.26 

Employee: 
(EmpNo) 

Millson, Augustine Dangaard, Elizabeth  Brown, Victor  

 Record 10 Record 11 Record 12 

Date: 2/01/2017 2/01/2017 2/01/2017 

Description: Coffee and Tea 
Expenses 

Accommodation A Accommodation B 

Amount: $7.72 $123.44 $237.86 

Employee: 
(EmpNo) 

Samuelson, George  McDonald, Victoria  Williams, Lance  
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ADDING RECORDS USING A SUBDATASHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In Access when you view a lookup table you can 
also see the transaction table records related to 
the record currently selected in the lookup table. 
For example, when we view an employee in the 

Employees table, we can also see the related 
expenses for that employee in the Expense 
Transactions table. The related records appear in 
a subdatasheet – a datasheet within a datasheet. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Transactional 
Records_3.accdb... 

 
In the Navigation pane, 
double-click on the 
Employees table to 
open it 

 
Click on expand  for 
EmpNo 107 to see the 
expense details for that 
employee 

The related records from 
the Expense 
Transactions table will 
appear and the button 
will change to a minus 
sign… 

 
Click in ExpDate on the 
(New) line and type the 
new records, as shown 

 
Click on collapse  to 
close the subdatasheet 

 
Click on  and  for 
several other employees 
and examine their 
records (try 101 and 
109) 

 
Close the table 

 

2 

3 

For Your Reference… 

To add records using a subdatasheet: 

1. Double-click on the lookup table 

2. Click on expand  for a record to see the 
subdatasheet 

3. Enter data into a (New) record of the 
subdatasheet as normal 

13 2/01/2017 Meals 52.86 

14 16/01/2017 Accommodation A 155.60 

 

Handy to Know… 

 You need to have a good understanding of 
the relationships between your tables to 
effectively use the subdatasheet features. 
Just remember that the subdatasheet is 
usually the transaction table (i.e. with the 
many records). 
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REMOVING A SUBDATASHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Subdatasheets are created automatically when 
you link a lookup table and transactional table. If 
you prefer not to have the transaction details 
visible via the lookup table, you can remove the 

subdatasheet. This procedure does not interfere 
with the relationship between the tables and does 
not affect the data in any way. 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Transactional 
Records_4.accdb... 

 
In the Navigation pane, 
double-click on the 
Employees table to open it 

 
On the Home tab, click on 
More in the Records group 
to display a menu 

 
Point to Subdatasheet, 
then select Remove to 
remove the current 
subdatasheet from the 
layout 

Notice that the expand 
icons  are no longer 
displayed… 

 
Close the table 

Removing a subdatasheet 
alters the layout of a table, 
so you will be asked if you 
want to save these 
changes… 

 
Click on [Yes] to save the 
changed layout and close 
the table 

 

1 

3 

For Your Reference… 

To remove a subdatasheet: 

1. On the Home tab, click on More in the 
Records group 

2. Point to Subdatasheet then select Remove 

Handy to Know… 

 Removing a subdatasheet is effectively the 
same as hiding it. The data previously shown 
in the subdatasheet is not deleted. All you 
have done is removed the option to view it 
from the datasheet, which is one way of 
protecting the data. 

4 
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INSERTING A SUBDATASHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If a subdatasheet has been removed either 
deliberately or accidentally, or if a lookup table is 
linked to more than one other table, you may 
need to use the Insert Subdatasheet dialog box 

to assign a transaction table to the lookup table. 
Access knows which field to link the tables on 
because of the table relationships that you 
established earlier. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Transactional 
Records_5.accdb... 

 
In the Navigation pane, 
double-click on the 
Employees table to open 
it 

 
On the Home tab, click on 
More in the Records 
group to display the menu 

 
Point to Subdatasheet 
then select Subdatasheet 
to display the Insert 
Subdatasheet dialog box 

Since we are currently in 
the Employees lookup 
table, it is the Expense 
Transactions table that we 
wish to insert as a 
subdatasheet… 

 
Click on Expense 
Transactions, then click 
on [OK] to insert this table 
as a subdatasheet 

Expand icons are 
displayed in the leftmost 
column… 

 
Close the table and click 
on [Yes] to save the 
changed layout 

 

1 

3 

For Your Reference… 

To insert a subdatasheet: 

1. On the Home tab, click on More in the 
Records group 

2. Point to Subdatasheet and select 

Subdatasheet 

Handy to Know… 

 If a lookup table is linked to more than one 
transaction table, the Insert Subdatasheet 
dialog box can be used to switch between 
transaction tables. 

4 
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NOTES: 
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CHAPTER 8 WORKING WITH RECORDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to navigate through records in a table 

 learn how to navigate to a specific record 

 learn how to edit records in a table 

 learn how to delete data in a record 

 learn how to undo changes made to records in a table 

 learn how to delete a record from a table 

 learn how to delete several records 

 learn how to search for text in a table 

 learn how to search within a field 

 learn how to find and replace data in a table 

 learn how to print records from a table 

 learn how to compact a database. 

Databases constantly need updating. Customers change address, 
prices rise or fall, and incorrect data sometimes gets typed into a 
database. 

Microsoft Access makes it relatively easy to make changes to 
existing data. In computer jargon when you make a change to data 
it is referred to as editing. 

As a fully-functional database management system, Access allows 
you to both edit and delete data. This can be done either in a form 
or through Datasheet view where your data is presented in rows 
and columns on the screen. 

INFOCUS 
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TABLE NAVIGATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To be able to edit, delete and even add data to a 
table, you need to be able to locate the data that 
you want. To locate specific data, you need to 
know how to navigate through a table of data. 

When a table is open, one record of the table is 
deemed to be the active record. An active record 
is highlighted blue and the active field is outlined in 
orange. 

Try This Yourself: 

O
p

e
n
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Before starting this exercise 
you MUST open the file 
Working With 
Records_1.accdb… 

 
Double-click on the 
Employees table to open it 

The first record is the “active” 
or “current” record… 

 
Press  and  several times 
to change the active record 

The navigation bar at the 
bottom of the screen indicates 
the current record… 

 
Press  and  several 
times to move down and up a 
screen at a time 

 
In the navigation bar, click on 
the Last record button to 
move to the last record 

 
Click on the Previous record 
button several times to move 
up through the records 

 
Click on the First record 
button to move back to the first 
record 

 
Close the table 

 

1 

2 

The navigation bar contains the First record, Previous record, 
Current Record, Next record, Last record and New (blank) 
record tools. 

For Your Reference… 

To navigate records in a table you can: 

 Click on the buttons in the navigation bar at 
the bottom of the window 

 Press , , , or  

Handy to Know… 

 There will always be one record in a table 
that is deemed to be the active record. The 
active record is the one that is referred to in 
the Current Record field in the navigation 
bar at the bottom of the database window. 

4 

The Last record button 
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NAVIGATING TO A SPECIFIC RECORD 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Techniques such as using the record buttons to 
navigate through a table are fine if you have a 
small number of records, but can be very tedious 
if you have a medium to large number of records 

to step through. You can use the record number in 
the Current Record field to navigate directly to a 
specific record as long as you know the number of 
the record you require. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Working With 
Records_1.accdb... 

 
Double-click on the 
Employees table to open 
it 

Notice that there are 104 
records in the table… 

 
In the navigation bar, 
double-click on the record 
number (in our case it is 
1) in the Current Record 
box to select it 

 
Type 50 and press  
to move to record 50, 
which is EmpNo 150 in 
the table 

 
Click on the First record 
button to return to the first 
record 

 
Close the table 

 

1 

2 

For Your Reference… 

To navigate to a specific record: 

1. Double-click on the Current Record box in 
the navigation bar 

2. Type the record number you wish to move to 

and press  

3 

Handy to Know… 

 Record numbers are assigned by the table to 
the record – do not use the record number as 
a means of identifying a record other than for 
immediate navigation purposes. When 
records are deleted the record numbers are 
reassigned to remaining records in the table. 
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EDITING A RECORD 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Records in a table can be edited simply by 
clicking on the data to be changed. When you 
click on data in a table, the record pointer jumps 
immediately to that record. If you double-click on 

a word in a record, the text will be selected ready 
for editing. Whatever you type will replace the 
existing text. The changes are saved when you 
move to another record. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Working With 
Records_1.accdb... 

 
Double-click on the 
Employees table to open it 

 
Double-click on the word 
Administration in Department 
for Maureen Grayson (record 
106) to select it 

 
Type Occupational Safety, 

then press  

The department name is 
replaced and the edit highlight 
moves to the next field. Notice 
also that the record pointer 
appears as a pencil to indicate 
that a change has been made 
in the record and that you are 
in edit mode... 

 
Press  to save the changes 
and move to the next record 

 
Click after 06 in the Started 
date field for Lance Williams 
(118) 

 
Press  twice to delete 06, 

type 23, then press  

 
Close the table 

 

2 

3 

5 

For Your Reference… 

To edit data in a table: 

1. Click on, double-click on or click and drag 
over the text to select it 

2. Type the new text 

3. Press ,  or  to save the changes 

Handy to Know… 

 A record, and any changes made to it, is 
automatically saved when the record pointer 
leaves the record or field – you can use any 
of the navigation techniques to move to 
another record. 

6 
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DELETING RECORD DATA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can delete data in a record if you find it is no 
longer accurate or appropriate. For example, you 
may import data from another table and find that 
some clean-up of the data is required, or there 

may be organisational changes that result in the 
change of position or department names. Deleting 
data in a record is a similar process to deleting text 
in a word processing document. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Working With 
Records_2.accdb... 

 
Double-click on the 
Employees table to open it 

 
Double-click on the border 
between the column 
headings for Department 
and PhoneNo to widen the 
Department column 

 
Scroll down to the record 
for Antony De Rozario 
(119), then use the mouse 
to select the words Sales & 

 
Press  to delete the text 

Ensure that you also delete 
the space after the 
ampersand (&)… 

 
Press  to save the 
changes 

 
Click at the end of the word 
Marketing in Department 
for Eileen Reilly (123) 

 
Press  to delete the 
words & Marketing then 

press  

 
Close the table, then click 
on [No] so that the 
changes to the column 
widths are not saved 

 

2 

3 

4 

For Your Reference… 

To delete record data: 

 Position the cursor after the text in the record 

and press , or 

 Select the text and press  

Handy to Know… 

 You can select data in a record by dragging 
the mouse across the text or by 
double-clicking on a word. 

 If you click in a record and press , the 

character to the right of the cursor will be 
deleted. 

7 

5 
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UNDOING A CHANGE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Access, like most other applications, has an 
Undo facility which allows you to recover from 
the last operation. Unlike other applications, 
however, it is rather limited and will undo 

changes to formats and only minor changes to 
data. It does not undo record deletions or global 
find and replace operations – two operations that 
cause the greatest misery. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Working With 
Records_3.accdb... 

 
Double-click on the 
Employees table to open it 

 
Double-click on the name 
Millson for EmpNo 107 

 
Type Milford, then press  
to save the change 

To change it back you could 
simply retype it, but what if you 
can’t remember how to spell 
the name? 

 
In the Quick Access Toolbar, 
click on Undo to undo the 
change 

 
Double-click on Bennet (108) 
under LastName, type 

Bennett, then press  to 
save the record 

This time the changes apply to 
a record other than the current 
one… 

 
In the Quick Access Toolbar, 
click on Undo to undo the 
change 

 
Close the table 

 

2 

3 

For Your Reference… 

To undo a change: 

 Click on Undo in the Quick Access Toolbar 

Handy to Know… 

 The Undo operation has more chance of 
success if you perform it as soon as you 
realise an error has occurred. Once you have 
closed a table, changes that were performed 
on it in the previous session can no longer be 
undone. 

4 
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DELETING A RECORD 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Imagine a database as a long list of entries. To 
delete a record the database must pull the record 
out of the list, move all of the records below it up 
one line in the table, and then renumber the list. 

Fortunately, all of this happens behind the scenes. 
However, once a record is deleted, the only way for 
that record to be brought back again is for it to be 
entered as a new record. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Working With 
Records_4.accdb... 

 
Double-click on the 
Employees table to open it 

The grey box to the left of a 
record is known as the record 
box and it enables you to 
select the entire record… 

 
Click on the record box for 
EmpNo 116 to select the 
record – this should be Nellie 
Adams 

 
On the Home tab, click on 
Delete in the Records group 

The record will disappear from 
the table and a warning will be 
displayed, offering you a last 
chance to back out of the 
deletion… 

 
Click on [Yes] to delete the 
record 

 
Close the table 

 

2 

3 

For Your Reference… 

To delete a record from a table: 

1. Click on the record to delete 

2. On the Home tab, click on Delete in the 
Records group 

3. Click on [Yes] to confirm the deletion 

4 

Handy to Know… 

 Deletion is permanent – the only way to 
recover a deleted record is to re-enter it. 
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DELETING SEVERAL RECORDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Working With 
Records_5.accdb... 

 
Double-click on the 
Employees table to open it 

 
Click on the record box for 
EmpNo 121 to select the 
record 

 
Hold down  and click on 
the record box for EmpNo 123 
to select the three employees 

 
On the Home tab, click on 
Delete in the Records group 

The selected records will 
disappear from the table and a 
warning will be displayed, 
offering you a last chance to 
back out of the deletion… 

 
Click on [Yes] to delete the 
records 

 
Close the table 

 

Providing records are listed together (sometimes 
this is referred to as contiguous listing) you can 
delete several records at a time. This will 
require you to select several records at once 

which can be done using the  key. Once the 
records are selected, they can be deleted using the 

Delete command. 

2 

3 

4 

For Your Reference… 

To delete several records: 

1. Click in the record box for the first record, 

hold down  and click in the record box 
for the last record in a contiguous range 

2. On the Home tab, click on Delete in the 
Records group and click on [Yes] 

Handy to Know… 

 Unlike other Windows applications you can’t 

use the  key to select multiple, 
non-contiguous records. Only records that 
are grouped together (i.e. contiguous) can be 
selected. 

5 
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SEARCHING IN A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Access provides a search box at the bottom of a 
datasheet which allows you to search an entire 
table for specific text. As you begin typing in the 
Search box, the first record with data matching 

the search criteria will be highlighted. For example, 
if you type a the first entry beginning with the letter 
a is highlighted. If you then type b the first entry 

beginning with ab is highlighted, and so on. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Working With 
Records_6.accdb... 

 
Double-click on the 
Employees table to open it 

 
Click in the Search box in the 
navigation bar at the bottom of 
the window 

 
Type a, then f, then o and 
notice how the search finally 
arrives at Lisa Afonczenko 

This is because her last name 
begins with the letters afo… 

 
Double-click on afo in the 
Search box and type 02-D to 
find the first date for 02-Dec 

 
Close the table 

 

2 

The Search field appears at the bottom of the window 

3 

For Your Reference… 

To search in a table: 

1. Click in the Search box in navigation bar 

2. Type the text you wish to search for until the 
record is found 

Handy to Know… 

 The Search box is fine for general searching 
across the table. It is not good for specific 
searches in a field. 
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SEARCHING IN A FIELD 
 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

The Search box at the bottom of a Datasheet 
window is useful for a general search of the 
entire table. There are other, more specific, 
search tools available in Access for searching 

within a field. These tools are made available by 
right-clicking on a field heading to display the 
shortcut menu and then selecting the Find option 
to display the Find What dialog box. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Working With 
Records_6.accdb... 

 
Double-click on the 
Employees table to open it 

 
Right-click on the LastName 
field header and select Find 
to display the Find and 
Replace dialog box 

 
Type Smith in Find What, 
then click on [Find Next] to 
display the first occurrence 

 
Click on [Find Next] to 
display the next occurrence, 
then click on [Find Next] and 
notice how a message 
appears advising that there 
are no more matching 
records 

 
Click on [OK], then in the 
Find and Replace dialog 
box click on the drop arrow 
for Match and select Any 
Part of the Field 

 
Click on [Find Next] to and 
notice that Baker-Smith is 
now found  

 
Click on [Cancel] to close 
the Find and Replace dialog 
box 

 
Close the table 

 

2 

3 

For Your Reference… 

To search within a field: 

1. Right-click on the desired field header and 
select Find 

2. Type the Find What value you are looking 
for and click on [Find Next] to search within 
the field 

Handy to Know… 

 If you want to search for text that occupies 
an entire field, click on the drop arrow for 
Match and click on Whole Field in the Find 
and Replace dialog box. Then, for instance, 
typing Smith would not locate Baker-Smith 
as Smith is only part of the content in the 
field. 

5 

4 
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FINDING AND REPLACING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Working With 
Records_6.accdb... 

 
Double-click on the 
Employees table to open it 

 
Right-click on the PhoneNo 
field header and select Find to 
display the Find and Replace 
dialog box 

 
Click on the Replace tab 

 
Type 60 in Find What, then 
click in Replace With and type 
75 

 
Click on the drop arrow for 
Match and click on Start of 
Field so that only phone 
numbers beginning with 60 will 
be updated 

 
Click on [Replace] until all of 
the Executive phone numbers 
are updated 

A message appears informing 
you that Access can’t find the 
text you specified… 

 
Click on [OK] 

 
Click on [Cancel] to close the 
Find and Replace dialog box, 
then close the table 

 

Sometimes you will have a need to make the 
same change to several records. Rather than 
making these changes manually and possibly 
making typing mistakes, you can use the 

computer to search for the text and replace it 
automatically. This can be done in Access using 
the Find and Replace feature. However be careful 
with this – find and replace cannot be undone. 

3 

5 

6 

For Your Reference… 

To find and replace data in a table: 

1. Right-click on a field header, select Find and 
click on the Replace tab 

2. Type the find value in Find What and the 
replace value in Replace With 

3. Click on [Replace] 

Handy to Know… 

 The Find and Replace dialog box has a 
[Replace All] button which will replace all 
matching values. This can sometimes lead to 
unforseen replacements occurring and it is 
not generally advisable to use this feature 
unless there are many replacements to be 
done and you’re positive you’ve got it right. 
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PRINTING RECORDS FROM A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are several ways to extract data from your 
database and to get it onto paper. However, the 
two main ways are to create a report object in the 
database or to simply print the list of records from 

an open table. In this section we'll deal with the 
easier of the processes – printing records directly 
from a table. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Working With 
Records_7.accdb... 

 
Double-click on the 
Employees table to 
open it 

 
Click on the File tab to 
display the Backstage, 
then click on Print to 
display the Print area 

 
Click on Print to display 
the Print dialog box 

 
Ensure that your printer 
is online and ready to 
print, then click on [OK] 

 
Close the table 

 

2 

3 

For Your Reference… 

To print records from a table: 

1. Open the table 

2. Click on the File tab, then click on Print 

3. Click on Print 

4. Click on [OK] 

Handy to Know… 

 The default Print operation will print all 
records. You can, however, set a filter on a 
table so that only records that meet specific 
criteria will appear and will therefore be 
printed. 
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COMPACTING A DATABASE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you make changes to a table, the changes 
and deletions appear immediately on the screen 
for you but unseen data and information is left 
hanging around within the recesses of the table. 

Access has a compacting and repairing utility that 
both repairs and resizes the table data and 
generally cleans things up so that they perform at 
an optimal level. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Working With 
Records_7.accdb... 

 
Click on the File tab to 
display the 
Backstage, then 
ensure Info is selected 

 
Click on [Compact & 
Repair Database] 

It will look as though 
nothing has happened 
as the compaction 
routine operates 
quickly and occurs in 
the background 

 

1 

2 

For Your Reference… 

To compact a database file: 

1. Click on the File tab, then click on Info 

2. Click on [Compact & Repair Database] 

Handy to Know… 

 Using the Access Options dialog box (click 
on the File tab and select Options), you can 
set compaction to occur automatically every 
time you close a database file. In the 
Current Database options, click on 
Compact on Close until it appears with a 
tick. 
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NOTES: 
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CHAPTER 9 FORMATTING TABLES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to change the width of table columns 

 learn how to format cells in a table 

 learn how to change the fonts used in a table 

 learn how to move fields in a table 

 learn how to freeze and unfreeze columns in a table 

 learn how to hide columns in a table 

 learn how to unhide columns in a table that have been 
hidden. 

Formatting refers to the process of changing the appearance of 
something, usually so that it is more visually pleasing or easier to 
read. 

The default formatting for tables in Access is rather bland. 
Fortunately, Access provides a number of tools for formatting tables 
including changing the gridlines between columns and rows, 
shading the background of cells, and changing fonts and font 
colours. 

Since tables can be easily printed, formatting a table provides a 
quick and efficient way of creating and printing simple reports of the 
data. 

INFOCUS 
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CHANGING COLUMN WIDTHS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Often you will find that the width of a column in 
Datasheet view is not appropriate for the data in 
the field. Either the column is too small and you 
can't see the data, or the column is unnecessarily 

wide. Access allows you to change the width of a 
column. You can use commands in the ribbon for 
precise sizing or you can drag the column heading 
using the mouse. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Formatting Tables_1.accdb… 

 
In the Navigation pane, 
double-click on the 
Employees table to open it 

 
Click on any LastName field 

 
On the Home tab, click on 
More in the Records group 
and select Field Width to 
display the Column Width 
dialog box 

 
Type 20, then click on [OK] to 
widen the LastName column 

 
Point to the border between 
the FirstName and 
LastName headers until it 
changes to a double-headed 
arrow, then click and drag 
right until the FirstName field 
is about half as wide again, as 
shown 

 
Point to the border between 
Department and PhoneNo, 
then double-click to perform a 
best fit on the Department 
column 

 
Click on Save in the QAT to 
save the design changes 

 
Close the table 

 

2 

3 

4 

For Your Reference… 

To adjust table column widths: 

 Click in the column, then on the Home tab, 
click on More in the Records group and 
select Field Width, or 

 Drag the field name border to change width 

Handy to Know… 

 To retain the changes to layouts you must 
save them by clicking on Save in the Quick 
Access Toolbar. 

 Changing the width of a column on screen 
doesn't change the field size property – the 
field size determines how much data can be 
placed in a field. 

5 
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FORMATTING CELLS IN A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Formatting 
Tables_2.accdb... 

 
Double-click on the 
Employees table to open it 

 
On the Home tab, click on the 
dialog box launcher in the Text 
Formatting group to open the 
Datasheet Formatting dialog 
box 

 
Click on the options in Cell 
Effect and observe the 
changes in Sample – when 
done, click on Flat 

 
Click on the drop arrow for 
Alternate Background 
Colour and click on Maroon 2 
in Standard Colours (column 
6, row 3) 

 
Ensure that both Horizontal 
and Vertical appear ticked in 
Gridlines Shown 

 
Click on the drop arrow for 
Gridline Colour and click on 
Green in Standard Colours 
(column 7, row 1) 

 
Click on [OK] to apply the 
changes 

 
Save and close the table 

 

Access provides a number of options for 
changing things such as the grid lines displayed 
in the table, the background colours of cells, the 
alternate background colours of cells and much 

more. Formatting cells in the table is achieved 
using the various commands on the ribbon or 
through the options in the Datasheet Formatting 
dialog box. 

1 

2 

For Your Reference… 

To change cell formatting: 

1. On the Home tab, click on the dialog box 
launcher in the Text Formatting group 

2. Change the effects as desired 

3. Click on [OK] 

Handy to Know… 

 Unlike a spreadsheet application, such as 
Microsoft Excel, in Access you can’t change 
individual cells. You can either format the 
entire table or not at all. 

7 
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CHANGING FONTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Access uses a set of standard fonts to display 
your data in a Datasheet, but you can change the 
font and apply virtually any font installed on your 
computer. You can increase or decrease the font 

sizes, apply coloured fonts and much more. It is 
important to make sure you use a font that is easy 
to read for the sake of accuracy. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous file 
with this exercise, or open the 
file Formatting 
Tables_3.accdb... 

 
Double-click on the Employees 
table to open it 

 
On the Home tab, click on the 
drop arrow for Font Colour in 
the Text Formatting group to 
display a palette of colours 

 
Click on Dark Blue in Standard 
Colours (column 4, row 1) to 
change the colour of the font 

 
Click on the drop arrow for Font 
Size and click on 14 to increase 
the font size 

A little overwhelming… 

 
Click on the drop arrow for Font 
Size and click on 8 to decrease 
the font size 

Now it’s a bit small… 

 
Repeat step 5 and increase the 
font size to 11 

 
Click on the drop arrow for Font 
and click on Book Antiqua to 
change the font 

Let’s change this back… 

 
Repeat step 7 and set the font 
back to Calibri (Detail) 

 
Save and close the table 

 

For Your Reference… 

To change the fonts in a table: 

1. On the Home tab, click on the respective 
drop arrows in the ribbon for Font, Font Size 
and Font Colour in the Text Formatting 
group 

2. Click on the appropriate option 

3 

2 

Handy to Know… 

 There are a myriad of font formatting options 
available. However, sometimes keeping the 
default settings is the most pleasing to the 
eye. Don’t go overboard with “busy” fonts 
and colours unless you are really trying to 
make a statement. 

7 
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MOVING COLUMNS IN A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Formatting 
Tables_4.accdb... 

 
Double-click on the 
Employees table to open it 

 
Click on the LastName field 
header to select the entire 
column 

 
Point to the bottom of the 
field name until the pointer 
changes to a four-headed 
arrow, as shown 

The four-headed arrow is the 
move pointer… 

 
Hold down the left mouse 
button and drag left until a 
thick line appears to the left 
of the FirstName column, as 
shown 

 
Release the mouse button to 
reposition the LastName 
column 

 
Save and close the table 

 

The order in which columns are presented in a 
table is determined by the order in which fields 
were defined in the design of the table. While 
these positions may have made sense when the 

table was designed, they may be inappropriate for 
viewing the data in a table. You can alter the 
column positions in a table and move columns 
around by dragging. 

3 

For Your Reference… 

To move a field in a table: 

1. Click on the column header of the field to 
select it 

2. Drag the column to the desired location 

4 

Handy to Know… 

 Dragging field headers in a table does not 
alter the position of fields in the table 
structure when viewed in Design View. 

5 
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FREEZING COLUMNS IN A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you have a table that contains many fields, 
chances are that as you scroll right through the 
table, the information in the fields at the left will 
disappear because the screen is not wide 

enough to display all of the data. This can be 
annoying, particularly if there is reference point 
data in the left fields. You can freeze columns in a 
table, thereby keeping fields locked on the screen. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Formatting 
Tables_5.accdb... 

 
Double-click on the 
Employees table to open 
it 

 
Click on the EmpNo 

header, hold down , 
then click on the 
LastName header to 
select both columns 

 
On the Home tab, click on 
More in the Records 
group, then select Freeze 
Fields 

The selected fields will 
now be locked on the 
screen… 

 
If necessary use the 
horizontal scroll bar to 
scroll right until 
WeeklyHours appears 
next to LastName 

Let’s unfreeze the fields 
again… 

 
On the Home tab, click on 
More in the Records 
group and select Unfreeze 
All Fields 

 
Save and close the table 

2 

For Your Reference… 

To freeze or unfreeze columns in a table: 

1. Select the column(s) to freeze or unfreeze 

2. On the Home tab, click on More in the 
Records group 

3. Select Freeze Fields or Unfreeze All Fields 

Handy to Know… 

 You can only freeze multiple columns that 
are next to one another. If you wish to freeze 
a column further to the right you will need to 
reposition it to be alongside the other 
column(s) first. 

4 
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HIDING COLUMNS IN A TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In Access it is possible to hide columns in a table 
from view. When a column is hidden, it is still part 
of the table but doesn’t appear on the screen. 
This can be useful to prevent sensitive 

information, such as salary details, from appearing 
on the screen and also for making a large table 
appear smaller, containing more relevant data. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Formatting 
Tables_6.accdb... 

 
Double-click on the 
Employees table to 
open it 

 
Click anywhere in the 
Department column to 
select it 

 
On the Home tab, click 
on More in the 
Records group and 
select Hide Fields to 
hide the Department 
field 

 
Repeat the above steps 
for the following 
columns: FirstName, 
Started, Fulltime, 
Salary, and Comments 

You should now have 
quite a compact table… 

 
Save and close the 
table 

 

2 

3 The Department field (column) is now hidden and the other columns move 
left one position, so that the PhoneNo column is now next to FirstName. 

For Your Reference… 

To hide columns in a table: 

1. Select the column(s) to hide 

2. On the Home tab, click on More in the 
Records group 

3. Select Hide Fields 

4 

Handy to Know… 

 Hidden columns do not print when you print 
the table. However, any data in themis still 
utilised in any expressions (formulas) and the 
like that you have created. 
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UNHIDING COLUMNS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Formatting 
Tables_7.accdb... 

 
Double-click on the 
Employees table to open 
it 

 
On the Home tab, click on 
More in the Records 
group and select Unhide 
Fields to display the 
Unhide Columns dialog 
box 

This dialog box lists all of 
the fields in the table. 
Fields that appear with a 
tick are currently on 
display, while fields that 
appear without a tick are 
currently hidden... 

 
Click on each empty tick 
box until it appears with a 
tick – notice how the 
columns reappear in the 
background as you click 

 
Click on [Close] to close 
the Unhide Columns 
dialog box 

All of the columns should 
be visible when you scroll 
to the right… 

 
Save and close the table 

 

A hidden column is not deleted, but it will not be 
displayed on the screen unless you choose to 
unhide it. The display of columns is recorded in 
the Unhide Columns dialog box. This dialog box 

lists all of the columns in the table. Each column 
has a tick box which indicates whether the column 
is hidden (unticked) or visible (ticked). This box 
therefore can be used to unhide hidden columns. 

1 

For Your Reference… 

To unhide columns in a table: 

1. Open the table 

2. On the Home tab, click on More in the 
Records group and select Unhide Fields 

3. Tick columns to unhide, then click on [Close] 

2 

Handy to Know… 

 You can use the Unhide Columns dialog 
box to unhide and hide columns from the 
display. Just click in the tick box for the 
relevant field to remove the tick (hide) or 
display the tick (unhide). 

3 
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CHAPTER 10 SORTING AND FILTERING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to perform simple sorting operations in a table 

 learn how to sort on more than one field in a table 

 learn how to apply a simple filter to a table 

 learn how to work with filters 

 learn how to apply a filter between two dates. 

In Access, data in a table is sorted in its default mode by the 
primary key. However, you can sort the data virtually in any order 
that you wish. 

In addition, you can apply a filter so that only specific records 
appear in the table. When you first open a table you will see all 
records in the table. A filter can be set so that only records that 
match the specific conditions of the filter are displayed. 

Sorting and filtering are two useful tools for working with the records 
within a table. 

INFOCUS 
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SIMPLE SORTING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sorting in databases involves arranging records 
in alphabetical or numerical order. For example, 
you may wish to see all of your employees in last 
name order, or in order of the department in 

which they are employed. Simple sorting in Access 
is performed using the two sorting commands 

found on the ribbon: Ascending and Descending. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file Sort 
And Filter_1.accdb… 

 
Double-click on the 
Employees table to open it 

The records are currently in 
primary key (EmpNo) order… 

 
Click in any LastName field 
then, on the Home tab, click 
on Ascending in the Sort & 
Filter group to sort the records 
by LastName 

 
Click on Descending to 
reverse the sort order 

 
Click in any Department field, 
then click on Ascending 

 
Click on Close to close the 
table 

Since sorting is deemed to be 
a layout feature you will be 
asked if you wish to save 
changes to the layout… 

 
Click on [No] to discard the 
changes and retain the original 
order 

 

1 

2 

For Your Reference… 

To sort data in a table: 

1. Click in the field to sort 

2. On the Home tab, click on Ascending or 
Descending in the Sort & Filter group 

Handy to Know… 

 By default, tables are sorted according to the 
primary key. If you choose to save the 
layout of a table after it has been sorted, the 
records will appear in this order when you 
next open the table. 

4 
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SORTING ON SEVERAL FIELDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Simple sorting is easy. However, how do you sort 
by department so that you can see the 
employees in alphabetical order? To do this you 
must select several fields at the same time and 

then use the relevant sort tool. You can select more 
than one field, and thereby sort on several fields, 

by using the  key when making your selection. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Sort And 
Filter_1.accdb... 

 
Double-click on the 
Employees table to open it 

 
Click on the LastName field 

header, then hold down  
and click on the Department 
field header to select both 
fields 

 
On the Home tab, click on 
Ascending in the Sort & 
Filter group 

The records will now be sorted 
first by LastName and then by 
Department… 

 
Click on the Started field 

header, then hold down  
and click on the DateOfBirth 
field header 

 
Click on Ascending to sort the 
records first by DateStarted 
and then by DateOfBirth 

 
Close the table, then click on 
[No] to discard the changes 

 

2 

3 

For Your Reference… 

To sort on several fields: 

1. Click on the first field, hold down  and 
click on the last field 

2. On the Home tab, click on either Ascending 

or Descending in the Sort & Filter group 

Handy to Know… 

 Fields must be next to one another to sort on 
multiple fields. You can drag fields around a 
table by clicking on the field heading to select 
it, then click and drag the field to another 
location. 

5 



Microsoft Access 2016 - An Introduction 

© 2017 The University of Nottingham Page 100 Chapter 10 - Sorting and Filtering 

SIMPLE FILTERING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Access allows you to hide records in a table. This 
is achieved by setting a filter. When you set a 
filter you must provide Access with criteria that it 
can use to work out which records to display. The 

simplest form of criteria allows you to choose an 
existing value from a field in the table. This value is 
then compared to the values in the other records, 
and records that don’t match it are hidden. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Sort And 
Filter_1.accdb... 

 
Double-click on the 
Employees table to open it 

 
Click on any Administration 
record in the Department field 

 
On the Home tab, click on 
Selection in the Sort & Filter 
group and select Equals 
“Administration” 

Only records with the word 
Administration in the 
Department field are displayed 
– there are 26… 

 
Click on 09-Dec-07 for EmpNo 
181 

 
Click on Selection in the Sort 
& Filter group and select On 
or After 09-Dec-07 

Only those records where 
Department is “Administration”, 
for people who started after 
09-Dec-07, are displayed… 

 
Close the table, then click on 
[No] to discard the changes 

 

2 

3 

4 

For Your Reference… 

To create a simple filter: 

1. Click on a field entry to use as criteria 

2. On the Home tab, click on Selection in the 
Sort & Filter group and select Equals 

<example> 

Handy to Know… 

 When a filter is applied to a table, the word 
Filtered appears in the Status bar, 
alongside the record count.  

5 
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WORKING WITH FILTERS 
 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Sort And 
Filter_1.accdb... 

 
Double-click on the 
Employees table, then click 
on any Department field 

 
On the Home tab, click on 
Filter in the Sort & Filter 
group to see each field value 
in a menu list 

 
Click on the tick for Select 
All to remove all of the ticks, 
then click on the tick box for 
Administration 

 
Click on [OK] to see only the 
Administration records 

 
On the Home tab, click on 
Toggle Filter in the Sort & 
Filter group several times to 
switch the filter off and on 

 
Click on any Department 
field, then click on Filter to 
see the Filter menu 

 
Select Clear filter from 
Department to remove the 
filter 

 
Close the table, then click on 
[No] to discard the changes 

 

Filters provide a powerful way of working with 
records in a table. There are a number of useful 
tools and commands for working with filters that 
you should become acquainted with. For 

example, Access allows you to toggle a filter off 
and on so that you can switch between the 
unfiltered and filtered records. You can also clear a 
filter to display all of the data. 

2 

3 

For Your Reference… 

To clear a filter: 

1. Click in the field with the filter 

2. On the Home tab, click on Filter in the Sort 
& Filter group 

3. Select Clear Filter from <fieldname> and 

click on [OK] to remove the filter 

Handy to Know… 

 When a filter is applied to data, a funnel icon 
appears at the top of the table next to the 
names of the field(s) that have a filter 
applied. When the filter is switched off, the 
words No Filter appears in the status bar, 
but the words are greyed out. 

5 
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FILTERING BETWEEN DATES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file A1608 Sort And 
Filter_1.accdb... 

 
Double-click on the 
Employees table to open it, 
then click in any DateOfBirth 
field 

 
On the Home tab, click on 
Filter in the Sort & Filter 
group to display the filter 
menu 

 
Point to Date Filters then 
select Between to display 
the Between Dates dialog 
box 

 
Type 01-Jan-60 in Oldest, 

press  twice and type 
31-Dec-65 in Newest 

 
Click on [OK] to see all of the 
employees born between 
1960 and 1965 

 
Close the table – click on 
[No] to discard the changes 

 

Applying filters to dates can be a bit tricky. 
Generally you don’t want to filter on a specific 
date, but rather a range of dates. For example, in 
our case study you may want to see all of the 

people who started in December 2007. This would 
require you to filter between the dates of Dec 1 and 
Dec 31. This can be done using the Between 
Dates filter option. 

2 

4 

For Your Reference… 

To filter between dates: 

1. Click in the date field then, on the Home tab, 
click on Filter in the Sort & Filter group 

2. Select Date Filters > Between 

3. Type the start date in Oldest and the end 

date in Newest, then click on [OK] 

Handy to Know… 

 The dates specified in the Between Dates 
dialog box are inclusive. For instance, if 
Oldest is set to 01-01-60 and Newest is set 
to 31-12-65, then anyone born on January 1, 
1960 or December 31, 1965 would also be 
included in the results. 
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CHAPTER 11 IMPORTING & EXPORTING RECORDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 learn how to export records to Microsoft Excel 

 learn how to export records to a delimited text file 

 learn how to import data from Microsoft Excel 

 learn how to import data from a text file 

 learn how to link to an external data source. 

Not everyone uses Microsoft Access and, as a consequence, you 
may find the need in Access to work with data from other 
applications and sources. 

Microsoft Access 2016 allows you to export records to and import 
records from a number of different applications including other 
databases, spreadsheets, and text files. 

In this session you’ll explore exporting data from an existing table to 
a variety of sources and importing data from a number of different 
applications. 

INFOCUS 
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EXPORTING RECORDS TO MICROSOFT EXCEL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Microsoft Excel comes from the same suite of 
products as Microsoft Access, so exporting 
records is easy and relatively effortless. The 
built-in Export Wizard automatically converts 

fields from an Access database into columns and 
converts Access records into rows. This enables 
easy export of the data to an Excel workbook. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file Exporting 
Records_1.accdb… 

 
In the Navigation pane, 
double-click on the table 
Employees – 
Administration to open it 

 
Click on the External 
Data tab, then click on 
Excel in the Export group 
to display the Export 
Wizard 

Here you can specify a 
destination File name and 
location… 

 
Click on [Browse], then 
locate and double-click on 
the course files folder 

We will apply the file 
name that appears by 
default… 

 
Click on [Save], then click 
on [OK] to perform the 
export and display the 
Save Export Steps 
option in the wizard 

 
Ensure that Save export 
steps appears without a 
tick, then click on [Close] 
to return to the table 

 
Close the table 

2 

For Your Reference… 

To export records to Microsoft Excel: 

1. Open the table to export 

2. On the External Data tab, click on Excel in 
the Export group 

3. Complete the steps in the wizard 

Handy to Know… 

 The Save Export Steps options of the 
Export Wizard allows you to save any 
export settings you may have used. This is 
handy if you need to perform the same 
operation on a routine basis. If you only do 
the export as a one-off operation, there is 
probably no need to retain the steps. 

4 
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EXPORTING RECORDS TO A TEXT FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Exporting 
Records_1.accdb... 

 
Open the Employees – Sales 
table 

 
Click on the External Data 
tab, then click on Text File in 
the Export group to display 
the Export Wizard 

Exporting to text requires a few 
extra steps... 

 
Click on [Browse], locate and 
select the course files folder, 
then click on [Save] to set the 
destination and click on [OK] 

 
Ensure that Delimited is 
selected, then click on [Next] 
to specify the delimiter 
character 

 
Ensure that Comma is 
selected as the delimiter, then 
click on [Next] 

We’ll use the suggested 
filename… 

 
Click on [Finish] to display the 
Save Export Steps option in 
the wizard 

 
Ensure that Save export 
steps appears without a tick, 
then click on [Close] 

 
Close the table 

For Your Reference… 

To export records to a text file format: 

1. Open the table to export 

2. On the External Data tab, click on Text File 
in the Export group 

3. Complete the steps in the wizard 

Text files are the mainstay of data exporting and 
importing. Virtually every application that has 
data will have a way of importing and exporting 
text file formats. So, if you intend to export 

Access records to an application that doesn’t 
appear in the export options, you can simply export 
it as text and then import it into the destination 
application. 

3 

Handy to Know… 

 There are two types of text files. One type 
has the data delimited (enclosed) with 
quotation marks and separated by commas. 
The other type is where the data is fixed 
length. The delimited type, while it sounds 
more complex, is the one most supported by 
other applications. 
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IMPORTING FROM MICROSOFT EXCEL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Importing Records_2.accdb… 

 
Click on the External Data tab, 
then click on Excel in the 
Import & Link group to start 
the Get External Data wizard 

 
Click on [Browse] to display 
the File Open dialog box, then 
locate and open the course files 
folder 

 
Click on Employees – 
Import.xlsx, then click on 
[Open] 

 
Click on Append a copy of the 
records to the table and 
ensure that Employees is the 
selected table 

 
Click on [OK] to display the 
Import Spreadsheet Wizard 
screen 

 
Click on [Next] to display the 
column headings 

 
Click on [Next] to display the 
final screen 

 
Click on [Finish] to display the 
Save Import Steps screen, 
ensure that Save import steps 
appears without a tick, then 
click on [Close] 

 
Open the Employees table to 
view the imported data, then 
close the table 

 

Importing data from Microsoft Excel is a 
straightforward process, but there are several 
more steps than you might expect. This is 
because Access has to take into account so 

many of the different nuances in Excel data. The 
Import Wizard guides you through the steps, 
prompting for responses about the Excel data 
being imported. 

4 

For Your Reference… 

To import data from Microsoft Excel: 

1. On the External Data tab, click on Excel in 
the Import & Link group 

2. Choose the file to import, then click on [OK] 

3. Complete the steps of the Get External Data 
wizard 

Handy to Know… 

 When importing data from Excel, Access has 
to manipulate the data from a 3-dimensional 
spreadsheet format into a 2-dimensional 
database format – that is why there are quite 
a few steps in the import wizard. 
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IMPORTING FROM A TEXT FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Since text file formats are common in the 
computer world it is only logical to expect that 
Access would have routines that allow you to 
import from text files. When importing data from a 

text file, Access needs to have specific information 
about the format of the data and it will prompt you 
for this information through a series of steps in the 

Get External Data Wizard. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the 
file Importing Records_3.accdb... 

 
Click on the External Data tab, 
then click on Text File in the 
Import & Link group to start the 
Get External Data wizard 

 
Click on [Browse] to display the 
File Open dialog box, ensure the 
course files folder is open, then 
click on Employees – Import.txt 
and click on [Open] 

 
Click on Append a copy of the 
records to the table and ensure 
the Employees table is selected 

 
Click on [OK] to display the 
Import Text Wizard screen 

 
Ensure that Delimited is 
selected, then click on [Next] to 
display the delimiters options 

 
Ensure that Comma is selected, 
then click on [Next] to see the 
final screen 

 
Click on [Finish] to display the 
Save import steps screen, 
ensure that Save import steps 
appears without a tick, then click 
on [Close] 

 
Open the table Employees to 
see the additional imported 
records, then close the table 

 

4 

For Your Reference… 

To import data from a text file: 

1. On the External Data tab, click on Text File 
in the Import & Link group 

2. Choose the file to import and click on [OK] 

3. Complete the steps of the Get External Data 

Wizard 

Handy to Know… 

 When importing data, you should always 
open the table into which the data was 
imported to ensure that it has been imported 
correctly. 
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LINKING TO AN EXTERNAL SOURCE 
 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Importing 
Records_4.accdb... 

 
Click on the External Data 
tab, then click on Excel in the 
Import & Link group, to start 
the Get External Data wizard 

 
Click on [Browse] to display 
the File Open dialog box, 
ensure the course files folder 
is open, then click on 
Employees – Import.xlsx and 
click on [Open] 

 
Click on Link to the data 
source by creating a linked 
table, then click on [OK] to 
display the Link Spreadsheet 
Wizard screen 

 
Click on [Next] to display the 
column headings screen 

 
Ensure that First Row 
Contains Column Headings 
is selected, then click on 
[Next] to display the final 
screen 

 
Click on [Finish] 

A message will display when 
linking is complete… 

 
Click on [OK] to see the linked 
table in the Navigation pane 

 

For Your Reference… 

To create a link to an external source: 

 Perform the import in the normal way except 
choose the Link to the data source by 
creating a linked table option on the first 
screen 

In Access you can elect to link to an external 
data source. When you do this, the external 
source appears like a table in the Navigation 
pane. The linked table can be opened and 

viewed like any other table, but the data cannot be 
changed. The advantage of this approach is that 
the linked table always contains the most recent 
changes to the external data source. 

3 

Handy to Know… 

 There are pros and cons associated with 
linking to an external data source. Although 
you always get the latest data, you are 
restricted in what can be done with it. If you 
need to import data on a regular basis, use 
this option, otherwise stick with the straight 
import routines. 
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CHAPTER 12 CREATING AND USING FORMS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of how forms work in Access 

 learn how to create a basic form 

 learn how to create a split form 

 learn how to create a form based on a query 

 learn how to create a form using the Form Wizard 

 learn how to work with existing forms 

 learn how to edit records in a form 

 learn how to delete records through a form 

 learn how to delete a form from a database file. 

Forms are used to provide a friendly interface so that data in tables, 
queries and reports can be accessed more easily. 

They can be used to provide a navigation system, to automate 
processes and to generally make life easier for those users whose 
knowledge of Access is limited. 
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UNDERSTANDING FORMS 
 

 

 

 

 

 

Forms are like special templates that you can 
use to make data, which would normally appear 
in rows and columns in a table, more presentable 
on screen. Forms can be used for viewing data 

on the screen, for editing data, and for adding new 
data. Forms can be created quickly from scratch, 
based on an existing table, or by using a special 

Wizard that steps you through the process. 

Creating Forms 

Working with records in tables is not difficult to do. However, opening a table and allowing people to 
work directly in it can be fraught with problems. They may inadvertently delete records, or corrupt data 
in fields, and even see some fields of data (such as salary information) that you would prefer they 
rather did not. 

So, instead of providing users with direct access to the data in a table, you can control what they see 
and what they work with, by giving them access to the data through forms. 

Forms themselves do not contain data, but are created as structural templates into which the data is 
placed when the form is viewed. The template basically defines what to display (e.g. which fields to 
use), where to display it (e.g. where the fields should appear on the page), and how it should look (e.g. 
font size, colour, etc). 

When a form is first created it is based on either an existing table or an existing query. You base the 
form on a table if you wish to report on all of the data, or a query if you wish to view a subset of the 
data. 

The Many Ways of Creating a Form 

In Access you can create simple forms or very complex and intricate forms. So, as you’d expect, 
Access offers several ways for you to create forms. In Access, forms are created using the tools on the 
Create tab of the ribbon. Here you can create: 

 A basic form using the Form tool, the Split Form tool or the Multiple Items tool – these tools 
create a form that appears almost instantly and requires very little work on your part, as all of 
the work is done for you. 

 More intricate forms using the Form Wizard tool – the Form Wizard metaphorically holds your 
hand and asks you a series of questions which ultimately, when answered, result in the form 
being created for you, as specified. 

 A complex, elaborate form using either the Blank Form tool or the Form Design tool – these 
options present you with a blank form canvas and you are required to do all of the work to lay 
out what you want, where you want it, and how it should look. This is the most difficult of the 
options to use as you have to do everything yourself. 

Achieving a Balance 

There is no right or wrong way to create forms – choose the method that achieves the results using the 
least amount of time and effort. 

The beauty of the form creation tools in Access is that even after you create a form using any of the 
techniques above, that form can still be modified and customised to suit specifically what you are after. 
So even if the basic form doesn’t quite provide you with what you want or the Form Wizard hasn’t 
quite done all it should, you can still change the form design yourself. 

Many Access users create their forms initially using the Form tool, the Split Form tool or the Form 
Wizard tool, and then fine tune the layout or the design to suit their needs. 



Microsoft Access 2016 - An Introduction 

© 2017 The University of Nottingham Page 111 Chapter 12 - Creating and Using Forms 

CREATING A BASIC FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

One of the easiest and simplest ways to create a 
form in Access is to use the Form tool which is 
found on the Create tab of the ribbon. All you 
need to do is select the table or query upon 

which to base the form and then click on the tool. 
This is a good way to get an instant form on the 
screen for data entry or editing. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Creating Forms_1.accdb… 

 
In the Navigation pane, click 
on the Employees table to 
specify the table to use 

 
Click on the Create tab, then 
click on Form in the Forms 
group 

A form layout will instantly 
appear. The layout view of 
the form allows you to make 
adjustments to the form 
template… 

 
Click on the top half of View 
in the Views group to see the 
form in Form View where the 
data is presented 

 
Click on the various Record 
buttons in the Navigation bar 
at the bottom of the screen to 
move through the records 

 
Click on Save in the QAT to 
display the Save As dialog 
box 

 
Type frmEmployees in Form 
Name and click on [OK] to 
save the form 

 
Close the form 

 

2 

4 

For Your Reference… 

To create a basic form: 

1. Select the table or query in the Navigation 
pane 

2. Click on the Create tab, and click on Form in 
the Forms group 

Handy to Know… 

 When creating a basic form for a table, linked 
tables will also appear as subdatasheets on 
the form. Access assumes you want to see 
the records from lookup tables in a form. 

6 
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CREATING A SPLIT FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Another quick and basic form that you can create 
in Access is a split form. A split form shows a 
standard form at the top of the screen, where 
only one record appears at a time, and a 

datasheet view at the bottom of the screen. The 
datasheet shows the records in a table format. 
Each time you click on a record in the datasheet, 
the fields for that record appear in the top form. 

Try This Yourself: 

S
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e
 

Continue using the previous 
file with this exercise, or 
open the file Creating 
Forms_2.accdb... 

 
In the Navigation pane, 
click on the Employees 
table 

 
Click on the Create tab, 
then click on More Forms in 
the Forms group and select 
Split Form 

A split form layout will 
instantly appear… 

 
On the Form Layout Tools: 
Design tab, click on View in 
the Views group to see the 
form in Form View 

 
Click on the record buttons 
in the Navigation bar 

 
Click on the record for 
EmpNo 108 (Amanda 
Bennet) to display the 
details in the top form 

 
Click on Save in the QAT to 
display the Save As dialog 
box 

 
Type 
frmEmployeesSplitForm in 
Form Name and click on 
[OK] 

 
Close the form  

 

2 

5 

For Your Reference… 

To create a split form: 

1. In the Navigation pane, select the table or 
query 

2. Click on the Create tab, then click on More 
Forms in the Forms group and select Split 

Form 

Handy to Know… 

 Linked tables do not appear in a split form. 
This is because there is already a datasheet 
in the bottom part of the window. 
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BINDING A FORM TO A QUERY 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The attachment of a table or query to a form is 
known as data binding. One of the strengths of 
Access is that both forms and reports can be 
based on either a full table of data or a subset of 

the table known as a query. When a form is bound 
to a query, the query is run first to extract matching 
fields and records, and then presented in the form 
much the same as a full table would be. 

Try This Yourself: 

S
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m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Creating 
Forms_3.accdb... 

 
In the Navigation pane, click 
on qryEmployees to specify 
the query to use 

 
Click on the Create tab, then 
click on Form in the Forms 
group 

Only the fields specified in 
the query will appear in the 
form layout… 

 
On the Form Layout Tools: 
Design tab, click on View in 
the Views group to see the 
form in Form View where the 
data is presented 

 
Click on Save in the QAT to 
display the Save As dialog 
box 

 
Type frmEmployeeSalary in 
Form Name and click on 
[OK] to save the form 

 
Close the form 

The new form will appear in 
the Navigation pane 

 

For Your Reference… 

To create a form from a query: 

1. In the Navigation pane, click on the query 

2. Click on the Create tab, then click on Form 
in the Forms group 

Handy to Know… 

 You can create a form from a query using 
Split Form and Multiple Item. 

 Unlike a form based on a table, a form based 
on a query does not show the transactional 
records in the form. 

3 

4 

5 



Microsoft Access 2016 - An Introduction 

© 2017 The University of Nottingham Page 114 Chapter 12 - Creating and Using Forms 

USING THE FORM WIZARD 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To have more say in what to include in your form 
and how it should look, you can create a form 
using the Form Wizard. The Form Wizard will 
walk you through the steps to create a new form. 

The Form Wizard is made up of several screens, 
each of which requires you to specify what fields to 
include, how it should look, and what the new form 
should be called. 

Try This Yourself: 

S
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Continue using the 
previous file with this 
exercise, or open the file 
Creating Forms_4.accdb... 

 
In the Navigation pane, 
click on the Employees 
table 

 
Click on the Create tab, 
then click on Form Wizard 
in the Forms group to start 
the wizard 

 
Double-click on EmpNo, 
FirstName, LastName, 
Department and PhoneNo 
to add them to the 
Selected Fields list 

 
Click on [Next] to proceed 
to the next screen, then 
continue working through 
the screens using the 
settings as shown 

 
Once you have specified 
the title in the last screen of 
the wizard, click on [Finish] 
to build the form 

 
Close the form 

 

2 

Screen Settings Click on… 

Layout Columnar [Next] 

Title Employee Phone No  

 

4 4 

For Your Reference… 

To create a form using the Form Wizard: 

1. Click on the table or query 

2. Click on the Create tab, then click on Form 
Wizard in the Forms group 

3. Complete the steps of the Wizard 

Handy to Know… 

 When using the Form Wizard, if you have 
made a mistake in any of the Wizard 
screens or would simply like to review your 
work, click on [Back] to move back through 
previous screens. 

5 
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WORKING WITH EXISTING FORMS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once forms have been created they are ready for 
use. Forms are generally used either to provide 
access to the records and data for editing or just 
simply to search and view data. When you open 

a form from the Navigation pane, it is opened in 
Form View where it is ready for action. There are 
also several other views that you need to be aware 
of when working with forms. 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
Creating Forms_5.accdb... 

 
In the Navigation pane, 
double-click on 
frmEmployees to open the 
form in Form View 

This is the view where you 
can edit the data… 

 
On the Home tab, click on 
View in the Views group to 
see the form in Layout 
View 

In this view you can make 
changes to the layout of the 
form, including changing 
column widths, colours, 
etc… 

 
Click on View to return to 
Form View 

 
Click on the bottom half of 
View and select Design 
View to see the form 
design 

This is a more sophisticated 
design area of the form… 

 
Click on the Home tab, 
then click on View to switch 
back to Form View 

 
Close the form 

 

1 

4 

For Your Reference… 

To change the views of a form: 

1. Open the form in any view 

2. Click on the bottom half of View and click on 
the desired view 

Handy to Know… 

 Changes to a form’s structure are done in 
either Layout or Design views. Layout view 
provides a view of the form with data in 
place. Design view provides access to more 
of the detailed areas of the form such as the 
header and footer. 
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EDITING RECORDS IN A FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Forms are really intended to make working with 
the data in a table easier by providing better and 
hopefully more intuitive access to the data in the 
records. Forms therefore provide an alternative to 

working in a table and virtually any editing changes 
you can make to the data in the table can also be 
made to the data when it appears in a form. 

Try This Yourself: 

S
a

m
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Continue using the previous 
file with this exercise, or 
open the file Creating 
Forms_5.accdb... 

 
In the Navigation pane, 
double-click on 
frmEmployees to open the 
form in Form View 

 
Click and drag over the 
current record number in the 
Navigation bar at the bottom 
of the screen to select it 

 
Type 6 and press  to 
move to EmpNo 106 
(Maureen Grayson) 

 
Click and drag over  
Occupational Safety in the 
Department field and type 
Executive 

 
Click in Comments and type 
Promoted to Executive 
status in March. 

 
Click on Next record to save 
the changes, then click on 
Previous record to return to 
Maureen’s record to see the 
change 

 
Close the form 

 

2 

3 

For Your Reference… 

To edit a record through a form: 

1. Open the form, then locate the record to edit 

2. Make the changes as required and move to 
another record to save the changes 

Handy to Know… 

 You can move back through the fields on a 

form by pressing  + . 

 When you edit a record in a form, the edit 
icon will appear in the top left corner of the 
record in the form window. 

5 
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DELETING RECORDS THROUGH A FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Forms can be used to delete records from a 
table. The first step is to locate the record that 
you want to delete. The deletion process is 
permanent – once a record has been removed it 

cannot be restored. If you are at all unsure about 
removing records, you should make a backup copy 
of the database before you start deleting. 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Forms_6.accdb... 

 
Double-click on 
frmEmployeesSplitForm 
to open the form in Form 
View 

 
In the datasheet, at the 
bottom of the form, locate 
and click to the left of the 
record for George 
Samuelson (EmpNo 109) 

Clicking to the left selects 
the record and activates 
the Delete tool in the 
ribbon… 

 
On the Home tab, click on 
Delete in the Records 
group 

You will be asked to 
confirm the deletion… 

 
Click on [Yes] to delete 
the record 

The record is gone… 

 
Close the form 

 

2 

3 

For Your Reference… 

To delete a record using a form: 

1. Open the form in Form View 

2. Locate and select the record 

3. On the Home tab, click on Delete in the 
Records group 

4. Click on [Yes] 

Handy to Know… 

 When deleting records through a form, the 
records are deleted from the table, not the 
form. No matter which form is opened, the 
record will no longer be there because it no 
longer exists in the table. 

4 
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DELETING AN UNWANTED FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Forms, like reports, are database objects that 
exist as templates for displaying and working with 
records in a table or query. They can be created 
with relative ease and therefore you will find that 

you create quick, minimal usage forms for 
convenience. Fortunately, you can delete unwanted 
forms even faster than creating them. 

Try This Yourself: 

S
a

m
e

 F
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Forms_7.accdb... 

 
In the Navigation pane, 
click on the Employee 
Phone No form to select 
it 

 
On the Home tab, click on 
Delete in the Records 
group 

A warning about 
permanently deleting a 
form will appear, and you 
will be asked to confirm 
your intentions… 

 
Click on [Yes] to 
permanently delete the 
form 

 

1 

3 

For Your Reference… 

To delete a form: 

1. In the Navigation pane, click on the form to 
select it 

2. Click on the Home tab, then click on Delete 
in the Records group 

3. Click on [Yes] 

Handy to Know… 

 It is always a good idea to make a backup 
copy of the database file (e.g. using File 
Explorer) before deleting objects such as 
reports, queries and forms from the file. 
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CHAPTER 13 MODIFYING FORMS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of how the modification of forms 
works 

 learn how to switch between Layout and Design Views 

 learn how to select objects on a form 

 learn how to work with a control stack 

 learn how to change the width of a control 

 learn how to move controls on a form 

 learn how to align controls on a form 

 gain an understanding of object properties 

 learn how to change the caption shown in labels on a 
form 

 learn how to add an unbound control to a form 

 learn how to enter an expression into a control source 
property 

 learn how to format a control on a form 

 learn how to check the tab order in a form 

 learn how to change the tab order on a form 

 learn how to insert the date and time into a form header. 

Forms are predominantly used in Access to display data from 
tables or queries on the screen. Forms are usually created using 
the Access form creation tools and then modified to suit specific 
requirements. 

This modification can involve many aspects, from changing the 
colour scheme to completely revamping the layout and operation of 
the form. In this session you’ll change quite a few aspects of a 
standard form that was previously created using the form generator. 

Special Note: There is a lot of similarity between the way forms 
and reports are created and modified. Both use a template 
approach where the design and layout is specified using special 
placeholders, known as controls, to specify where data should 
appear. Much of the skills and knowledge you acquire in this 
session will apply to both forms and reports.  

INFOCUS 
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UNDERSTANDING FORM DESIGN AND LAYOUT 
 

 

 

 

 

  

Although you can create your own forms 
completely from scratch, it would be a very 
laborious process. Even seasoned Access 
programmers rely on the form creation tools to 

create a starting form and then adapt and modify 
that to suit their specific requirements. While 
modifying a form is not difficult, there are several 
conceptual aspects you should understand first. 

Forms are Templates 

While the word template has 
many different and 
sometimes specific 
connotations in computing, it 
does provide a good way to 
describe what a form really is. 
A form is simply a template 
with objects on it that 
determine what should 
appear on the screen, where 
it should appear, and how it 
should look. 

Everything on a form is an 
object, including the heading, 
logos, data placeholders, 
even the background. 

Objects on the Form 

Every object on the form, including the form itself (which is an object), has properties that determine 
how the object should look (format), what it should contain (data), and how it should behave (event). 

A special type of object known as a control is used to display data from a table, query or expression 
(formula) in a form. Controls can be bound to a data source (such as a field from a table), or can be 
unbound and appear with static information (such as a heading) or dynamic, changeable information 
(such as the current date). 

So, when you modify a form, you do so by playing around with the objects on the form – resizing 
them, adding more of them, deleting unwanted ones, changing their colours or fonts, etc. 

The Three Form Views 

There are three ways to view a form. When you double-click on a form in the Navigation pane you 
will run the form. When the form is running, data from the data source (e.g. table or query) is merged 
into the controls on the form template and displayed on the screen. This is the view that the users of 
your database will employ to see their data. 

There are also two views that allow you to modify the form – Layout View and Design View. With 
both of these views you can move objects around and change properties so that objects look and 
behave the way you want. 

Layout View is more like a layout preview. In Layout View your controls appear with data in them 
just as they would if the form was running. You can modify the controls, move them around, resize 
them, recolour them, and see exactly how they will appear when the form is run because they already 
contain data – from the first record. 

In Design View you can do most of the changes to layout and appearance that you can in Layout 
View, plus you can add controls and finely adjust all of the control settings. In Design View you see 
the names of the controls, not the actual data, and you also see the structure of the form such as its 
header area, body area, and footer area. 
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SWITCHING BETWEEN FORM VIEWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Access provides two views in which modifications 
to a form can be made: Layout view and Design 
view. Both of these are available from a shortcut 
menu when you right-click on a form in the 

Navigation pane, or they can be switched while 
the form is open using the View tool on the ribbon. 
While both views allow you to make changes to a 
form, there are subtle differences. 

Try This Yourself: 

O
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Before starting this 
exercise you MUST open 
the file Modifying 
Forms_1.accdb… 

 
In the Navigation pane, 
right-click on 
frmEmployees and 
select Layout View to 
open the form in Layout 
View 

 
Spend a few moments 
studying the options on 
the three Form Layout 
Tools tabs 

 
On the Form Layout 
Tools: Design tab, click 
on the bottom half of View 
in the Views group and 
select Design View to 
see the form in Design 
View 

 
Spend a few moments 
studying the options now 
available on the three 
Form Design Tools tabs 

Many of the options will 
only be available when an 
object or a control on the 
form is selected … 

 
Close the form 

 

1 

2 

For Your Reference… 

To switch between form views: 

1. Click on the bottom half of View in the Views 
group 

2. Select either Design View or Layout View 

Handy to Know… 

 It is recommended that you use Layout View 
to make changes to the formatting and layout 
of controls on a form, and Design View 
when making changes to the structure of a 
form such as inserting more controls or 
adding a form footer. 

3 
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SELECTING FORM OBJECTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
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e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Forms_1.accdb... 

 
Open frmEmployees in 
Layout View 

 
Click on EmpNo to select 
the label control 

An orange border 
indicates that the object is 
selected… 

 
Click on 101 to select the 
text box control 

 
Click on EmpNo, then 

hold down  and click 
on FirstName and 
Executive to select the 
three controls 

 
Click on the four-headed 
arrow icon at the top left of 
EmpNo to select all of the 
controls in this control 
stack 

A control stack is an object 
that is made up of a group 
of objects... 

 
Click in the white area of 
the form to select the form 
background 

 
Click on Employees in the 
heading to select it 

 
Close the form 

Everything you see on a form, including the form 
itself, is an object. In both Design View and 
Layout View you need to select the object that 
you intend to work with before you can do 

anything with it. Selecting an object is usually as 
simple as clicking on it with the mouse. Once 
selected, an object will appear with a coloured 
border to indicate it is the current object. 

2 

4 

5 

For Your Reference… 

To select an object on a form: 

1. Click on the desired object until it appears 
with a selection border 

2. Hold down  and click on subsequent 
objects to select multiple (non-contiguous) 
objects 

Handy to Know… 

 Each object on a form has its own set of 
properties that control how it looks and 
behaves. An object needs to be selected 
before it is possible to access its properties. 

7 
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WORKING WITH A CONTROL STACK 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When a form is created in Access, bound 
controls used for fields from a table or query are 
often placed into a stack. A stack is simply a way 
of grouping controls together so that they can be 

easily moved, resized and consistently spaced. A 
control is part of a stack when a dotted line appears 
around it and a four-headed arrow appears at the 
top left of the lead control. 

Try This Yourself: 

S
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Continue using the previous 
file with this exercise, or open 
the file Modifying 
Forms_1.accdb... 

 
Open frmEmployees in 
Layout View 

 
Click on EmpNo, click on the 
Form Layout Tools: Arrange 
tab, then click on Select 
Layout in the Rows & 
Columns group to select all 
controls in this control stack 

You can also click on the 
four-headed arrow at the top 
left of the stack… 

 
Press  three times to move 
the stack right three positions 

 
Press  three times to move 
the stack left three positions 

 
Click on Salary to select this 
control 

 
On the Form Layout Tools: 
Arrange tab, click on Select 
Row in the Rows & Columns 
group 

 
Click on Move Down in the 
Move group to move the row 
down below Comments 

 
Press  to delete the row 

 
Save and close the form 

 

2 

For Your Reference… 

To work with a stack: 

1. Click on a control to select it 

2. On the Form Layout Tools: Arrange tab, 
click on Move Down in the Move group to 
move the field in the stack, or 

 Press  to delete the control 

Handy to Know… 

 On a form, when you delete a control from a 
stack, the other controls below will be moved 
up to ensure the stack stays together. 

 When working with a control stack on a form, 
you can click on Move Up (on the Form 
Layout Tools: Arrange tab) to move 
controls up in the stack. 

7 
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CHANGING CONTROL WIDTHS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

When a form is created using the various 
generation tools, the width of the controls is often 
made the same. One of the first tasks when 
modifying a form is to alter the control widths to 

more accurately reflect the data that will appear in 
the control. Control widths are changed by 
dragging their borders, although a degree of 
complexity is added if the control is part of a stack. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the 
file Modifying Forms_2.accdb... 

 
Open frmEmployees in Layout 
View 

 
Click on Kerr to select the 
LastName control 

 
Point to the right border until it 
changes to a double-headed 
arrow, hold down the left mouse 
button, then drag to the left until 
the field (and the stack) is about 
one third of its original size 

 
Release the mouse button to 
complete the resize 

The subform is also resized, but 
we’ll fix that in the next 
exercise… 

 
Right-click on the Comments 
label and select Select Entire 
Row 

 
Right-click on the Comments 
label again, then point to Layout 
and select Remove Layout to 
remove the field from the stack 

 
Click on the blank Comment 
box, then drag the right border 
to the right until the box is about 
twice its size 

 
Save and close the form 

 

3 

For Your Reference… 

To change control widths: 

1. Point to the appropriate border 

2. Click and drag the border to the left or the 
right to resize the control 

4 

Handy to Know… 

 In a form, when you remove selected 
controls from a control stack, they may 
appear obscured by the controls still in the 
stack. While the removed controls are still 
selected, it is best to move them to another 
position – it may be easier to use the arrow 
keys on the keyboard. 

7 



Microsoft Access 2016 - An Introduction 

© 2017 The University of Nottingham Page 125 Chapter 13 - Modifying Forms 

MOVING CONTROLS ON A FORM 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
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F
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 Continue using the previous file 

with this exercise, or open the 
file Modifying Forms_3.accdb... 

 
Open frmEmployees in 
Layout View 

 
Click on the four-headed arrow 
icon at the top left of EmpNo to 
select the control stack 

 
Right-click on any of the 
selected controls, then point to 
Layout and select Remove 
Layout to remove all of the 
controls from the stack 

The four-headed arrow icon 
now disappears… 

 
Click in a blank area to 
deselect all controls, click on 

LastName, then hold down  
and click on Kerr to select both 
objects 

 
Point to the selection until the 
pointer becomes a four-headed 
arrow, then click and drag the 
control into position as shown 

 
Repeat steps 4 and 5 to move 
the other controls as shown 

 
Click on the subform to select 
it, then click and drag the right 
border to align it with the right 
edge of the Comments box 

 
Save and close the form 

 

For Your Reference… 

To move a control: 

1. Click on the control to select it 

2. Point to the control 

3. Hold down the left mouse button and drag 
the control to the desired location 

A control stack manages not only the size of a 
control but also where it is placed relative to the 
other controls. As the name suggests, controls in 
a stack are placed on top of one another. If this 

positioning is not desirable you will need to break 
the stack by removing the controls from it and then 
move those controls to another position on the 
form. 

5 

Handy to Know… 

 To move a control stack on a form, drag the 
four-headed arrow icon to the desired 
location. 

 On a form, selected controls might be easier 
to move using the arrow keys on the 
keyboard. 

6 

7 
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ALIGNING CONTROLS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous file 

with this exercise, or open the 
file Modifying Forms_4.accdb... 

 
Open frmEmployees in Design 
View 

 
Hold down  and click on the 
controls as shown to select them 

 
Click on the Form Design 
Tools: Arrange tab, then click 
on Align in the Sizing & 
Ordering group and select Left 
to align the controls along their 
left edges 

 
Click on FirstName, then hold 

down  and click on the other 
controls in the row, as shown 

 
On the Form Design Tools: 
Arrange tab, click on Align in 
the Sizing & Ordering group, 
then select Bottom to align the 
controls horizontally 

 
Using the above steps, align the 
EmpNo column of labels to the 
left, the LastName column of 
labels to the left, and each 
horizontal row to the bottom  

Use the arrow keys to space 
controls horizontally, if needed… 

 
Save and close the form 

 

For Your Reference… 

To align controls: 

1. Select two or more controls that need to be 
aligned to one another 

2. On the Form Design Tools: Arrange tab, 
click on Align in the Sizing & Ordering 
group then select the appropriate alignment 
option 

Once you start moving controls around a form 
you will realise just how difficult it can be to align 
them again. If you attempt to align controls 
using the mouse and just your eye, you need 

good co-ordination and patience. Fortunately, there 
are a series of Alignment tools on the Arrange tab 
on the ribbon that make aligning controls easy. 

2 

Handy to Know… 

 When aligning controls on a form, if you want 
to align the text within the control use the 
Align Text tools in the Font group on the 
Format tab. 

3 

4 
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UNDERSTANDING PROPERTIES 
 

 

 

 

 

 

Everything on a form, including the form itself, is 
an object and all objects have specific 
properties that can be modified. Some objects 
have only a handful of properties while others 

may have hundreds. Properties of an object control 
the way it looks, the way it behaves, and what it 
actually does. 

Accessing Object Properties 

In Access there are usually multiple ways to achieve the same end result, especially when it comes 
to properties and the way they are accessed. For example, when you change the font in a control 
the most obvious way to do this is to use the commands on the ribbon. However, when you use 
these commands to change the way an object looks or behaves, you are really changing specific 
properties of that object. Rather than searching for the right command, it is often easier to display 
the Property Sheet pane and adjust the settings using the relevant property. 

Understanding the Property Sheet Pane 

The Property Sheet pane displays the properties of the object that is currently selected in the form. 
If no object is selected then the properties of the form itself are displayed. 

The Property Sheet pane consists of five tabs that each display different settings. There are four 
separate tabs (Format, Data, Event, and Other) and a fifth tab which displays the settings from All 
of the tabs: 

 the Format tab displays settings pertaining to the way the control appears (colour, height, 
font, etc.) 

 the Data tab contains settings linking the object to a data source, where relevant (e.g. the 
field in a table) 

 the Event tab contains settings which determine how that object will behave (e.g. when it is 
clicked or changed) 

 the Other tab includes settings that don’t fit into the other 3 tabs. 

The Property Sheet pane contains a wealth of information about the object currently selected. 

Object name 
Object type 

Object property Property setting 
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CHANGING LABEL CAPTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Modifying 
Forms_5.accdb... 

 
Open frmEmployees in 
Layout View 

 
Click on EmpNo, then on the 
Form Layout Tools: Design 
tab, click on Property Sheet in 
the Tools group to display the 
Property Sheet pane 

 
In the Property Sheet pane, 
click on the Format tab, 
double-click on EmpNo in the 
Caption property to select it, 
then type Employee No and 

press  

 
Click on Close in the top right 
corner of the Property Sheet 
pane to close the pane 

You can also edit a caption 
directly... 

 
Click on FirstName, then 
double-click to select the text 

 
Type First Name, then press 

 

 
Change the other captions as 
shown 

 
Save and close the form 

 

For Your Reference… 

To change label captions: 

1. Click on the object to select it 

2. On the Form Layout Tools: Design tab, 
click on Property Sheet in the Tools group, 
then click on the Format tab 

3. Change the text in the Caption property 

Fields from a data source such as a table or 
query are represented by a pair of controls in the 
form – one is a label control which shows the 
caption of the field, and the other is usually a text 

box control which shows the data from the field 
when the report is run or in Layout View. The 
caption in the label is often written in a way that 
may be cryptic or confusing to a user. 

2 3 

6 

Handy to Know… 

 Changing a caption directly on a form is 
probably easier than using the Property 
Sheet pane, if you are renaming several 
captions. The Property Sheet pane might be 
more useful when you want to change 
several properties for a single control. 

7 
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ADDING AN UNBOUND CONTROL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The fields used for data from a table or query are 
referred to as bound controls – they are bound 
(linked) to a data source. Controls that have no 
links to data are known as unbound controls 

and fall into two categories: dynamic and static. A 
static unbound control is one that doesn’t change, 
while a dynamic unbound control is one that is 
usually based on an expression (formula). 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Modifying 
Forms_6.accdb... 

 
Open frmEmployees in 
Design View 

 
Resize the Started 
control, then move the 
Full Time controls to 
make room for a new 
control, as shown 

 
On the Form Design 
Tools: Design tab, click 
on Text Box in the 
Controls group and click 
in the blank area you 
made in step 2 

 
Point to the small dark 
square above the Text 
label until it changes to a 
four-headed arrow, then 
click and drag it to the 
right to move the label 
closer to the Unbound 
control 

 
Align the row of controls 
so that they are neatly 
arranged 

 
Save and close the form 

 

2 

For Your Reference… 

To add an unbound control to a form: 

1. Open the form in Design View 

2. On the Form Design Tools: Design tab, 
choose the desired control from the gallery in 
the Controls group 

3. Click in the form to position the new control 

4 

Handy to Know… 

 Bound controls appear differently in Design 
View compared to the other views – in 
Design View they show the field name 
(which is usually the same as the caption) in 
lieu of a field value. 

5 
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ADDING A CONTROL SOURCE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Modifying 
Forms_7.accdb... 

 
Open frmEmployees in 
Design View 

 
Click on the Unbound control 
to select it 

 
On the Form Design Tools: 
Design tab, click on Property 
Sheet in the Tools group to 
display the Property Sheet 
pane 

 
Click on the Data tab, then 
click in Control Source and 
type the formula as shown – 

press  when finished 

 
Click on the Other tab in the 
Property Sheet pane, then 
double-click on the text in the 
Name property to select it 

 
Type YearsOfService and 

press  

 
Close the Property Sheet 
pane 

 
Save and close the form 

 

For Your Reference… 

To add a control source: 

1. Click on the unbound control 

2. In the Property Sheet pane, click in the 
Control Source property and type an 
appropriate expression (formula) 

Unbound controls can be used to display static 
text, as in the form of a label control which shows 
the caption for a field, or they can be used to 
display dynamic, changing information. In our 

example, we’ll use an unbound form to show the 
length of service of the employee. This will require 
us to enter a formula, known in Access as an 
expression, into the control source property. 

2 

4 

 =Format((Date()-[Started])/365,”#0.0”) 

Handy to Know… 

 A control source expression can use both 
round and square brackets, where the 
square brackets are used to indicate the 
name of an existing field. 

6 
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FORMATTING A CONTROL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Modifying 
Forms_8.accdb... 

 
Open frmEmployees in 
Design View, then click on 
the unbound control 
(YearsOfService) 

 
On the Form Design Tools: 
Design tab, click on Property 
Sheet in the Tools group to 
display the Property Sheet 
pane 

 
Change the properties to: 

Tab Property Setting 
Format Height        0.635cm 
Data Locked Yes 

 
Click on the label control to 
select it 

 
Change the properties to: 

Tab Property Setting 

Format Caption Service 
Format Height
 0.635cm 

 
Close the Property Sheet 
pane, then use the alignment 
tools on the Form Design 
Tools: Arrange tab to align 
the controls as shown 

 
Save and close the form 

 

One of the tasks frequently performed when 
modifying a form is to change the formatting 
properties of specific objects. In our case study, a 
new unbound control has been added to the form 

but it has taken on the default formatting rather 
than that of the existing controls. To make the new 
control resemble the existing controls we will need 
to change some of the properties. 

1 3 

For Your Reference… 

To format a control: 

1. Click on the control to select it 

2. Change the appropriate properties in the 

Property Sheet pane 

Handy to Know… 

 On a form, the Locked property for a text 
box control locks the control from editing and 
ensures that the user can’t change the value 
that appears. 

6 
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CHECKING THE CURRENT TAB ORDER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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e
 

Continue using the previous 
file with this exercise, or 
open the file Modifying 
Forms_9.accdb... 

 
Double-click on 
frmEmployees to run the 
form 

 
Press  three times and 
notice how the selected field 
is now Department – if the 
controls were ordered 
sequentially it should be 
Phone No 

 
Press  slowly until you 
eventually get back to 
Employee No and note the 
non-sequential order in 
which Access moves through 
the fields 

 
Close the form 

 

For faster data entry, many users prefer to press 

the  key to move through the fields on a 
running form. When you use the form generation 
tools in Access, the fields are placed into a 

sequential tab order. If you have modified the form 
by moving field controls around there is a good 
chance that the tab order will be out of sequence. 

1 

For Your Reference… 

To check the tab order of the form: 

1. Run the form 

2. Press  to move through the fields 

Handy to Know… 

 You can press  +  to move 
backwards through the fields on a form. 

 You can use the arrow keys on the keyboard 
to move between fields on a form. 

2 
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CHANGING THE TAB ORDER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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e
 

Continue using the previous 
file with this exercise, or open 
the file Modifying 
Forms_9.accdb... 

 
Open frmEmployees in 
Design View 

 
On the Form Design Tools: 
Design tab click on Tab Order 
in the Tools group, to display 
the Tab Order dialog box 

 
Click on [Auto Order] to 
change the order of the 
controls in sequence with the 
layout on the form 

 
Click on [OK] 

 
Save and close the form 

 
Run the form, then press  
to move through the fields to 
ensure that the tab order is 
correct 

 
Close the form 

 

For Your Reference… 

To change the tab order of a form: 

1. Open the form in Design View 

2. On the Form Design Tools: Design tab, 
click on Tab Order in the Tools group 

3. Click on [Auto Order] 

If the tab order of a form is out of sequence, you 
can change it using the Tab Order dialog box. 
This dialog box allows you to specify the order for 
each tab control by dragging them up or down in 

a list. Alternatively, the dialog box has an [Auto 
Order] button which automatically sets the order to 
the sequence in which the controls appear on the 
form. 

2 

3 

Handy to Know… 

 If you want to specify your own order for the 
controls on a form, in the Tab Order dialog 
box, click on the control in the list and drag it 
to the desired location in the list. 
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INSERTING THE DATE INTO THE FORM HEADER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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e
 

Continue using the previous 
file with this exercise, or open 
the file Modifying 
Forms_10.accdb... 

 
Open frmEmployees in 
Layout View 

 
On the Form Layout Tools: 
Design tab, click on Date and 
Time in the Header/Footer 
group to display the Date and 
Time dialog box 

 
Ensure that both Include Date 
and Include Time are ticked 

 
Click on the middle date format 
and the middle time format to 
select them 

 
Click on [OK] to insert the 
current date and time into the 
top right of the form header 
area 

 
Click on the date to select the 
unbound control, then on the 
Form Layout Tools: Format 
tab, click on Bold in the Font 
group 

 
Save and close the form 

 

The top part of the form is known as the form 
header. It is usually reserved for information 
such as the name and purpose of the form – for 
instance, our case study form shows the title 

Employees. But you can also use this area to insert 
other controls that display information such as the 
date and the time. 

4 

5 

For Your Reference… 

To insert the date and time into the header: 

1. Open the form in Layout View 

2. On the Form Layout Tools: Design tab, 
click on Date and Time in the 
Header/Footer group 

3. Change the settings and click on [OK] 

Handy to Know… 

 The same procedure for adding the date and 
time to a form header can also be used for 

adding a date and time to a report header. 

6 
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CHAPTER 14 CREATING QUERIES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of how queries work 

 learn how to create a new query design 

 learn how to work with a query 

 learn how to modify a query design 

 learn how to apply record criteria for a query 

 learn how to clear selection criteria 

 learn how to save a query 

 learn how to run queries from the Navigation pane 

 learn how to delete a query from a database file 

 gain an understanding of creating additional queries. 

You can easily sort and locate data using table sorting and filtering 
options. However, these are relatively lightweight when compared 
to using queries. 

Queries are sometimes known as Query By Example, or QBE. A 
query is like a report based on the data in a table. With a query you 
are required to specify which fields to see in the query, and which 
records to display. 

This is done by giving Access criteria to search for, much the same 
as what is done for a simple filter. For example, listing all of the 
records that have Sales in the Department field, or all of the 
records that occurred on 12/3/2016, are examples of queries. 

Once the criteria and output fields are nominated, Access will 
search through the data and produce a table of matching records. 

INFOCUS 
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UNDERSTANDING QUERIES 
 

 

 

 

 

   

A select query is like a filter that you place on 
your data so that you see only the information 
that is relevant to you. Select queries can be 
used, for example, to produce a list of customers 

from Tasmania, or all of the items that you've 
purchased in the last six months valued at $300 or 
more. Select queries are so named because they 
select records according to your query design. 

Select queries are created 
using the Create tab of the 
ribbon, and are run and 
modified as a Query object 
in the Navigation pane. 

Select queries are based on 
a Query Design. The upper 
part of the design is known 
as the Field List, while the 
lower portion is known as the 

Query Grid. 

The records displayed in the 
query are determined by the 
sample data that you enter 
into the Criteria row in the 
Query Grid – this is why the 
process is sometimes 
referred to as query by 
example. 

The easiest way to see the 
data is to switch to 
Datasheet view. In 
Datasheet view the data that 
matches the query criteria is 
displayed in a special 
dynaset table. A dynaset is 
a subset of the full table of 
data – however, it is still a 
live set of data and any 
changes made to data here 
will be reflected back in the 
full table later on. 

Field list 

Query grid 

Criteria row 
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CREATING A QUERY DESIGN 
 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Queries are created from the Create tab on the 
ribbon. Like table structures, there is a design 
view where the layout, criteria, and the like, 
required for the query are specified, and a run 

view where the data is brought into the design 
layout structure from the relevant table. The first 
step in creating a query, therefore, is to create a 
query design structure. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 

Before starting this 
exercise you MUST open 
the file Creating 
Queries_1.accdb… 

 
Click on the Create tab, 
then click on Query 
Design in the Queries 
group to display a new 
query design and the 
Show Table dialog box 

 
Click on [Add] to add the 
Employees table fields to 
the design, then click on 
[Close] to close the dialog 
box 

 
In the field listing 
double-click on EmpNo, 
LastName, FirstName 
and Department to add 
these fields to the grid in 
this order 

 
Click on Save in the QAT 
to display the Save As 
dialog box 

 
Type qryEmployees in 
Query Name, then click 
on [OK] 

The name of the query will 
now appear in the 
Navigation pane under the 
Queries header… 

 
Close the query 

 

1 

2 

For Your Reference… 

To create a query design: 

1. Click on the Create tab 

2. Click on Query Design in the Queries group 

3. Add the table and select the fields 

4. Save the query 

3 

Handy to Know… 

 The Show Table dialog box, displayed when 
creating a new query design, lists all of the 
tables and queries in the current database 
file. 

Double-click on the entries here to add them to the 
table below 
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WORKING WITH A QUERY 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Queries offer you the ability to see snapshots of 
your data – a particular view or representation of 
your data at a point in time. There are three main 
views within a query: the design view where you 

specify what data you wish to see in the snapshot; 
the datasheet view where the data based on the 
design is displayed; and SQL view which shows 
the programming behind the query. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Queries_2.accdb... 

 
Double-click on 
qryEmployees to see 
the query in Datasheet 
view, displaying the data 

 
On the Home tab, click 
on the top half of View 
in the Views group to 
toggle between Design 
and Datasheet views 

 
Click on the bottom half 
of View to display a 
menu of options 

 
Select SQL View to see 
the SQL code required 
behind the scenes to 
create the query 

 
Close the query 

 

1 

For Your Reference… 

To see different aspects of a query: 

1. Double-click on the query to see it in 
Datasheet view 

2. On the Home tab, click on the top half of 
View in the Views group to toggle between 
Design and Datasheet views 

3 

Handy to Know… 

 Until you seriously get into programming, you 
won't use the SQL View option for queries all 
that often. SQL is pronounced "sequel" or 
simply S.Q.L. 

4 
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CHANGING A QUERY DESIGN 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Most query designs are not as critical as table 
designs and can therefore be changed randomly 
and when the need arises. Select queries, 
where you are trying to extract matching data, 

are often run using a trial and error approach where 
the query design is experimented with and modified 
until the perfect solution is found.  

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Creating 
Queries_3.accdb... 

 
In the Navigation pane, 
right-click on 
qryEmployees to display a 
menu of options, then select 
Design View to see the 
query in Design view 

 
Scroll down the list of fields 
in the Employee field listing 
and double-click on 
WeeklyHours and then 
Salary to place both fields 
at the end of the grid 

 
Click on WeeklyHours in 
the grid then, on the Query 
Tools: Design tab, click on 
Insert Columns in the 
Query Setup group 

A new, blank column will 
appear… 

 
Click on the drop arrow in 
the new column and select 
Started 

 
Click on the Home tab, then 
click on the top half of View 
in the Views group to run 
the query and see the data 
presented in the modified 
design 

 
Click on Save in the QAT, 
then close the query 

 

2 

4 

For Your Reference… 

To insert more fields into a Design grid: 

 Double-click on the field name in the field 
listing, or 

 Click in the grid, then click on Insert 

Columns in the Query Setup group 

Handy to Know… 

 You can delete a field from a query grid by 
clicking on it and then clicking on Delete 
Columns in the Query Setup group on the 
Home tab. 

5 
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APPLYING RECORD CRITERIA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

The real power of a query lies in its ability to 
display a filtered list of records in a dynaset. To 
filter the records and see only the ones that you 
want, you will need to enter search criteria in the 

criteria row in the query grid. You simply type an 
example of the data that you want to see in the 
criteria cell and run the query to display all records 
from the original table that match the criteria. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or 
open the file Creating 
Queries_4.accdb... 

 
Right-click on 
qryEmployees to display a 
menu of options and select 
Design View 

 
Click in the Criteria cell for 
Department and type 
Administration 

 
On the Query Tools: 
Design tab, click on the top 
half of View in the Views 
group to see only those 
records with 
Administration in the 
Department field 

 
Repeat step 3 to switch 
back to Design view 

 
Type 40 in the Criteria cell 
for WeeklyHours, then click 
on View to display only 
those people who work 40 
hours in the 
Administration department 

 
Switch to Design view and 
type >=80000 in the 
Criteria cell for Salary, then 
click on View to see all 
Administration people who 
work 40 hours and earn 
$80,000 or more 

 
Save and close the query 

2 

3 

For Your Reference… 

To select records in a query: 

1. Click in the Criteria cell for a field and type 
the desired search criteria 

2. On the Query Tools:Design tab, click on 
View in the Views group to run the query 

Handy to Know… 

 When creating queries, if you add more 
criteria across fields, you are creating what is 
known as an AND query – you want records 
that have this AND this AND this... 

 When constructing queries, use > for greater 

than and < for less than situations. 

6 
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CLEARING SELECTION CRITERIA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You do need to exercise a little care when 
running queries. If you leave residual criteria from 
an earlier query in the query grid (which is easy 
to do if you have more fields than can be seen on 

the screen), you may end up with incorrect results. 
It is a good idea therefore to clear the selection 
criteria after you have performed a query and found 
the data that you want. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Queries_5.accdb... 

 
In the Navigation pane, 
right-click on 
qryEmployees to display a 
menu of options and select 
Design View 

 
Point to the left of the first 
criteria cell until the mouse 
pointer changes to a black 
horizontal arrow  

 
Click once to select the 
entire criteria row 

 
Press  to delete all of 
the criteria in the row 

 
Save and close the query 

 

2 

For Your Reference… 

To clear selection criteria: 

1. Point to the left of the row and click once to 
select it 

2. Press  to delete the criteria in the row 

3 

Handy to Know… 

 When working with a query design, you can 
delete the contents of a single cell in the 
Criteria row by double-clicking on the value 

in the cell and pressing . 

4 
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SAVING A QUERY 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are two main types of select queries: those 
that you create as a one-off search of the data; 
and those that you create for repeated and 
on-going use. If you are going to use a query on 

a regular basis it should be saved. You can then 
also use it as a template to create other queries 
with variations perhaps to the criteria or the field 
grid. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the previous 
file with this exercise, or open 
the file Creating 
Queries_6.accdb... 

 
Right-click on qryEmployees 
to display a menu of options 
and select Design View 

 
Type Administration in the 
Criteria cell for Department 

 
On the Query Tools: Design 
tab, click on View in the Views 
group to see the results – 
there should be 26 records 

 
Click on the File tab, then click 
on Save As to display the 
Save As area 

 
Click on Save Object As in 
File Types, then click on 
[Save As] to display the Save 
As dialog box 

 
Type qryEmployeesAdmin 
and click on [OK] 

The new query appears in the 
Navigation bar… 

 
Switch to Design view then 
repeat steps 2 to 6 to create 
another query that only 
displays employees from the 
Executive department – save 
this query as 
qryEmployeesExec 

 
Close the query 

 

3 

5 

7 

For Your Reference… 

To save a query: 

1. Create the query 

2. On the File tab, click on Save As, then click 
on Save Object As and click on [Save As] 

3. Type a name and click on [OK] 

Handy to Know… 

 It is important to give your queries 
meaningful names so that you remember 
what they are for. Using a prefix, such as 
qry, will tell you at a glance that you are 
looking at a list of queries and make the 
queries easier to distinguish from tables, 
forms and reports. 
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RUNNING QUERIES FROM THE NAVIGATION PANE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                   , 

Queries store the layout, fields, criteria and other 
information required to produce the list of data 
that you want. Given that they can be time 
consuming to create, especially in the case of 

complex queries, it makes sense to save them and 
then run them as often as you require. Queries can 
be run directly from the object listing in the 
Navigation pane, as often as you like. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the file 
Creating 
Queries_7.accdb... 

 
In the Navigation pane 
under Queries, 
double-click on 
qryEmployees, then 
double-click on 
qryEmployeesAdmin, 
then double-click on 
qryEmployeesExec 

Notice how the names of 
the three queries appear 
in three separate tabs at 
the top of the window. 
The last query opened is 
the one that is currently 
seen and is known as the 
“active” query… 

 
Click on the tab for 
qryEmployeesAdmin to 
see the employees in the 
Administration 
department 

 
Click on the tab for 
qryEmployees to see all 
of the employees 

 
Close each query 

 

1 

2 

For Your Reference… 

To run a query from the Navigation pane: 

 In the Navigation pane, double-click on the 

name of the query from the Query object list 

Handy to Know… 

 Queries do not contain data. Each time a 
query is opened in Datasheet view, Access 
retrieves the latest data from the table upon 
which the query is based and uses the query 
design to display the relevant records and 
information. 

3 
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DELETING A QUERY 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Queries often work with data that is stored in 
tables or that results from other queries. They 
can be used to create data by performing 
calculations and can be used as a source of data 

for other queries, forms and reports. Therefore, you 
should be especially careful when deleting queries 
– make sure that the query is not used by any other 
objects in the database first. 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file Creating 
Queries_7.accdb... 

 
Click on 
qryEmployeesExec in 
the Navigation pane 
to select it 

 
On the Home tab, click 
on Delete in the 
Records group 

A warning message 
will appear, seeking 
your confirmation to 
delete the query… 

 
Click on [Yes] to 
confirm the deletion 

The query no longer 
appears listed under 
Queries in the 
Navigation pane 

 

1 

2 

3 

For Your Reference… 

To delete a query from a database file: 

1. Click on the name of the query in the 
Navigation pane 

2. On the Home tab, click on Delete in the 
Records group 

Handy to Know… 

 You can delete a query by clicking on it in the 

Navigation pane and pressing . 
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CREATING ADDITIONAL QUERIES 
 

 

 

 

  

 

Select queries are by far the most common type 
of query that you will create and use. In this 
assignment you will have the opportunity to put 
your understanding of queries to use by creating 

a wide range of different queries, including those 
that show records that match specific criteria, and 
those that fit within specific ranges of dates. 
 

Sub Heading 

Use the qryEmployees query to run the various queries as shown. Note that you will have to clear the 
criteria from time to time. Also, we won’t need these queries so there is no need to save them. 

Save the final query design as qryEmployeesNew then close it. 

The datasheet that shows the results is exactly like a table and you can therefore use the Print 
commands on the File tab to print the result once the datasheet is displayed. 

Access automatically places quotation marks around criteria based on text. The quotation marks are 
programming symbols that tell the computer to treat the data as character strings rather than numbers. 
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NOTES: 
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CHAPTER 15 CREATING AND USING REPORTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of the reporting process in Access 

 learn how to create a basic report 

 learn how to work with reports and switch between the 
various views 

 learn how to preview and print a report 

 learn how to change the layout of a report 

 learn how to use the Report Wizard to create a report 

 learn how to use the Report Wizard to create a grouped 
report 

 learn how to use the Report Wizard to create a statistical 
report 

 learn how to work with grouped reports. 

Reports in Access provide a way of formally presenting data from 
either tables or queries. In essence, reports are used to present raw 
data in a format that is more readable, understandable and better to 
look at. 

INFOCUS 
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UNDERSTANDING REPORTING IN ACCESS 
 

 

 

 

 

 

Reports provide you with a means of more 
formally presenting, and even analysing, data 
from your tables and queries. Reports have 
traditionally been produced as printed documents 

but they can also be viewed on the screen or 
published to the web. Before creating a report, it is 
advisable to understand how they work and what 
they can actually do for you. 

Creating Reports 

All database systems, including Access, provide you with a report generator facility to design your 
reports. Reports themselves do not contain data, but are created as structural templates into which 
the data is placed when the report is run. The template basically defines what to display (e.g. which 
fields to use), where to display it (e.g. where the fields should appear on the page), and how it should 
look (e.g. font size, colour, etc). 

When a report is first created it is based on either an existing table or an existing query. You base the 
report on a table if you wish to report on all of the data, or a query if you wish to report on just a 
subset of the data. 

The Many Ways of Creating a Report 

In Access you can create simple reports or very complex and intricate reports. So, as you’d expect, 
Access offers several ways for you to create reports. In Access, reports are created from the tools on 
the Create tab on the ribbon. Here you can create: 

 A basic, no frills report using the Report tool – these reports appear almost instantly and 
require very little work on your part. All of the work is done for you. 

 More intricate reports using the Report Wizard tool – the Report Wizard metaphorically holds 
your hand and asks you a series of questions which ultimately, when answered, result in a 
report. 

 A complex, elaborate report using either the Blank Report tool or the Report Design tool – 
these options present you with a blank report canvas and you are required to do all of the work 
to lay out what you want, where you want it, and how it should look. This is the most difficult of 
the options to use as you have to do everything yourself. 

Achieving a Balance 

There is no right or wrong way to create reports – choose the method that achieves the results using 
the least amount of time and effort. 

The beauty of the reporting tools in Access is that even after you have created a report using any of 
the techniques, the report can still be edited, modified and customised to suit specifically what you are 
after. So even if the basic report doesn’t quite provide you with what you want or the Report Wizard 
hasn’t quite done all it should, you can still change the report design yourself. 

Many Access users create their reports using the Report tool or the Report Wizard tool, and then 
fine-tune the layout or the design to suit their needs. 
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CREATING A BASIC REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The easiest and simplest way to create a basic 
report in Access is to use the Report tool which 
is located on the Create tab on the ribbon. All 
you need to do here is to select the table or the 

query in the Navigation pane as the basis for the 
report and then run the command. 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
Reports_1.accdb… 

 
In the Navigation pane, click 
on the Employees table to 
select it 

This indicates the table to 
base the report on… 

 
Click on the Create tab, then 
click on Report in the 
Reports group 

A report layout will instantly 
appear. The Layout View of 
the report allows you to make 
adjustments to the report 
template… 

 
On the Report Layout Tools: 
Design tab, click on View in 
the Views group to see the 
report in Report View where 
the data is presented 

Data is presented in Layout 
View as well, but Report View 
is the finished view of the 
report… 

 
Click on Save in the QAT to 
display the Save As dialog 
box 

 
Type rptEmployees in 
Report Name, then click on 
[OK] to save the design and 
layout 

 
Close the report 

 

2 

For Your Reference… 

To create a basic report: 

1. Click on the table or query in the Navigation 
pane 

2. Click on the Create tab, then click on Report 
in the Reports group 

3 

Handy to Know… 

 When creating reports, Layout view allows 
you to make changes to the layout of a 
report, such as column widths, row heights, 
field placement etc. Report view is the 
polished view of the report. 

5 
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WORKING WITH EXISTING REPORTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Reports do not contain data – they are simply 
templates with field placeholders which 
determine where data will be placed. As a 
consequence there are several different views of 

a report – you can see its structure in both the 
Design and Layout views, and you can see data in 
Report, Print Preview and Layout views. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Reports_2.accdb... 

 
Double-click on the report 
rptEmployees to open it 

Report view shows you 
the report with data. No 
changes can be made to 
either the data or the 
report layout here… 

 
On the Home tab, click on 
View in the Views group 
to see the report in Layout 
view where changes can 
be made 

The View tool toggles 
between Layout and 
Report views… 

 
Click on the bottom half of 
View and select Design 
View 

Design view is the ultimate 
design and layout view 
where you can edit the 
fields, placements and 
even formats, and also 
make changes to report 
headers and footers… 

 
Close the report 

 

1 

For Your Reference… 

To change the report view: 

1. Open the report in any view 

2. On the Home tab, click on the bottom half of 
View in the Views group and select the 
desired view 

Handy to Know… 

 Changes to report structure are made in 
either Layout or Design view. Layout view 
provides a view of the report with data in 
place. Design view provides access to more 
of the detailed areas of the report such as 
the header and footer. 

3 
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PREVIEWING AND PRINTING A REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file Reports_2.accdb... 

 
Right-click on rptEmployees 
and select Print Preview to 
see the report in preview mode 

 
Click on Next Page and 
Previous Page at the bottom 
of the window several times to 
view the pages 

The report is too wide to fit on 
one piece of paper… 

 
On the Print Preview tab, click 
on Landscape in the Page 
Layout group to turn the report 
sideways 

We still haven’t got all columns 
on one page, but let’s print just 
the first page to see how it 
looks… 

 
Click on Print in the Print 
group to display the Print 
dialog box 

 
Click on Pages in Print Range 
and type 1 in both From and 
To 

 
Click on [OK] to print the first 
page of the report 

 
Close the report 

 

Reports are commonly designed for and printed 
on paper using a printer. While you can print a 
report without directly running it, it is a good idea 
to use Print Preview to see how it will look 

before it is sent to the printer. Often you will find 
that the report is too wide or needs to be changed 
in some other way prior to a formal print run. 

1 

5 

For Your Reference… 

To preview and print a report: 

1. Right-click on the report in the Navigation 
pane and select Print Preview to see the 
report in preview mode 

2. On the Print Preview tab, click on Print in 
the Print group to print the report 

Handy to Know… 

 Basic reports seldom print well without a bit 
of editing. Typically there may be too many 
columns or rows to fit neatly on a page. 
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CHANGING THE REPORT LAYOUT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Layout view provided for reports in Access 
allows you to make adjustments to the layout of 
the report. These adjustments may be required 
for aesthetic purposes, to make the report more 

visually appealing, or for practical purposes such 
as trying to squeeze the report onto one page. In 
Layout view you can adjust column widths and 
instantly see whether they will work or not. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file Reports_3.accdb... 

 
Right-click on rptEmployees 
and select Layout View 

 
Point to the right border of the 
orange square surrounding 
Emp No 101 

The pointer should change to a 
double-headed arrow… 

 
Hold down the left mouse 
button and drag the border left 
to make the column narrower 

 
Click in the FirstName column, 
then repeat steps 2 and 3 to 
make this column narrower 

 
On the Report Layout Tools: 
Design tab, click on the bottom 
half of View in the Views 
group, select Print Preview, 
then click on One Page in the 
Zoom group to see if the 
Comments fit on the page  

 
Click on Close Print Preview 
in the Close Preview group, 
then repeat steps 2 and 3 with 
the other columns, until the 
Comments column is on the 
page 

 
Save and close the report 

 

2 

3 

For Your Reference… 

To adjust column width in a report: 

1. Open the report in Layout view 

2. Click in the column to change 

3. Point to the right border of the orange 
square, hold down the left mouse button and 
drag left to narrow the column 

Handy to Know… 

 The grey dotted lines that appear in Layout 
view of a report indicate whether the page 
will break when printed. These dotted lines 
are based on the current printer settings on 
your computer and are very useful when 
trying to resize a page of the report. 

6 
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USING THE REPORT WIZARD 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Report Wizard will guide you through the 
process of creating more formal reports from the 
data in your data table. The Report Wizard 
consists of a number of screens that prompt you 

for the information required to generate a report. 
Some of the screens may seem cryptic to begin 
with, but you will soon learn what is required and 
be able to generate reports quickly and efficiently. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file Reports_4.accdb... 

 
In the Navigation pane, click 
on the Employees table to 
specify the table to report on 

 
Click on the Create tab, then 
click on Report Wizard in the 
Reports group to start the 
Report Wizard 

 
Double-click on EmpNo, 
FirstName, LastName, 
Department and PhoneNo in 
Available Fields to add them 
to the Selected Fields list 

 
Click on [Next] to proceed to 
the next screen. Continue 
working through the screens 
using the settings as shown 

 
Once you have specified the 
title in the last screen of the 
wizard, click on Preview the 
report, then click on [Finish] 
to build the report 

Spend a moment previewing 
the report… 

 
Close the report 

The new report is now listed in 
the Navigation pane 

 

2 

3 

4 

For Your Reference… 

To create a report using the Report Wizard: 

1. Click on the table or query 

2. Click on the Create tab, then click on Report 
Wizard in the Reports group 

3. Complete the steps of the Wizard 

Screen Settings Click on… 

Grouping No change [Next] 

Sort Order 1. LastName, Ascending [Next] 

Layout Tabular & Portrait [Next] 

Title Employee Phone Listing  

 

Handy to Know… 

 When creating a report using the Report 
Wizard, if you have made a mistake in any of 
the screens or would simply like to review 
your work, click on [Back] to move back 
through previous screens. 

2 3 
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CREATING A GROUPED REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

By creating a grouped report you can present 
data so that it is grouped according to one or 
more fields. For example, if you create a grouped 
report listing all employees by department, the 

departments will be listed in alphabetical order and 
the employees will be listed in alphabetical order 
within each department. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Reports_5.accdb... 

 
In the Navigation pane, 
click on the Employees 
table 

 
Click on the Create tab, 
then click on Report 
Wizard in the Reports 
group to start the Wizard 

 
Double-click on 
Department, EmpNo, 
LastName, FirstName, 
Started and Salary, then 
click on [Next] 

In this screen you are 
required to specify how to 
group the records… 

 
Double-click on 
Department as the 
grouping level 

 
Click on [Next] and 
complete the remaining 
wizard screens as shown 

 
Click on [Finish] to build 
the report 

 
Close the report 

 

4 

5 Screen Settings Click on… 

Sort Order 1. LastName, Ascending [Next] 

Layout Stepped & Portrait [Next] 

Title Employee Salary Listing  

 

For Your Reference… 

To create a grouped report: 

1. Click on the Create tab, click on Report 
Wizard and create a report, selecting the 
field to be grouped on as the first field 

2. Select this field on the Grouping screen 

3. Complete the wizard and save the report 

6 

Handy to Know… 

 When creating a grouped report, you may 
find that you need to make minor 
adjustments to column widths in Layout 
View to be able to see all of the grouping 
column. 
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CREATING A STATISTICAL REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

One great feature of reports is the ability to 
summarise the data in the database. For 
example, reports allow you to calculate the total 
(sum), minimum, maximum, average, and 

number of records (count) for numerical fields in a 
database. You can also count non-numerical fields. 
These statistical reports assist with analysis of 
the data in the database. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file Reports_6.accdb... 

 
In the Navigation pane, click 
on the Employees table, click 
on the Create tab and click on 
Report Wizard in the Reports 
group 

 
Double-click on Department 
and Salary, then click on 
[Next] 

 
Double-click on Department 
as the Grouping level, then 
click on [Next] 

 
Click on [Summary Options] 
to display the Summary 
Options dialog box 

 
Click in the tick boxes for Sum, 
Avg, Min and Max, then click 
on Summary Only in Show 

 
Click on [OK] to return to the 
Wizard, then click on [Next] 
and complete the settings as 
shown 

 
Click on [Finish] to build the 
report 

We will fix the hash signs in 
the next exercise… 

 
Close the report 

 

4 

Screen Settings Click on… 

Layout Stepped & Portrait [Next] 

Title Salary Analysis Report  

 

6 

For Your Reference… 

To create a statistical summary report: 

1. Create a grouped report using the wizard 

2. Click on [Summary Options] on the sorting 
screen 

3. Click on the statistics required then click on 

[OK] and finish creating the report 

Handy to Know… 

 When a report displays hash signs (####) in 
lieu of numbers, it is because the column 
size in the report isn’t large enough to display 
the values in the fields. 

7 
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WORKING WITH GROUPED REPORTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0  

If a column is not wide enough to display values, 
Access will substitute the values with cryptic 
signs like the hash (#) symbol. This can happen 
when using the statistical functions (sum, avg, 

etc.) on the values that involve many numbers, 
such as currency. To correct this problem you will 
need to access either Layout View or Design 
View and modify the column widths. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Reports_7.accdb... 

 
In the Navigation pane, 
double-click on Salary 
Analysis Report to run it 

Here you can see the hash 
signs replacing numbers… 

 
Switch to Design View 

 
In Department Footer, 
click on =Sum([Sal, hold 

down  and click on 
=Avg([Sal, =Min([Sal, 
=Max([Sal and =Sum([Sal 
(in Report Footer) 

You should have selected 
five fields… 

 
Point to the left border of 
one of the selected fields, 
click and drag to the left 
until the fields are about 3 
times as long 

 
Click on the Home tab, 
click on the bottom half of 
View in the Views group, 
then select Report View to 
run the report – this time 
the values are displayed 

 
Save and close the report 

 

3 

5 

For Your Reference… 

To modify the layout of a grouped report: 

1. Open the report in either Report Layout or 
Report Design view 

2. Make the changes to the layout as required 

Handy to Know… 

 You can adjust field widths either through 
Report Design view or in Report Layout 
view. However, =Sum (that sums the footer) 
is easier to access in Report Design view. 
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CONCLUDING REMARKS 

 

 

 

 

 

 

 

 

Congratulations!  

You have now completed Microsoft Access 2016 - An Introduction. Microsoft Access 2016 - An 
Introduction was designed to get you to the point where you can competently perform a variety of 
operations.  

We have tried to build up your skills and knowledge by having you work through specific tasks. 
The step by step approach will serve as a reference for you when you need to repeat a task. 

 

Where To From Here? 

The following is a little advice about what to do next: 

 Spend some time playing with what you have learnt. You should reinforce the skills that you 
have acquired and use some of the application's commands. This will test just how much of 
the concepts and features have stuck! Don't try a big task just yet if you can avoid it - small 
is a good way to start. 

 Some aspects of the course may now be a little vague. Go over some of the points that you 
may be unclear about. Use the examples and exercises in these notes and have another go 
- these step-by-step notes were designed to help you in the classroom and in the work 
place! 

Here are a few techniques and strategies that we've found handy for learning more about 
technology: 

 read computer magazines - there are often useful articles about specific techniques 

 if you have the skills and facilities browse the Internet, specifically the technical pages of 
the application that you have just learnt 

 take an interest in what your work colleagues have done and how they did it - we don't 
suggest that you plagiarise but you can certainly learn from the techniques of others 

 if your software came with a manual (which is rare nowadays) spend a bit of time each day 
reading a few pages. Then try the techniques out straight away - over a period of time 
you'll learn a lot this way 

 and of course, there are also more courses and books for you to work through. 

Hungry for More? 

We live in an ever-changing world where we all need to review and upgrade our 
skills. 

If you have received this course book on a training course why not ask the tutor or 
trainer for other courses that may be of benefit to you. If you are attending a 
college ask for one of their brochures. 

Alternatively, if you’ve enjoyed using this course book you can find others that 
cover a wide range of topics at our web site www.watsoniapublishing.com. 

 

http://www.watsoniapublishing.com/
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